summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/lighttpd/ChangeLog15
-rw-r--r--www-servers/lighttpd/files/1.4.20/03_all_lighttpd-1.4.11-errorlog-pipe.diff175
-rw-r--r--www-servers/lighttpd/files/1.4.22-r1/03_all_lighttpd-1.4.11-errorlog-pipe.diff164
-rw-r--r--www-servers/lighttpd/files/1.4.25-fix-unknown-AM_SILENT_RULES.patch18
-rw-r--r--www-servers/lighttpd/files/lighttpd-1.4.24-mod_magnet-fix-pairs.patch15
-rw-r--r--www-servers/lighttpd/files/lighttpd-1.4.24-mod_rewrite-without-pcre.patch232
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.20.ebuild214
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.22-r1.ebuild205
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.25.ebuild (renamed from www-servers/lighttpd/lighttpd-1.4.24.ebuild)6
9 files changed, 35 insertions, 1009 deletions
diff --git a/www-servers/lighttpd/ChangeLog b/www-servers/lighttpd/ChangeLog
index 440b313ea06c..fa12760e2162 100644
--- a/www-servers/lighttpd/ChangeLog
+++ b/www-servers/lighttpd/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for www-servers/lighttpd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.211 2009/11/05 18:19:29 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.212 2009/11/25 09:59:17 bangert Exp $
+
+*lighttpd-1.4.25 (25 Nov 2009)
+
+ 25 Nov 2009; Thilo Bangert <bangert@gentoo.org>
+ +files/1.4.25-fix-unknown-AM_SILENT_RULES.patch,
+ -files/1.4.20/03_all_lighttpd-1.4.11-errorlog-pipe.diff,
+ -files/1.4.22-r1/03_all_lighttpd-1.4.11-errorlog-pipe.diff,
+ -lighttpd-1.4.20.ebuild, -lighttpd-1.4.22-r1.ebuild,
+ -lighttpd-1.4.24.ebuild,
+ -files/lighttpd-1.4.24-mod_magnet-fix-pairs.patch,
+ -files/lighttpd-1.4.24-mod_rewrite-without-pcre.patch,
+ +lighttpd-1.4.25.ebuild:
+ version bump - remove old versions
05 Nov 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
lighttpd-1.4.24.ebuild,
diff --git a/www-servers/lighttpd/files/1.4.20/03_all_lighttpd-1.4.11-errorlog-pipe.diff b/www-servers/lighttpd/files/1.4.20/03_all_lighttpd-1.4.11-errorlog-pipe.diff
deleted file mode 100644
index 5133fea95283..000000000000
--- a/www-servers/lighttpd/files/1.4.20/03_all_lighttpd-1.4.11-errorlog-pipe.diff
+++ /dev/null
@@ -1,175 +0,0 @@
-Initial patch from http://trac.lighttpd.net/trac/ticket/296
-Updated to apply against 1.4.20 by hoffie
-Upstream will only accept it once it has been changed to make the pipe logging more generic
-
-diff -r 447bac6969ef src/base.h
---- a/src/base.h Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/base.h Tue Aug 19 19:45:00 2008 +0200
-@@ -530,7 +530,7 @@
-
- /* the errorlog */
- int errorlog_fd;
-- enum { ERRORLOG_STDERR, ERRORLOG_FILE, ERRORLOG_SYSLOG } errorlog_mode;
-+ enum { ERRORLOG_STDERR, ERRORLOG_FILE, ERRORLOG_SYSLOG, ERRORLOG_PIPE } errorlog_mode;
- buffer *errorlog_buf;
-
- fdevents *ev, *ev_ins;
-diff -r 447bac6969ef src/log.c
---- a/src/log.c Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/log.c Tue Aug 19 19:45:00 2008 +0200
-@@ -57,10 +57,11 @@
- /**
- * open the errorlog
- *
-- * we have 3 possibilities:
-+ * we have 4 possibilities:
- * - stderr (default)
- * - syslog
- * - logfile
-+ * - pipe
- *
- * if the open failed, report to the user and die
- *
-@@ -79,21 +80,80 @@
- srv->errorlog_mode = ERRORLOG_SYSLOG;
- } else if (!buffer_is_empty(srv->srvconf.errorlog_file)) {
- const char *logfile = srv->srvconf.errorlog_file->ptr;
-+ if (logfile[0] == '|') {
-+#ifdef HAVE_FORK
-+ /* create write pipe and spawn process */
-
-- if (-1 == (srv->errorlog_fd = open(logfile, O_APPEND | O_WRONLY | O_CREAT | O_LARGEFILE, 0644))) {
-- log_error_write(srv, __FILE__, __LINE__, "SSSS",
-+ int to_log_fds[2];
-+ int fd;
-+ pid_t pid;
-+
-+ if (pipe(to_log_fds)) {
-+ log_error_write(srv, __FILE__, __LINE__, "ss",
-+ "pipe failed: ", strerror(errno));
-+ return -1;
-+ }
-+
-+ /* fork, execve */
-+ switch (pid = fork()) {
-+ case 0:
-+ /* child */
-+
-+ close(STDIN_FILENO);
-+ dup2(to_log_fds[0], STDIN_FILENO);
-+ close(to_log_fds[0]);
-+ /* not needed */
-+ close(to_log_fds[1]);
-+
-+ /* we don't need the client socket */
-+ for (fd = 3; fd < 256; fd++) {
-+ close(fd);
-+ }
-+
-+ /* exec the log-process (skip the | )
-+ *
-+ */
-+
-+ execl("/bin/sh", "sh", "-c", logfile + 1, NULL);
-+
-+ log_error_write(srv, __FILE__, __LINE__, "sss",
-+ "spawning log-process failed: ",
-+ strerror(errno), logfile + 1);
-+
-+ exit(-1);
-+ break;
-+ case -1:
-+ /* error */
-+ log_error_write(srv, __FILE__, __LINE__, "ss", "fork failed:", strerror(errno));
-+ break;
-+ default:
-+ close(to_log_fds[0]);
-+
-+ srv->errorlog_fd = to_log_fds[1];
-+
-+ break;
-+ }
-+ srv->errorlog_mode = ERRORLOG_PIPE;
-+#else
-+ log_error_write(srv, __FILE__, __LINE__, "SSS",
-+ "opening errorlog '", logfile,"' impossible");
-+ return -1;
-+#endif
-+ } else {
-+ if (-1 == (srv->errorlog_fd = open(logfile, O_APPEND | O_WRONLY | O_CREAT | O_LARGEFILE, 0644))) {
-+ log_error_write(srv, __FILE__, __LINE__, "SSSS",
- "opening errorlog '", logfile,
- "' failed: ", strerror(errno));
-
-- return -1;
-+ return -1;
-+ }
-+ srv->errorlog_mode = ERRORLOG_FILE;
- }
- #ifdef FD_CLOEXEC
- /* close fd on exec (cgi) */
- fcntl(srv->errorlog_fd, F_SETFD, FD_CLOEXEC);
- #endif
-- srv->errorlog_mode = ERRORLOG_FILE;
- }
--
- log_error_write(srv, __FILE__, __LINE__, "s", "server started");
-
- #ifdef HAVE_VALGRIND_VALGRIND_H
-@@ -122,7 +182,7 @@
- */
-
- int log_error_cycle(server *srv) {
-- /* only cycle if we are not in syslog-mode */
-+ /* only cycle if the error log is a file */
-
- if (srv->errorlog_mode == ERRORLOG_FILE) {
- const char *logfile = srv->srvconf.errorlog_file->ptr;
-@@ -154,6 +214,7 @@
-
- int log_error_close(server *srv) {
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE: /* fall through */
- case ERRORLOG_FILE:
- close(srv->errorlog_fd);
- break;
-@@ -173,6 +234,7 @@
- va_list ap;
-
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE:
- case ERRORLOG_FILE:
- case ERRORLOG_STDERR:
- /* cache the generated timestamp */
-@@ -257,6 +319,7 @@
- va_end(ap);
-
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE: /* fall through */
- case ERRORLOG_FILE:
- buffer_append_string_len(srv->errorlog_buf, CONST_STR_LEN("\n"));
- write(srv->errorlog_fd, srv->errorlog_buf->ptr, srv->errorlog_buf->used - 1);
-diff -r 447bac6969ef src/mod_cgi.c
---- a/src/mod_cgi.c Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/mod_cgi.c Tue Aug 19 19:45:00 2008 +0200
-@@ -781,7 +781,7 @@
- *
- * we feed the stderr of the CGI to our errorlog, if possible
- */
-- if (srv->errorlog_mode == ERRORLOG_FILE) {
-+ if ((srv->errorlog_mode == ERRORLOG_FILE) || (srv->errorlog_mode == ERRORLOG_PIPE)) {
- close(STDERR_FILENO);
- dup2(srv->errorlog_fd, STDERR_FILENO);
- }
-diff -r 447bac6969ef src/mod_rrdtool.c
---- a/src/mod_rrdtool.c Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/mod_rrdtool.c Tue Aug 19 19:45:00 2008 +0200
-@@ -134,7 +134,7 @@
-
- close(STDERR_FILENO);
-
-- if (srv->errorlog_mode == ERRORLOG_FILE) {
-+ if ((srv->errorlog_mode == ERRORLOG_FILE) || (srv->errorlog_mode == ERRORLOG_PIPE)) {
- dup2(srv->errorlog_fd, STDERR_FILENO);
- close(srv->errorlog_fd);
- }
diff --git a/www-servers/lighttpd/files/1.4.22-r1/03_all_lighttpd-1.4.11-errorlog-pipe.diff b/www-servers/lighttpd/files/1.4.22-r1/03_all_lighttpd-1.4.11-errorlog-pipe.diff
deleted file mode 100644
index 0ee3049b2572..000000000000
--- a/www-servers/lighttpd/files/1.4.22-r1/03_all_lighttpd-1.4.11-errorlog-pipe.diff
+++ /dev/null
@@ -1,164 +0,0 @@
-Initial patch from http://redmine.lighttpd.net/issues/296
-Updated to apply against 1.4.20 by hoffie
-Updated to apply against 1.4.22 by bangert
-Upstream will only accept it once it has been changed to make the pipe logging more generic
-
-diff -r 447bac6969ef src/base.h
---- a/src/base.h Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/base.h Tue Aug 19 19:45:00 2008 +0200
-@@ -530,7 +530,7 @@
-
- /* the errorlog */
- int errorlog_fd;
-- enum { ERRORLOG_STDERR, ERRORLOG_FILE, ERRORLOG_SYSLOG } errorlog_mode;
-+ enum { ERRORLOG_STDERR, ERRORLOG_FILE, ERRORLOG_SYSLOG, ERRORLOG_PIPE } errorlog_mode;
- buffer *errorlog_buf;
-
- fdevents *ev, *ev_ins;
-diff -r 447bac6969ef src/log.c
---- a/src/log.c Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/log.c Tue Aug 19 19:45:00 2008 +0200
-@@ -57,10 +57,11 @@
- /**
- * open the errorlog
- *
-- * we have 3 possibilities:
-+ * we have 4 possibilities:
- * - stderr (default)
- * - syslog
- * - logfile
-+ * - pipe
- *
- * if the open failed, report to the user and die
- *
-@@ -79,21 +80,80 @@
- srv->errorlog_mode = ERRORLOG_SYSLOG;
- } else if (!buffer_is_empty(srv->srvconf.errorlog_file)) {
- const char *logfile = srv->srvconf.errorlog_file->ptr;
-+ if (logfile[0] == '|') {
-+#ifdef HAVE_FORK
-+ /* create write pipe and spawn process */
-
-- if (-1 == (srv->errorlog_fd = open(logfile, O_APPEND | O_WRONLY | O_CREAT | O_LARGEFILE, 0644))) {
-- log_error_write(srv, __FILE__, __LINE__, "SSSS",
-+ int to_log_fds[2];
-+ int fd;
-+ pid_t pid;
-+
-+ if (pipe(to_log_fds)) {
-+ log_error_write(srv, __FILE__, __LINE__, "ss",
-+ "pipe failed: ", strerror(errno));
-+ return -1;
-+ }
-+
-+ /* fork, execve */
-+ switch (pid = fork()) {
-+ case 0:
-+ /* child */
-+
-+ close(STDIN_FILENO);
-+ dup2(to_log_fds[0], STDIN_FILENO);
-+ close(to_log_fds[0]);
-+ /* not needed */
-+ close(to_log_fds[1]);
-+
-+ /* we don't need the client socket */
-+ for (fd = 3; fd < 256; fd++) {
-+ close(fd);
-+ }
-+
-+ /* exec the log-process (skip the | )
-+ *
-+ */
-+
-+ execl("/bin/sh", "sh", "-c", logfile + 1, NULL);
-+
-+ log_error_write(srv, __FILE__, __LINE__, "sss",
-+ "spawning log-process failed: ",
-+ strerror(errno), logfile + 1);
-+
-+ exit(-1);
-+ break;
-+ case -1:
-+ /* error */
-+ log_error_write(srv, __FILE__, __LINE__, "ss", "fork failed:", strerror(errno));
-+ break;
-+ default:
-+ close(to_log_fds[0]);
-+
-+ srv->errorlog_fd = to_log_fds[1];
-+
-+ break;
-+ }
-+ srv->errorlog_mode = ERRORLOG_PIPE;
-+#else
-+ log_error_write(srv, __FILE__, __LINE__, "SSS",
-+ "opening errorlog '", logfile,"' impossible");
-+ return -1;
-+#endif
-+ } else {
-+ if (-1 == (srv->errorlog_fd = open(logfile, O_APPEND | O_WRONLY | O_CREAT | O_LARGEFILE, 0644))) {
-+ log_error_write(srv, __FILE__, __LINE__, "SSSS",
- "opening errorlog '", logfile,
- "' failed: ", strerror(errno));
-
-- return -1;
-+ return -1;
-+ }
-+ srv->errorlog_mode = ERRORLOG_FILE;
- }
- #ifdef FD_CLOEXEC
- /* close fd on exec (cgi) */
- fcntl(srv->errorlog_fd, F_SETFD, FD_CLOEXEC);
- #endif
-- srv->errorlog_mode = ERRORLOG_FILE;
- }
--
- log_error_write(srv, __FILE__, __LINE__, "s", "server started");
-
- #ifdef HAVE_VALGRIND_VALGRIND_H
-@@ -122,7 +182,7 @@
- */
-
- int log_error_cycle(server *srv) {
-- /* only cycle if we are not in syslog-mode */
-+ /* only cycle if the error log is a file */
-
- if (srv->errorlog_mode == ERRORLOG_FILE) {
- const char *logfile = srv->srvconf.errorlog_file->ptr;
-@@ -154,6 +214,7 @@
-
- int log_error_close(server *srv) {
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE: /* fall through */
- case ERRORLOG_FILE:
- close(srv->errorlog_fd);
- break;
-@@ -173,6 +234,7 @@
- va_list ap;
-
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE:
- case ERRORLOG_FILE:
- case ERRORLOG_STDERR:
- /* cache the generated timestamp */
-@@ -257,6 +319,7 @@
- va_end(ap);
-
- switch(srv->errorlog_mode) {
-+ case ERRORLOG_PIPE: /* fall through */
- case ERRORLOG_FILE:
- buffer_append_string_len(srv->errorlog_buf, CONST_STR_LEN("\n"));
- write(srv->errorlog_fd, srv->errorlog_buf->ptr, srv->errorlog_buf->used - 1);
-diff -r 447bac6969ef src/mod_cgi.c
---- a/src/mod_cgi.c Tue Aug 19 18:04:17 2008 +0200
-+++ b/src/mod_cgi.c Tue Aug 19 19:45:00 2008 +0200
-@@ -781,7 +781,7 @@
- *
- * we feed the stderr of the CGI to our errorlog, if possible
- */
-- if (srv->errorlog_mode == ERRORLOG_FILE) {
-+ if ((srv->errorlog_mode == ERRORLOG_FILE) || (srv->errorlog_mode == ERRORLOG_PIPE)) {
- close(STDERR_FILENO);
- dup2(srv->errorlog_fd, STDERR_FILENO);
- }
diff --git a/www-servers/lighttpd/files/1.4.25-fix-unknown-AM_SILENT_RULES.patch b/www-servers/lighttpd/files/1.4.25-fix-unknown-AM_SILENT_RULES.patch
new file mode 100644
index 000000000000..2c72c6af3cc7
--- /dev/null
+++ b/www-servers/lighttpd/files/1.4.25-fix-unknown-AM_SILENT_RULES.patch
@@ -0,0 +1,18 @@
+Allow to build on older automakes. this disables color output on tests,
+but leaves the AM_SILENT_RULES intact for automakes which support this.
+
+Signed-off-by: Thilo Bangert <bangert@gentoo.org>
+
+diff -Naur lighttpd-1.4.25.orig/configure.ac lighttpd-1.4.25/configure.ac
+--- lighttpd-1.4.25.orig/configure.ac 2009-11-25 10:27:12.000000000 +0100
++++ lighttpd-1.4.25/configure.ac 2009-11-25 10:43:20.000000000 +0100
+@@ -8,7 +8,8 @@
+
+ AC_CANONICAL_TARGET
+
+-AM_INIT_AUTOMAKE([-Wall -Wportability -Wno-override -Werror foreign dist-bzip2 tar-ustar silent-rules color-tests])
++m4_pattern_allow([AM_SILENT_RULES])
++AM_INIT_AUTOMAKE([-Wall -Wportability -Wno-override -Werror foreign dist-bzip2 tar-ustar])
+ AM_SILENT_RULES
+
+ # Checks for programs.
diff --git a/www-servers/lighttpd/files/lighttpd-1.4.24-mod_magnet-fix-pairs.patch b/www-servers/lighttpd/files/lighttpd-1.4.24-mod_magnet-fix-pairs.patch
deleted file mode 100644
index 797a720c08ab..000000000000
--- a/www-servers/lighttpd/files/lighttpd-1.4.24-mod_magnet-fix-pairs.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Patch already applied upstream as revision 2680
-http://redmine.lighttpd.net/projects/lighttpd/repository/revisions/2680/diff
-
-Index: branches/lighttpd-1.4.x/src/mod_magnet.c
-===================================================================
---- branches/lighttpd-1.4.x/src/mod_magnet.c (revision 2679)
-+++ branches/lighttpd-1.4.x/src/mod_magnet.c (revision 2680)
-@@ -170,6 +170,7 @@
- return lua_gettop(L);
- } else {
- lua_pushvalue(L, lua_upvalueindex(1));
-+ lua_insert(L, 1);
- lua_call(L, lua_gettop(L) - 1, LUA_MULTRET);
- return lua_gettop(L);
- }
diff --git a/www-servers/lighttpd/files/lighttpd-1.4.24-mod_rewrite-without-pcre.patch b/www-servers/lighttpd/files/lighttpd-1.4.24-mod_rewrite-without-pcre.patch
deleted file mode 100644
index dac3a8624045..000000000000
--- a/www-servers/lighttpd/files/lighttpd-1.4.24-mod_rewrite-without-pcre.patch
+++ /dev/null
@@ -1,232 +0,0 @@
---- src/mod_rewrite.c (revision 2682)
-+++ src/mod_rewrite.c (revision 2683)
-@@ -9,10 +9,9 @@
- #include <stdlib.h>
- #include <string.h>
-
--typedef struct {
- #ifdef HAVE_PCRE_H
-+typedef struct {
- pcre *key;
--#endif
-
- buffer *value;
-
-@@ -70,7 +69,6 @@
- }
-
- static int rewrite_rule_buffer_append(rewrite_rule_buffer *kvb, buffer *key, buffer *value, int once) {
--#ifdef HAVE_PCRE_H
- size_t i;
- const char *errptr;
- int erroff;
-@@ -109,18 +107,9 @@
- kvb->used++;
-
- return 0;
--#else
-- UNUSED(kvb);
-- UNUSED(value);
-- UNUSED(once);
-- UNUSED(key);
--
-- return -1;
--#endif
- }
-
- static void rewrite_rule_buffer_free(rewrite_rule_buffer *kvb) {
--#ifdef HAVE_PCRE_H
- size_t i;
-
- for (i = 0; i < kvb->size; i++) {
-@@ -130,7 +119,6 @@
- }
-
- if (kvb->ptr) free(kvb->ptr);
--#endif
-
- free(kvb);
- }
-@@ -201,24 +189,29 @@
- ((data_string *)(da->value->data[j]))->key,
- ((data_string *)(da->value->data[j]))->value,
- once)) {
--#ifdef HAVE_PCRE_H
- log_error_write(srv, __FILE__, __LINE__, "sb",
- "pcre-compile failed for", da->value->data[j]->key);
--#else
-- log_error_write(srv, __FILE__, __LINE__, "s",
-- "pcre support is missing, please install libpcre and the headers");
--#endif
- }
- }
- }
-
- return 0;
- }
-+#else
-+static int parse_config_entry(server *srv, array *ca, const char *option) {
-+ static int logged_message = 0;
-+ if (logged_message) return 0;
-+ if (NULL != array_get_element(ca, option)) {
-+ logged_message = 1;
-+ log_error_write(srv, __FILE__, __LINE__, "s",
-+ "pcre support is missing, please install libpcre and the headers");
-+ }
-+ return 0;
-+}
-+#endif
-
- SETDEFAULTS_FUNC(mod_rewrite_set_defaults) {
-- plugin_data *p = p_d;
- size_t i = 0;
--
- config_values_t cv[] = {
- { "url.rewrite-repeat", NULL, T_CONFIG_LOCAL, T_CONFIG_SCOPE_CONNECTION }, /* 0 */
- { "url.rewrite-once", NULL, T_CONFIG_LOCAL, T_CONFIG_SCOPE_CONNECTION }, /* 1 */
-@@ -243,33 +236,37 @@
- { NULL, NULL, T_CONFIG_UNSET, T_CONFIG_SCOPE_UNSET }
- };
-
-+#ifdef HAVE_PCRE_H
-+ plugin_data *p = p_d;
-+
- if (!p) return HANDLER_ERROR;
-
- /* 0 */
- p->config_storage = calloc(1, srv->config_context->used * sizeof(specific_config *));
-+#else
-+ UNUSED(p_d);
-+#endif
-
- for (i = 0; i < srv->config_context->used; i++) {
-- plugin_config *s;
- array *ca;
-+#ifdef HAVE_PCRE_H
-+ plugin_config *s;
-
- s = calloc(1, sizeof(plugin_config));
- s->rewrite = rewrite_rule_buffer_init();
- s->rewrite_NF = rewrite_rule_buffer_init();
--
-- cv[0].destination = s->rewrite;
-- cv[1].destination = s->rewrite;
-- cv[2].destination = s->rewrite_NF;
-- cv[3].destination = s->rewrite_NF;
-- cv[4].destination = s->rewrite;
-- cv[5].destination = s->rewrite;
--
- p->config_storage[i] = s;
-+#endif
-+
- ca = ((data_config *)srv->config_context->data[i])->value;
-
- if (0 != config_insert_values_global(srv, ca, cv)) {
- return HANDLER_ERROR;
- }
-
-+#ifndef HAVE_PCRE_H
-+# define parse_config_entry(srv, ca, x, option, y) parse_config_entry(srv, ca, option)
-+#endif
- parse_config_entry(srv, ca, s->rewrite, "url.rewrite-once", 1);
- parse_config_entry(srv, ca, s->rewrite, "url.rewrite-final", 1);
- parse_config_entry(srv, ca, s->rewrite_NF, "url.rewrite-if-not-file", 1);
-@@ -280,7 +277,9 @@
-
- return HANDLER_GO_ON;
- }
-+
- #ifdef HAVE_PCRE_H
-+
- #define PATCH(x) \
- p->conf.x = s->x;
- static int mod_rewrite_patch_connection(server *srv, connection *con, plugin_data *p) {
-@@ -330,7 +329,7 @@
-
- return 0;
- }
--#endif
-+
- URIHANDLER_FUNC(mod_rewrite_con_reset) {
- plugin_data *p = p_d;
-
-@@ -345,7 +344,6 @@
- }
-
- static int process_rewrite_rules(server *srv, connection *con, plugin_data *p, rewrite_rule_buffer *kvb) {
--#ifdef HAVE_PCRE_H
- size_t i;
- handler_ctx *hctx;
-
-@@ -444,19 +442,11 @@
- }
- #undef N
- }
--#else
-- UNUSED(srv);
-- UNUSED(con);
-- UNUSED(p);
-- UNUSED(hctx);
-- UNUSED(kvb);
--#endif
-
- return HANDLER_GO_ON;
- }
-
- URIHANDLER_FUNC(mod_rewrite_physical) {
--#ifdef HAVE_PCRE_H
- plugin_data *p = p_d;
- handler_t r;
- stat_cache_entry *sce;
-@@ -480,17 +470,11 @@
- default:
- return r;
- }
--#else
-- UNUSED(srv);
-- UNUSED(con);
-- UNUSED(p_d);
--#endif
-
- return HANDLER_GO_ON;
- }
-
- URIHANDLER_FUNC(mod_rewrite_uri_handler) {
--#ifdef HAVE_PCRE_H
- plugin_data *p = p_d;
-
- mod_rewrite_patch_connection(srv, con, p);
-@@ -498,29 +482,27 @@
- if (!p->conf.rewrite) return HANDLER_GO_ON;
-
- return process_rewrite_rules(srv, con, p, p->conf.rewrite);
--#else
-- UNUSED(srv);
-- UNUSED(con);
-- UNUSED(p_d);
--#endif
-
- return HANDLER_GO_ON;
- }
-+#endif
-
- int mod_rewrite_plugin_init(plugin *p);
- int mod_rewrite_plugin_init(plugin *p) {
- p->version = LIGHTTPD_VERSION_ID;
- p->name = buffer_init_string("rewrite");
-
-+#ifdef HAVE_PCRE_H
- p->init = mod_rewrite_init;
- /* it has to stay _raw as we are matching on uri + querystring
- */
-
- p->handle_uri_raw = mod_rewrite_uri_handler;
- p->handle_physical = mod_rewrite_physical;
-- p->set_defaults = mod_rewrite_set_defaults;
- p->cleanup = mod_rewrite_free;
- p->connection_reset = mod_rewrite_con_reset;
-+#endif
-+ p->set_defaults = mod_rewrite_set_defaults;
-
- p->data = NULL;
-
diff --git a/www-servers/lighttpd/lighttpd-1.4.20.ebuild b/www-servers/lighttpd/lighttpd-1.4.20.ebuild
deleted file mode 100644
index 0b08ed34a522..000000000000
--- a/www-servers/lighttpd/lighttpd-1.4.20.ebuild
+++ /dev/null
@@ -1,214 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.20.ebuild,v 1.8 2009/02/03 12:46:51 betelgeuse Exp $
-
-WANT_AUTOCONF=latest
-WANT_AUTOMAKE=latest
-inherit eutils autotools depend.php
-
-DESCRIPTION="Lightweight high-performance web server"
-HOMEPAGE="http://www.lighttpd.net/"
-SRC_URI="http://www.lighttpd.net/download/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="bzip2 doc fam fastcgi gdbm ipv6 ldap lua minimal memcache mysql pcre php rrdtool ssl test webdav xattr"
-
-# cherokee block should be resolved properly
-# http://bugs.gentoo.org/show_bug.cgi?id=224781
-RDEPEND="
- !www-servers/cherokee
- >=sys-libs/zlib-1.1
- bzip2? ( app-arch/bzip2 )
- fam? ( virtual/fam )
- gdbm? ( sys-libs/gdbm )
- ldap? ( >=net-nds/openldap-2.1.26 )
- lua? ( >=dev-lang/lua-5.1 )
- memcache? ( dev-libs/libmemcache )
- mysql? ( >=virtual/mysql-4.0 )
- pcre? ( >=dev-libs/libpcre-3.1 )
- php? ( virtual/httpd-php )
- rrdtool? ( net-analyzer/rrdtool )
- ssl? ( >=dev-libs/openssl-0.9.7 )
- webdav? (
- dev-libs/libxml2
- >=dev-db/sqlite-3
- sys-fs/e2fsprogs
- )
- xattr? ( kernel_linux? ( sys-apps/attr ) )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )
- test? (
- virtual/perl-Test-Harness
- dev-libs/fcgi
- )"
-
-# update certain parts of lighttpd.conf based on conditionals
-update_config() {
- local config="/etc/lighttpd/lighttpd.conf"
-
- # enable php/mod_fastcgi settings
- use php && \
- dosed 's|#.*\(include.*fastcgi.*$\)|\1|' ${config}
-
- # enable stat() caching
- use fam && \
- dosed 's|#\(.*stat-cache.*$\)|\1|' ${config}
-}
-
-# remove non-essential stuff (for USE=minimal)
-remove_non_essential() {
- local libdir="${D}/usr/$(get_libdir)/${PN}"
-
- # text docs
- use doc || rm -fr "${D}"/usr/share/doc/${PF}/txt
-
- # non-essential modules
- rm -f \
- ${libdir}/mod_{compress,evhost,expire,proxy,scgi,secdownload,simple_vhost,status,setenv,trigger*,usertrack}.*
-
- # allow users to keep some based on USE flags
- use pcre || rm -f ${libdir}/mod_{ssi,re{direct,write}}.*
- use webdav || rm -f ${libdir}/mod_webdav.*
- use mysql || rm -f ${libdir}/mod_mysql_vhost.*
- use lua || rm -f ${libdir}/mod_{cml,magnet}.*
- use rrdtool || rm -f ${libdir}/mod_rrdtool.*
-
- if ! use fastcgi ; then
- rm -f ${libdir}/mod_fastcgi.* "${D}"/usr/bin/spawn-fcgi \
- "${D}"/usr/share/man/man1/spawn-fcgi.*
- fi
-}
-
-pkg_setup() {
- if ! use pcre ; then
- ewarn "It is highly recommended that you build ${PN}"
- ewarn "with perl regular expressions support via USE=pcre."
- ewarn "Otherwise you lose support for some core options such"
- ewarn "as conditionals and modules such as mod_re{write,direct}"
- ewarn "and mod_ssi."
- ebeep 5
- fi
-
- use php && require_php_with_use cgi
-
- enewgroup lighttpd
- enewuser lighttpd -1 -1 /var/www/localhost/htdocs lighttpd
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- EPATCH_SUFFIX="diff" EPATCH_OPTS="-l" epatch "${FILESDIR}"/"${PVR}" || die "Patching failed!"
-
- eautoreconf || die
-
- # dev-python/docutils installs rst2html.py not rst2html
- sed -i -e 's|\(rst2html\)|\1.py|g' doc/Makefile.in || \
- die "sed doc/Makefile.in failed"
-
- # fix typo
- sed -i -e 's|\(output_content\)_\(type\)|\1\2|' doc/cml.txt || \
- die "sed doc/cml.txt failed"
-}
-
-src_compile() {
- econf --libdir=/usr/$(get_libdir)/${PN} \
- --enable-lfs \
- $(use_enable ipv6) \
- $(use_with bzip2) \
- $(use_with fam) \
- $(use_with gdbm) \
- $(use_with lua) \
- $(use_with ldap) \
- $(use_with memcache) \
- $(use_with mysql) \
- $(use_with pcre) \
- $(use_with ssl openssl) \
- $(use_with webdav webdav-props) \
- $(use_with webdav webdav-locks) \
- $(use_with xattr attr) \
- || die "econf failed"
-
- emake || die "emake failed"
-
- if use doc ; then
- einfo "Building HTML documentation"
- cd doc
- emake html || die "failed to build HTML documentation"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # init script stuff
- newinitd "${FILESDIR}"/lighttpd.initd-1.4.13-r3 lighttpd || die
- newconfd "${FILESDIR}"/lighttpd.confd lighttpd || die
- use fam && has_version app-admin/fam && \
- sed -i 's/after famd/need famd/g' "${D}"/etc/init.d/lighttpd
-
- if use php || use fastcgi ; then
- newinitd "${FILESDIR}"/spawn-fcgi.initd spawn-fcgi || die
- newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi || die
- fi
-
- # configs
- insinto /etc/lighttpd
- doins "${FILESDIR}"/conf/lighttpd.conf
- doins "${FILESDIR}"/conf/mime-types.conf
- doins "${FILESDIR}"/conf/mod_cgi.conf
- newins "${FILESDIR}"/conf/mod_fastcgi.conf-1.4.13-r2 mod_fastcgi.conf
- # Secure directory for fastcgi sockets
- keepdir /var/run/lighttpd/
- fperms 0750 /var/run/lighttpd/
- fowners lighttpd:lighttpd /var/run/lighttpd/
-
- # update lighttpd.conf directives based on conditionals
- update_config
-
- # docs
- dodoc AUTHORS README NEWS ChangeLog doc/*.sh
- newdoc doc/lighttpd.conf lighttpd.conf.distrib
-
- use doc && dohtml -r doc/*
-
- docinto txt
- dodoc doc/*.txt
-
- # logrotate
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/lighttpd.logrotate lighttpd || die
-
- keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
- fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
- fperms 0750 /var/l{ib,og}/lighttpd
-
- use minimal && remove_non_essential
-}
-
-pkg_postinst () {
- echo
- if [[ -f ${ROOT}etc/conf.d/spawn-fcgi.conf ]] ; then
- einfo "spawn-fcgi is now included with lighttpd"
- einfo "spawn-fcgi's init script configuration is now located"
- einfo "at /etc/conf.d/spawn-fcgi."
- echo
- fi
-
- if [[ -f ${ROOT}etc/lighttpd.conf ]] ; then
- ewarn "As of lighttpd-1.4.1, Gentoo has a customized configuration,"
- ewarn "which is now located in /etc/lighttpd. Please migrate your"
- ewarn "existing configuration."
- ebeep 5
- fi
-
- if use fam ; then
- einfo "Remember to re-emerge lighttpd should you switch from"
- einfo "app-admin/famd to app-admin/gamin or vice versa."
- fi
- echo
-}
diff --git a/www-servers/lighttpd/lighttpd-1.4.22-r1.ebuild b/www-servers/lighttpd/lighttpd-1.4.22-r1.ebuild
deleted file mode 100644
index 6eb0d5a81a46..000000000000
--- a/www-servers/lighttpd/lighttpd-1.4.22-r1.ebuild
+++ /dev/null
@@ -1,205 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.22-r1.ebuild,v 1.3 2009/07/07 12:08:05 bangert Exp $
-
-EAPI="2"
-
-inherit eutils autotools depend.php
-
-DESCRIPTION="Lightweight high-performance web server"
-HOMEPAGE="http://www.lighttpd.net/"
-SRC_URI="http://www.lighttpd.net/download/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bzip2 doc fam fastcgi gdbm ipv6 ldap lua minimal memcache mysql pcre php rrdtool ssl test webdav xattr"
-
-RDEPEND="
- >=sys-libs/zlib-1.1
- bzip2? ( app-arch/bzip2 )
- fam? ( virtual/fam )
- gdbm? ( sys-libs/gdbm )
- ldap? ( >=net-nds/openldap-2.1.26 )
- lua? ( >=dev-lang/lua-5.1 )
- memcache? ( dev-libs/libmemcache )
- mysql? ( >=virtual/mysql-4.0 )
- pcre? ( >=dev-libs/libpcre-3.1 )
- php? ( virtual/httpd-php )
- rrdtool? ( net-analyzer/rrdtool )
- ssl? ( >=dev-libs/openssl-0.9.7 )
- webdav? (
- dev-libs/libxml2
- >=dev-db/sqlite-3
- sys-fs/e2fsprogs
- )
- xattr? ( kernel_linux? ( sys-apps/attr ) )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )
- test? (
- virtual/perl-Test-Harness
- dev-libs/fcgi
- )"
-
-# update certain parts of lighttpd.conf based on conditionals
-update_config() {
- local config="/etc/lighttpd/lighttpd.conf"
-
- # enable php/mod_fastcgi settings
- use php && \
- dosed 's|#.*\(include.*fastcgi.*$\)|\1|' ${config}
-
- # enable stat() caching
- use fam && \
- dosed 's|#\(.*stat-cache.*$\)|\1|' ${config}
-}
-
-# remove non-essential stuff (for USE=minimal)
-remove_non_essential() {
- local libdir="${D}/usr/$(get_libdir)/${PN}"
-
- # text docs
- use doc || rm -fr "${D}"/usr/share/doc/${PF}/txt
-
- # non-essential modules
- rm -f \
- ${libdir}/mod_{compress,evhost,expire,proxy,scgi,secdownload,simple_vhost,status,setenv,trigger*,usertrack}.*
-
- # allow users to keep some based on USE flags
- use pcre || rm -f ${libdir}/mod_{ssi,re{direct,write}}.*
- use webdav || rm -f ${libdir}/mod_webdav.*
- use mysql || rm -f ${libdir}/mod_mysql_vhost.*
- use lua || rm -f ${libdir}/mod_{cml,magnet}.*
- use rrdtool || rm -f ${libdir}/mod_rrdtool.*
-
- if ! use fastcgi ; then
- rm -f ${libdir}/mod_fastcgi.*
- fi
-}
-
-pkg_setup() {
- if ! use pcre ; then
- ewarn "It is highly recommended that you build ${PN}"
- ewarn "with perl regular expressions support via USE=pcre."
- ewarn "Otherwise you lose support for some core options such"
- ewarn "as conditionals and modules such as mod_re{write,direct}"
- ewarn "and mod_ssi."
- ebeep 5
- fi
-
- use php && require_php_with_use cgi
-
- enewgroup lighttpd
- enewuser lighttpd -1 -1 /var/www/localhost/htdocs lighttpd
-}
-
-src_prepare() {
- EPATCH_SUFFIX="diff" EPATCH_OPTS="-l" epatch "${FILESDIR}/${PVR}" || \
- die "Patching failed!"
- # dev-python/docutils installs rst2html.py not rst2html
- sed -i -e 's|\(rst2html\)|\1.py|g' doc/Makefile.am || \
- die "sed doc/Makefile.am failed"
-
- eautoreconf || die
-}
-
-src_configure() {
- econf --libdir=/usr/$(get_libdir)/${PN} \
- --enable-lfs \
- $(use_enable ipv6) \
- $(use_with bzip2) \
- $(use_with fam) \
- $(use_with gdbm) \
- $(use_with lua) \
- $(use_with ldap) \
- $(use_with memcache) \
- $(use_with mysql) \
- $(use_with pcre) \
- $(use_with ssl openssl) \
- $(use_with webdav webdav-props) \
- $(use_with webdav webdav-locks) \
- $(use_with xattr attr) \
- || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use doc ; then
- einfo "Building HTML documentation"
- cd doc
- emake html || die "failed to build HTML documentation"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # init script stuff
- newinitd "${FILESDIR}"/lighttpd.initd lighttpd || die
- newconfd "${FILESDIR}"/lighttpd.confd lighttpd || die
- use fam && has_version app-admin/fam && \
- sed -i 's/after famd/need famd/g' "${D}"/etc/init.d/lighttpd
-
- # configs
- insinto /etc/lighttpd
- doins "${FILESDIR}"/conf/lighttpd.conf
- doins "${FILESDIR}"/conf/mime-types.conf
- doins "${FILESDIR}"/conf/mod_cgi.conf
- doins "${FILESDIR}"/conf/mod_fastcgi.conf
- # Secure directory for fastcgi sockets
- keepdir /var/run/lighttpd/
- fperms 0750 /var/run/lighttpd/
- fowners lighttpd:lighttpd /var/run/lighttpd/
-
- # update lighttpd.conf directives based on conditionals
- update_config
-
- # docs
- dodoc AUTHORS README NEWS ChangeLog doc/*.sh
- newdoc doc/lighttpd.conf lighttpd.conf.distrib
-
- use doc && dohtml -r doc/*
-
- docinto txt
- dodoc doc/*.txt
-
- # logrotate
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/lighttpd.logrotate lighttpd || die
-
- keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
- fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
- fperms 0750 /var/l{ib,og}/lighttpd
-
- #spawn-fcgi may optionally be installed via www-servers/spawn-fcgi
- rm -f "${D}"/usr/bin/spawn-fcgi "${D}"/usr/share/man/man1/spawn-fcgi.*
-
- use minimal && remove_non_essential
-}
-
-pkg_postinst () {
- echo
- if [[ -f ${ROOT}etc/conf.d/spawn-fcgi.conf ]] ; then
- einfo "spawn-fcgi is now provided by www-servers/spawn-fcgi."
- einfo "spawn-fcgi's init script configuration is now located"
- einfo "at /etc/conf.d/spawn-fcgi."
- echo
- fi
-
- if [[ -f ${ROOT}etc/lighttpd.conf ]] ; then
- ewarn "Gentoo has a customized configuration,"
- ewarn "which is now located in /etc/lighttpd. Please migrate your"
- ewarn "existing configuration."
- ebeep 5
- fi
-
- if use fastcgi; then
- ewarn "As of lighttpd-1.4.22, spawn-fcgi is provided by the separate"
- ewarn "www-servers/spawn-fcgi package. Please install it manually, if"
- ewarn "you use spawn-fcgi."
- ewarn "It features a new, more featurefull init script - please migrate"
- ewarn "your configuration!"
- fi
-}
diff --git a/www-servers/lighttpd/lighttpd-1.4.24.ebuild b/www-servers/lighttpd/lighttpd-1.4.25.ebuild
index 0363a88e4330..68e47dc49bc7 100644
--- a/www-servers/lighttpd/lighttpd-1.4.24.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.24.ebuild,v 1.2 2009/11/05 18:19:29 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.25.ebuild,v 1.1 2009/11/25 09:59:17 bangert Exp $
EAPI="2"
@@ -8,7 +8,7 @@ inherit eutils autotools depend.php
DESCRIPTION="Lightweight high-performance web server"
HOMEPAGE="http://www.lighttpd.net/"
-SRC_URI="http://www.lighttpd.net/download/${P}.tar.bz2"
+SRC_URI="http://download.lighttpd.net/lighttpd/releases-1.4.x/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
@@ -96,7 +96,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/lighttpd-1.4.24-{mod_magnet-fix-pairs,mod_rewrite-without-pcre}.patch
+ epatch "${FILESDIR}"/1.4.25-fix-unknown-AM_SILENT_RULES.patch
# dev-python/docutils installs rst2html.py not rst2html
sed -i -e 's|\(rst2html\)|\1.py|g' doc/Makefile.am || \
die "sed doc/Makefile.am failed"