summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/linesrv/ChangeLog6
-rw-r--r--net-misc/linesrv/files/2.1.8-gcc34.patch64
-rw-r--r--net-misc/linesrv/linesrv-2.1.8.ebuild6
3 files changed, 74 insertions, 2 deletions
diff --git a/net-misc/linesrv/ChangeLog b/net-misc/linesrv/ChangeLog
index 329180a11920..2b1dfe1f7e04 100644
--- a/net-misc/linesrv/ChangeLog
+++ b/net-misc/linesrv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/linesrv
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linesrv/ChangeLog,v 1.9 2004/07/01 21:24:26 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linesrv/ChangeLog,v 1.10 2004/09/17 22:49:35 squinky86 Exp $
+
+ 17 Sep 2004; Jon Hood <squinky86@gentoo.org> +files/2.1.8-gcc34.patch,
+ linesrv-2.1.8.ebuild:
+ Add gcc-3.4 patch, #62541.
01 Jul 2004; Jon Hood <squinky86@gentoo.org> linesrv-2.1.6-r1.ebuild,
linesrv-2.1.8.ebuild:
diff --git a/net-misc/linesrv/files/2.1.8-gcc34.patch b/net-misc/linesrv/files/2.1.8-gcc34.patch
new file mode 100644
index 000000000000..fb2e8e305117
--- /dev/null
+++ b/net-misc/linesrv/files/2.1.8-gcc34.patch
@@ -0,0 +1,64 @@
+diff -Naur linesrv-2.1.vanilla/server/cfg.c linesrv-2.1/server/cfg.c
+--- linesrv-2.1.vanilla/server/cfg.c 2002-02-17 06:15:11.000000000 -0600
++++ linesrv-2.1/server/cfg.c 2004-09-17 17:45:52.167059584 -0500
+@@ -605,6 +605,7 @@
+ }
+ break;
+ default:
++ ;
+ }
+ }
+ }
+diff -Naur linesrv-2.1.vanilla/server/html_status.c linesrv-2.1/server/html_status.c
+--- linesrv-2.1.vanilla/server/html_status.c 2002-02-17 02:44:38.000000000 -0600
++++ linesrv-2.1/server/html_status.c 2004-09-17 17:45:52.169059280 -0500
+@@ -18,10 +18,10 @@
+ {
+ fprintf(where, "<html><head><style type=\"text/css\">\n\
+ p, table, br { align: center; font-family: Arial, Helvetica }\n\
+-body, td { font-family: Arial, Helvetica } \n\
+-A { text-decoration: none; \n\
+-font-style: italic; \n\
+-font-family: Arial, Helvetica } \n\
++body, td { font-family: Arial, Helvetica }\n\
++A { text-decoration: none;\n\
++font-style: italic;\n\
++font-family: Arial, Helvetica }\n\
+ </style></head><body bgcolor=\"#ffffff\" text=\"000080\">\n");
+ fprintf(where, "<center><p><a href=\"http://homepage.swissonline.ch/allenfuchs/stefan/lc/\">\
+ <img src=\"/lclog/lc-logo-01.gif\" width=\"246\" height=\"53\" border=\"0\"></a></p>\n\
+diff -Naur linesrv-2.1.vanilla/server/proc.c linesrv-2.1/server/proc.c
+--- linesrv-2.1.vanilla/server/proc.c 2001-02-01 10:55:22.000000000 -0600
++++ linesrv-2.1/server/proc.c 2004-09-17 17:45:52.171058976 -0500
+@@ -224,7 +224,7 @@
+ }
+ break;
+ default:
+- // uh... don't dial -> status would be incorrect
++ ; // uh... don't dial -> status would be incorrect
+ }
+ if ( who->status == CLT_ONLINE )
+ {
+diff -Naur linesrv-2.1.vanilla/server/proc_lcp3.c linesrv-2.1/server/proc_lcp3.c
+--- linesrv-2.1.vanilla/server/proc_lcp3.c 2001-10-28 12:48:52.000000000 -0600
++++ linesrv-2.1/server/proc_lcp3.c 2004-09-17 17:45:52.172058824 -0500
+@@ -158,7 +158,7 @@
+ who->status = CLT_OFFLINE;
+ break;
+ default:
+- // uh... don't dial -> status would be incorrect
++ ; // uh... don't dial -> status would be incorrect
+ }
+ lcp3_cmd_queue(CMD3_CLIENTSTAT, who, NULL, 0);
+ break; // CMD3_ONLINE
+diff -Naur linesrv-2.1.vanilla/server/user_pam.c linesrv-2.1/server/user_pam.c
+--- linesrv-2.1.vanilla/server/user_pam.c 2001-06-30 14:38:41.000000000 -0500
++++ linesrv-2.1/server/user_pam.c 2004-09-17 17:45:52.173058672 -0500
+@@ -31,6 +31,7 @@
+ rsp[i].resp = strdup("!!");
+ break;
+ default:
++ ;
+ }
+ rsp[i].resp_retcode = PAM_SUCCESS;
+ }
diff --git a/net-misc/linesrv/linesrv-2.1.8.ebuild b/net-misc/linesrv/linesrv-2.1.8.ebuild
index 441d821fdab0..fac4c330a60d 100644
--- a/net-misc/linesrv/linesrv-2.1.8.ebuild
+++ b/net-misc/linesrv/linesrv-2.1.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linesrv/linesrv-2.1.8.ebuild,v 1.3 2004/07/01 21:24:26 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linesrv/linesrv-2.1.8.ebuild,v 1.4 2004/09/17 22:49:35 squinky86 Exp $
+
+inherit eutils
IUSE="pam"
@@ -22,6 +24,8 @@ KEYWORDS="~x86 ~sparc"
src_unpack() {
unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc34.patch
}
src_compile() {