summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/yacas/ChangeLog10
-rw-r--r--sci-mathematics/yacas/files/yacas-1.2.2-gcc46.patch15
-rw-r--r--sci-mathematics/yacas/yacas-1.2.2-r1.ebuild54
3 files changed, 77 insertions, 2 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index 89bd44a5fd3c..883a67e7ee9e 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/yacas
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.27 2009/01/15 17:40:12 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.28 2011/04/17 09:58:34 jlec Exp $
+
+*yacas-1.2.2-r1 (17 Apr 2011)
+
+ 17 Apr 2011; Justin Lecher <jlec@gentoo.org> +yacas-1.2.2-r1.ebuild,
+ +files/yacas-1.2.2-gcc46.patch:
+ Fix for compilation with gcc4.6, #362377
15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
-files/yacas-1.0.63-as-needed.patch, -yacas-1.0.63.ebuild:
diff --git a/sci-mathematics/yacas/files/yacas-1.2.2-gcc46.patch b/sci-mathematics/yacas/files/yacas-1.2.2-gcc46.patch
new file mode 100644
index 000000000000..646de9091d11
--- /dev/null
+++ b/sci-mathematics/yacas/files/yacas-1.2.2-gcc46.patch
@@ -0,0 +1,15 @@
+ src/grower.h | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/grower.h b/src/grower.h
+index 9c91e58..34ea786 100644
+--- a/src/grower.h
++++ b/src/grower.h
+@@ -92,6 +92,7 @@ class ArrOpsDeletingPtr : public ArrOpsCustomPtr<T>
+ {
+ typedef T* TY;
+ public:
++ ArrOpsDeletingPtr() {}
+ inline void destruct(void * obj) const
+ { delete *static_cast<const TY*>(obj); }
+ };
diff --git a/sci-mathematics/yacas/yacas-1.2.2-r1.ebuild b/sci-mathematics/yacas/yacas-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..ba93411effc2
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.2.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.2.2-r1.ebuild,v 1.1 2011/04/17 09:58:33 jlec Exp $
+
+EAPI="4"
+
+inherit eutils java-pkg-opt-2
+
+DESCRIPTION="Powerful general purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc java server"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-makefixes.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc html-doc) \
+ $(use_enable server) \
+ --with-html-dir="/usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ # -j1 because of file generation dependence
+ emake -j1 -f makefile.yacas
+ fi
+}
+
+src_install() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
+ insinto /usr/share/${PN}
+ doins hints.txt yacasconsole.html
+ fi
+}