summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/icecast/ChangeLog11
-rw-r--r--net-misc/icecast/icecast-2.3.3.ebuild68
-rw-r--r--net-misc/icecast/metadata.xml3
3 files changed, 78 insertions, 4 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index 25a8d7624b76..f468ef2f966f 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.85 2009/07/21 17:18:54 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.86 2012/08/06 19:30:29 hwoarang Exp $
+
+*icecast-2.3.3 (06 Aug 2012)
+
+ 06 Aug 2012; Markos Chandras <hwoarang@gentoo.org> +icecast-2.3.3.ebuild,
+ metadata.xml:
+ Version bump. Eapi4fy it. Take exclusive maintainership
21 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> icecast-2.3.2.ebuild:
Touch access.log and error.log and chown them to icecast:nogroup wrt
@@ -331,4 +337,3 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
-
diff --git a/net-misc/icecast/icecast-2.3.3.ebuild b/net-misc/icecast/icecast-2.3.3.ebuild
new file mode 100644
index 000000000000..0931b27b8ff9
--- /dev/null
+++ b/net-misc/icecast/icecast-2.3.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.3.ebuild,v 1.1 2012/08/06 19:30:29 hwoarang Exp $
+
+EAPI=4
+inherit eutils libtool
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+speex +ssl +theora +yp"
+
+#Although there is a --with-ogg and --with-orbis configure option, they're
+#only useful for specifying paths, not for disabling.
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ media-libs/libogg
+ media-libs/libvorbis
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ enewuser icecast -1 -1 -1 nogroup
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --sysconfdir=/etc/icecast2 \
+ $(use_with theora) \
+ $(use_with speex) \
+ $(use_with yp curl) \
+ $(use_with ssl openssl) \
+ $(use_enable yp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+ doman debian/icecast2.1
+
+ newinitd "${FILESDIR}"/init.d.icecast icecast
+
+ insinto /etc/icecast2
+ doins "${FILESDIR}"/icecast.xml
+ fperms 600 /etc/icecast2/icecast.xml
+
+ diropts -m0764 -o icecast -g nogroup
+ dodir /var/log/icecast
+ keepdir /var/log/icecast
+ rm -rf "${D}"/usr/share/doc/icecast
+}
+
+pkg_postinst() {
+ touch "${ROOT}"var/log/icecast/{access,error}.log
+ chown icecast:nogroup "${ROOT}"var/log/icecast/{access,error}.log
+}
diff --git a/net-misc/icecast/metadata.xml b/net-misc/icecast/metadata.xml
index cfe6ecc0ffb1..945aee953126 100644
--- a/net-misc/icecast/metadata.xml
+++ b/net-misc/icecast/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<herd>sound</herd>
<maintainer>
- <email>sound@gentoo.org</email>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
</maintainer>
<use>
<flag name="yp">Build support for yp public directory listings</flag>