summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/g-wrap/ChangeLog9
-rw-r--r--dev-libs/g-wrap/g-wrap-1.3.4.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-libs/g-wrap/ChangeLog b/dev-libs/g-wrap/ChangeLog
index d6a209dae395..58f81fa0a448 100644
--- a/dev-libs/g-wrap/ChangeLog
+++ b/dev-libs/g-wrap/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-libs/g-wrap
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/ChangeLog,v 1.6 2003/02/12 06:03:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/ChangeLog,v 1.7 2003/03/17 06:38:25 edolnx Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
@@ -25,3 +25,10 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
+
+*g-wrap-1.3.4 (17MAR2003)
+
+ 17 MAR 2003; Carl Perry <edolnx@gentoo.org> ChangeLog:
+
+ Added 1.3.4 for gnucash 1.8 series - doesn't seem to adversely
+ interact with any other apps
diff --git a/dev-libs/g-wrap/g-wrap-1.3.4.ebuild b/dev-libs/g-wrap/g-wrap-1.3.4.ebuild
new file mode 100644
index 000000000000..212f135be97c
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/g-wrap-1.3.4.ebuild,v 1.1 2003/03/17 06:38:25 edolnx Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+SRC_URI="http://www.gnucash.org/pub/g-wrap/source/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org"
+
+SLOT="1.3"
+LICENSE="GPL-2"
+KEYWORDS="~x86 "
+
+inherit flag-o-matic
+
+filter-flags "-O?"
+
+DEPEND=">=dev-util/guile-1.4
+ >=dev-libs/slib-2.4.2"
+
+
+src_compile() {
+
+ econf \
+ --libexecdir=/usr/lib/misc || die
+
+# #GCC3 Compile fix, I tried to do this at the Makefile.in level
+# #but it hates me with a passion so it goes here.
+# for FILE in `find . -iname "Makefile"`
+# do
+# mv ${FILE} ${FILE}.old
+# sed -e "s: -I/usr/include : :" ${FILE}.old > ${FILE}
+# done
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README THANKS
+}