summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/foremost/foremost-0.69.ebuild6
-rw-r--r--app-antivirus/clamav/clamav-0.67.ebuild6
-rw-r--r--app-antivirus/clamav/clamav-0.68.1.ebuild7
-rw-r--r--app-antivirus/clamav/clamav-0.70.ebuild7
-rw-r--r--app-antivirus/clamav/clamav-0.71.ebuild7
-rw-r--r--app-antivirus/clamav/clamav-0.72.ebuild7
-rw-r--r--app-antivirus/clamav/clamav-0.73.ebuild7
7 files changed, 26 insertions, 21 deletions
diff --git a/app-admin/foremost/foremost-0.69.ebuild b/app-admin/foremost/foremost-0.69.ebuild
index 089fb06e1ace..03cfde13f2fb 100644
--- a/app-admin/foremost/foremost-0.69.ebuild
+++ b/app-admin/foremost/foremost-0.69.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/foremost/foremost-0.69.ebuild,v 1.4 2004/06/24 21:25:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/foremost/foremost-0.69.ebuild,v 1.5 2004/06/25 23:22:37 vapier Exp $
DESCRIPTION="A console program to recover files based on their headers and footers"
-SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
HOMEPAGE="http://foremost.sourceforge.net/"
+SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
KEYWORDS="~x86 ~ppc"
IUSE=""
LICENSE="public-domain"
SLOT="0"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/app-antivirus/clamav/clamav-0.67.ebuild b/app-antivirus/clamav/clamav-0.67.ebuild
index b4367f12193f..44a6c904c3b4 100644
--- a/app-antivirus/clamav/clamav-0.67.ebuild
+++ b/app-antivirus/clamav/clamav-0.67.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.67.ebuild,v 1.4 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.67.ebuild,v 1.5 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64"
IUSE="milter"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
PROVIDE="virtual/antivirus"
pkg_setup() {
@@ -23,7 +23,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"
diff --git a/app-antivirus/clamav/clamav-0.68.1.ebuild b/app-antivirus/clamav/clamav-0.68.1.ebuild
index 5dba27e3226c..cbade01afdef 100644
--- a/app-antivirus/clamav/clamav-0.68.1.ebuild
+++ b/app-antivirus/clamav/clamav-0.68.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.68.1.ebuild,v 1.4 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.68.1.ebuild,v 1.5 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
MY_P="${PN}-0.68-1"
@@ -13,9 +13,10 @@ SLOT="0"
KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ia64"
IUSE="milter crypt"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )"
PROVIDE="virtual/antivirus"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -25,7 +26,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"
diff --git a/app-antivirus/clamav/clamav-0.70.ebuild b/app-antivirus/clamav/clamav-0.70.ebuild
index 72e7c97bcbf3..009012d18f20 100644
--- a/app-antivirus/clamav/clamav-0.70.ebuild
+++ b/app-antivirus/clamav/clamav-0.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.70.ebuild,v 1.4 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.70.ebuild,v 1.5 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ~ia64"
IUSE="milter crypt"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )"
PROVIDE="virtual/antivirus"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -27,7 +28,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"
diff --git a/app-antivirus/clamav/clamav-0.71.ebuild b/app-antivirus/clamav/clamav-0.71.ebuild
index 3fbd0d1a8346..67eff9fad379 100644
--- a/app-antivirus/clamav/clamav-0.71.ebuild
+++ b/app-antivirus/clamav/clamav-0.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.71.ebuild,v 1.4 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.71.ebuild,v 1.5 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
IUSE="milter crypt"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )"
PROVIDE="virtual/antivirus"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -27,7 +28,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"
diff --git a/app-antivirus/clamav/clamav-0.72.ebuild b/app-antivirus/clamav/clamav-0.72.ebuild
index 18269d5891d0..26411a8334d8 100644
--- a/app-antivirus/clamav/clamav-0.72.ebuild
+++ b/app-antivirus/clamav/clamav-0.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.72.ebuild,v 1.4 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.72.ebuild,v 1.5 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
IUSE="milter crypt"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )"
PROVIDE="virtual/antivirus"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -27,7 +28,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"
diff --git a/app-antivirus/clamav/clamav-0.73.ebuild b/app-antivirus/clamav/clamav-0.73.ebuild
index 26f980ccd7f1..5211a5c4ee4d 100644
--- a/app-antivirus/clamav/clamav-0.73.ebuild
+++ b/app-antivirus/clamav/clamav-0.73.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.73.ebuild,v 1.2 2004/06/24 21:26:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.73.ebuild,v 1.3 2004/06/25 23:24:29 vapier Exp $
inherit eutils flag-o-matic
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
IUSE="milter crypt"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )"
PROVIDE="virtual/antivirus"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -27,7 +28,7 @@ pkg_setup() {
}
src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
local myconf
use milter && myconf="--enable-milter"