summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/comix/ChangeLog7
-rw-r--r--media-gfx/comix/comix-3.6.4-r1.ebuild38
-rw-r--r--media-gfx/comix/files/comix-3.6.4-command-argument-closure.patch158
-rw-r--r--media-gfx/comix/files/comix-3.6.4-tmpfile.patch163
4 files changed, 6 insertions, 360 deletions
diff --git a/media-gfx/comix/ChangeLog b/media-gfx/comix/ChangeLog
index e8cfb2382412..aa8dacf915e6 100644
--- a/media-gfx/comix/ChangeLog
+++ b/media-gfx/comix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/comix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/comix/ChangeLog,v 1.45 2008/10/18 13:48:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/comix/ChangeLog,v 1.46 2008/10/18 13:54:29 maekke Exp $
+
+ 18 Oct 2008; Markus Meier <maekke@gentoo.org>
+ -files/comix-3.6.4-command-argument-closure.patch,
+ -files/comix-3.6.4-tmpfile.patch, -comix-3.6.4-r1.ebuild:
+ old
18 Oct 2008; Brent Baude <ranger@gentoo.org> comix-3.6.5.ebuild:
stable ppc, bug 242394
diff --git a/media-gfx/comix/comix-3.6.4-r1.ebuild b/media-gfx/comix/comix-3.6.4-r1.ebuild
deleted file mode 100644
index bc35105cb085..000000000000
--- a/media-gfx/comix/comix-3.6.4-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/comix/comix-3.6.4-r1.ebuild,v 1.4 2008/04/06 20:21:28 dertobi123 Exp $
-
-inherit toolchain-funcs gnome2 eutils
-
-DESCRIPTION="A GTK image viewer specifically designed to handle comic books."
-HOMEPAGE="http://comix.sourceforge.net"
-SRC_URI="mirror://sourceforge/comix/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="doc rar"
-RDEPEND=">=dev-python/pygtk-2.8.0
- rar? ( app-arch/unrar )
- >=dev-python/imaging-1.1.4"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}"/${P}-command-argument-closure.patch
- epatch "${FILESDIR}"/${P}-tmpfile.patch
-}
-
-src_compile() {
- einfo "Nothing to be compiled."
-}
-
-src_install() {
- dodir /usr
- python install.py install --no-mime --installdir "${D}"usr 1>/dev/null || die
- insinto /usr/share/mime/packages/
- doins "${S}"/mime/comix.xml
- insinto /etc/gconf/schemas/
- doins "${S}"/mime/comicbook.schemas
- dobin "${S}"/mime/comicthumb
- dodoc ChangeLog README
-}
diff --git a/media-gfx/comix/files/comix-3.6.4-command-argument-closure.patch b/media-gfx/comix/files/comix-3.6.4-command-argument-closure.patch
deleted file mode 100644
index ec8d2a3bbdd0..000000000000
--- a/media-gfx/comix/files/comix-3.6.4-command-argument-closure.patch
+++ /dev/null
@@ -1,158 +0,0 @@
---- comix-3.6.4/comix.debug 2007-05-27 01:30:16.000000000 +0900
-+++ comix-3.6.4/comix 2008-04-02 20:11:53.000000000 +0900
-@@ -44,6 +44,9 @@
- import pwd
- import cPickle
-
-+import subprocess
-+import string
-+
- try:
- import pygtk
- pygtk.require('2.0')
-@@ -6277,9 +6280,12 @@
- archive = tarfile.open(path, 'r')
- files = archive.getnames()
- elif type == 'rar':
-+ #files = \
-+ #os.popen(self.rar + ' vb "' + path +
-+ #'"').readlines()
- files = \
-- os.popen(self.rar + ' vb "' + path +
-- '"').readlines()
-+ subprocess.Popen([self.rar, 'vb', path],
-+ stdout=subprocess.PIPE).communicate()[0].splitlines()
- files = [file.rstrip('\n') for file in files]
- cover = None
- files.sort()
-@@ -6302,9 +6308,20 @@
- break
- if cover != None:
- if type == 'rar':
-- os.popen(self.rar + ' p -inul -- "' + path + '" "' +
-- cover + '" > "' + thumb_dir +
-- '/temp" 2>/dev/null', "r").close()
-+ #os.popen(self.rar + ' p -inul -- "' + path + '" "' +
-+ #cover + '" > "' + thumb_dir +
-+ #'/temp" 2>/dev/null', "r").close()
-+ filen = thumb_dir + '/temp'
-+ try:
-+ os.remove(filen)
-+ except:
-+ pass
-+ fp = open(filen, 'w')
-+ fdp = fp.fileno()
-+ p = subprocess.Popen(
-+ [self.rar, 'p', '-inul', '--', path,
-+ cover ], stdout = fdp).wait()
-+ fp.close()
- image = Image.open(thumb_dir + '/temp')
- os.remove(thumb_dir + '/temp')
- elif type == 'zip':
-@@ -8733,8 +8750,10 @@
- # =======================================================
- elif archive_type == 'rar':
- if self.rar:
-- os.popen(
-- self.rar + ' x "' + src_path + '" "' + dst_path + '"')
-+ #os.popen(
-+ #self.rar + ' x "' + src_path + '" "' + dst_path + '"')
-+ subprocess.Popen(
-+ [self.rar, 'x', src_path, dst_path],stdout=sys.stdout).wait()
- else:
- self.statusbar.push(0,
- _('Could not find the unrar executable. Please install it if you wish to open RAR archives.'))
-@@ -9168,9 +9187,37 @@
- self.are_you_sure_dialog.hide()
- if response != -5:
- return
-- os.popen(self.jpegtran + ' -copy all -trim ' + operation +
-- ' -outfile "' + self.file[self.file_number] + '" "' +
-- self.file[self.file_number] + '"')
-+ #os.popen(self.jpegtran + ' -copy all -trim ' + operation +
-+ #' -outfile "' + self.file[self.file_number] + '" "' +
-+ #self.file[self.file_number] + '"')
-+ op = operation.split()
-+ op_len = len(op)
-+
-+ i=1
-+ filen = self.file[self.file_number]
-+ while (1):
-+ tmp_file = filen + '.tmp' + 'z' * i
-+ if os.path.exists(tmp_file):
-+ i += 1
-+ else:
-+ break
-+
-+ # Ugly hack :(
-+ if op_len == 2:
-+ p = subprocess.Popen(
-+ [self.jpegtran, '-copy', 'all', '-trim', op[0], op[1],
-+ '-outfile', tmp_file, filen],
-+ stdin=sys.stdin, stdout=sys.stdout)
-+ else:
-+ p = subprocess.Popen(
-+ [self.jpegtran, '-copy', 'all', '-trim', op[0],
-+ '-outfile', tmp_file, filen],
-+ stdin=sys.stdin, stdout=sys.stdout)
-+ p.wait()
-+ if p.returncode == 0:
-+ shutil.copymode(filen, tmp_file)
-+ shutil.copy(tmp_file, filen)
-+ os.remove(tmp_file)
- try:
- uri = 'file://' + urllib.pathname2url(self.file[self.file_number])
- thumb_path = md5.new()
---- comix-3.6.4/mime/comicthumb.debug 2007-05-27 01:30:16.000000000 +0900
-+++ comix-3.6.4/mime/comicthumb 2008-04-02 21:11:10.000000000 +0900
-@@ -22,6 +22,9 @@
- import StringIO
- import re
- import shutil
-+
-+import subprocess
-+
- try:
- import Image
- except:
-@@ -138,19 +141,35 @@
- if not rar:
- print "You must install unrar or rar to thumbnail RAR archives."
- sys.exit(1)
-- rarfiles = os.popen('%s vb "%s"' % (rar, compressed_file)).readlines()
-+ #rarfiles = os.popen('%s vb "%s"' % (rar, compressed_file)).readlines()
-+ rarfiles = subprocess.Popen([rar, 'vb', compressed_file],
-+ stdout=subprocess.PIPE).communicate()[0].splitlines()
- for i in range(len(rarfiles)):
- rarfiles[i] = rarfiles[i].rstrip("\n")
- rarfiles.sort()
- cover = guessCover(rarfiles)
- if cover:
-- picture = StringIO.StringIO(os.popen('%s p -inul -- "%s" "%s"'
-- % (rar, compressed_file, cover), "r").read())
-+ #picture = StringIO.StringIO(os.popen('%s p -inul -- "%s" "%s"'
-+ #% (rar, compressed_file, cover), "r").read())
-+ picture = StringIO.StringIO(subprocess.Popen(
-+ [rar, 'p', '-inul', '--', compressed_file, cover],
-+ stdout=subprocess.PIPE).stdout.read())
- else:
- subarchive = first_archive(rarfiles)
- if subarchive:
-- os.popen('%s p -inul -- "%s" "%s" > "/tmp/comicthumb/archive%d"'
-- % (rar, compressed_file, subarchive, depth), "r")
-+ #os.popen('%s p -inul -- "%s" "%s" > "/tmp/comicthumb/archive%d"'
-+ #% (rar, compressed_file, subarchive, depth), "r")
-+ filen = "/tmp/comicthumb/archive%d"%(depth)
-+ try:
-+ os.remove(filen)
-+ except:
-+ pass
-+ fp = open(filen, 'w')
-+ fdp = fp.fileno()
-+ subprocess.Popen(
-+ [rar, 'p', '-inul', '--', compressed_file, subarchive],
-+ stdout = fdp).wait()
-+ fp.close()
- return get_image("/tmp/comicthumb/archive%d" % (depth),
- depth + 1)
- return picture
diff --git a/media-gfx/comix/files/comix-3.6.4-tmpfile.patch b/media-gfx/comix/files/comix-3.6.4-tmpfile.patch
deleted file mode 100644
index e25cbf396024..000000000000
--- a/media-gfx/comix/files/comix-3.6.4-tmpfile.patch
+++ /dev/null
@@ -1,163 +0,0 @@
---- comix-3.6.4/comix.tmpfile 2008-04-03 01:23:35.000000000 +0900
-+++ comix-3.6.4/comix 2008-04-03 01:23:35.000000000 +0900
-@@ -47,6 +47,8 @@
- import subprocess
- import string
-
-+import tempfile
-+
- try:
- import pygtk
- pygtk.require('2.0')
-@@ -257,6 +259,8 @@
- window_height = 0
- colour_adjust_signal_kill = False
- colour_adjust_dialog_displayed = False
-+
-+ _tmp_dir = None
-
- def close_application(self, widget, event=None):
-
-@@ -270,8 +274,8 @@
- self.prefs['page of last file'] = self.file_number
- if os.path.exists(self.base_dir):
- shutil.rmtree(self.base_dir)
-- if len(os.listdir('/tmp/comix')) == 0:
-- shutil.rmtree('/tmp/comix')
-+ if len(os.listdir(self._tmp_dir)) == 0:
-+ shutil.rmtree(self._tmp_dir)
- self.exit = True
-
- # =======================================================
-@@ -369,9 +373,9 @@
- # =======================================================
- if os.path.exists(self.base_dir):
- shutil.rmtree(self.base_dir)
-- if os.path.isdir('/tmp/comix'):
-- if len(os.listdir('/tmp/comix')) == 0:
-- shutil.rmtree('/tmp/comix')
-+ if os.path.isdir(self._tmp_dir):
-+ if len(os.listdir(self._tmp_dir)) == 0:
-+ shutil.rmtree(self._tmp_dir)
-
-
- # =======================================================
-@@ -8027,7 +8031,7 @@
- return False
-
- # We don't want to open files from our selves.
-- if selection.data.startswith('file:///tmp/comix/'):
-+ if selection.data.startswith('file://' + self._tmp_dir):
- return
-
- uri = selection.data.strip()
-@@ -10543,15 +10547,20 @@
- # The dir is /tmp/comix/<num> where <num> is 1 or higher
- # depending on the number of Comix sessions opened.
- # =======================================================
-- if not os.path.exists('/tmp/comix/'):
-- os.makedirs('/tmp/comix/')
-- os.chmod('/tmp/comix/', 0700)
-+ #if not os.path.exists('/tmp/comix/'):
-+ # os.makedirs('/tmp/comix/')
-+ # os.chmod('/tmp/comix/', 0700)
-+
-+ self._tmp_dir = tempfile.mkdtemp(prefix='comix.', suffix=os.sep,
-+ dir = '/tmp')
-+ self._tmp_dir += "/"
-+
- dir_number = 1
- while 1:
-- if not os.path.exists('/tmp/comix/' + str(dir_number)):
-- os.mkdir('/tmp/comix/' + str(dir_number))
-- os.chmod('/tmp/comix/' + str(dir_number), 0700)
-- self.base_dir = '/tmp/comix/' + str(dir_number) + '/'
-+ if not os.path.exists(self._tmp_dir + str(dir_number)):
-+ os.mkdir(self._tmp_dir + str(dir_number))
-+ os.chmod(self._tmp_dir + str(dir_number), 0700)
-+ self.base_dir = self._tmp_dir + str(dir_number) + '/'
- break
- dir_number += 1
-
---- comix-3.6.4/mime/comicthumb.tmpfile 2008-04-03 01:23:35.000000000 +0900
-+++ comix-3.6.4/mime/comicthumb 2008-04-03 01:29:52.000000000 +0900
-@@ -24,6 +24,7 @@
- import shutil
-
- import subprocess
-+import tempfile
-
- try:
- import Image
-@@ -51,9 +52,13 @@
- sys.exit(1)
-
- # temp directory needed for multiple archives
--if not os.path.exists('/tmp/comicthumb/'):
-- os.makedirs('/tmp/comicthumb/')
-- os.chmod('/tmp/comicthumb/', 0700)
-+#if not os.path.exists('/tmp/comicthumb/'):
-+# os.makedirs('/tmp/comicthumb/')
-+# os.chmod('/tmp/comicthumb/', 0700)
-+_tmp_dir = tempfile.mkdtemp(prefix='comixthumb', suffix=os.sep,
-+ dir = '/tmp')
-+_tmp_dir += "/"
-+
-
- # return the first image in the list
- def first_image (filelist):
-@@ -104,10 +109,10 @@
- else:
- subarchive = first_archive(zipfiles)
- if subarchive:
-- output = open("/tmp/comicthumb/archive%d" % (depth), "wb")
-+ output = open( _tmp_dir + "archive%d" % (depth), "wb")
- output.write(zip.read(subarchive))
- output.close()
-- return get_image("/tmp/comicthumb/archive%d" % (depth),
-+ return get_image( _tmp_dir + "archive%d" % (depth),
- depth + 1)
- elif tarfile.is_tarfile(compressed_file):
- TYPE = TYPE or 'cbt'
-@@ -122,10 +127,10 @@
- else:
- subarchive = first_archive(tarfiles)
- if subarchive:
-- output = open("/tmp/comicthumb/archive%d" % (depth), "wb")
-+ output = open( _tmp_dir + "archive%d" % (depth), "wb")
- output.write(tar.extractfile(subarchive).read())
- output.close()
-- return get_image("/tmp/comicthumb/archive%d" % (depth),
-+ return get_image( _tmp_dir + "archive%d" % (depth),
- depth + 1)
- elif open(compressed_file, 'rb').read(4) == 'Rar!':
- TYPE = TYPE or 'cbr'
-@@ -159,7 +164,7 @@
- if subarchive:
- #os.popen('%s p -inul -- "%s" "%s" > "/tmp/comicthumb/archive%d"'
- #% (rar, compressed_file, subarchive, depth), "r")
-- filen = "/tmp/comicthumb/archive%d"%(depth)
-+ filen = _tmp_dir + "archive%d"%(depth)
- try:
- os.remove(filen)
- except:
-@@ -170,7 +175,7 @@
- [rar, 'p', '-inul', '--', compressed_file, subarchive],
- stdout = fdp).wait()
- fp.close()
-- return get_image("/tmp/comicthumb/archive%d" % (depth),
-+ return get_image( _tmp_dir + "archive%d" % (depth),
- depth + 1)
- return picture
-
-@@ -226,8 +231,8 @@
- exit_flag = 1
-
- # remove tempory stuff
--if os.path.isdir('/tmp/comicthumb/'):
-- shutil.rmtree('/tmp/comicthumb/')
-+if os.path.isdir(_tmp_dir):
-+ shutil.rmtree(_tmp_dir)
-
- # and exit
- sys.exit(exit_flag)