summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/kstreamripper/ChangeLog8
-rw-r--r--media-sound/kstreamripper/kstreamripper-0.3.4.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/media-sound/kstreamripper/ChangeLog b/media-sound/kstreamripper/ChangeLog
index e7b5e9881292..a5b8677eaa50 100644
--- a/media-sound/kstreamripper/ChangeLog
+++ b/media-sound/kstreamripper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kstreamripper
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kstreamripper/ChangeLog,v 1.12 2007/02/22 01:09:46 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kstreamripper/ChangeLog,v 1.13 2008/05/13 06:41:44 drac Exp $
+
+ 13 May 2008; Samuli Suominen <drac@gentoo.org> kstreamripper-0.3.4.ebuild:
+ Stop passing CFLAGS for g++ and MAKEOPTS because scons is stupid wrt
+ #220393.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild b/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild
index 07d3edabf5eb..db4f833031a5 100644
--- a/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild
+++ b/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild,v 1.3 2006/02/24 17:18:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kstreamripper/kstreamripper-0.3.4.ebuild,v 1.4 2008/05/13 06:41:44 drac Exp $
inherit kde
@@ -23,9 +23,9 @@ need-kde 3.2
src_compile() {
local myconf="kdeincludes=$(kde-config --prefix)/include prefix=/usr"
use amd64 && myconf="${myconf} libsuffix=64"
-
+ unset CFLAGS # freaking scons is passing CFLAGS into g++
scons configure ${myconf} || die "configure failed"
- scons ${MAKEOPTS} || die "scons failed"
+ scons || die "scons failed"
}
src_install() {