summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/text-hyphen/ChangeLog8
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild4
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.0.0-r3.ebuild33
3 files changed, 42 insertions, 3 deletions
diff --git a/dev-ruby/text-hyphen/ChangeLog b/dev-ruby/text-hyphen/ChangeLog
index 842bd850c582..36db7049adfe 100644
--- a/dev-ruby/text-hyphen/ChangeLog
+++ b/dev-ruby/text-hyphen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/text-hyphen
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/ChangeLog,v 1.23 2010/08/29 18:02:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/ChangeLog,v 1.24 2010/10/06 17:54:39 graaff Exp $
+
+*text-hyphen-1.0.0-r3 (06 Oct 2010)
+
+ 06 Oct 2010; Hans de Graaff <graaff@gentoo.org>
+ text-hyphen-1.0.0-r2.ebuild, +text-hyphen-1.0.0-r3.ebuild:
+ Revision bump to create a revision ready for stabilization without ruby19.
29 Aug 2010; Raúl Porcel <armin76@gentoo.org>
text-hyphen-1.0.0-r1.ebuild:
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild
index 60029bc04cd5..bf999f0526da 100644
--- a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild
+++ b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild,v 1.1 2010/08/01 18:33:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild,v 1.2 2010/10/06 17:54:39 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README Changelog"
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r3.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..e1f6d49d1d63
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r3.ebuild,v 1.1 2010/10/06 17:54:39 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README Changelog"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Hyphenates various words according to the rules of the language the word is written in."
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+SRC_URI="mirror://rubyforge/text-format/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/archive-tar-minitar
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Fix rakefile for new rake versions
+ sed -i -e 's: if t\.verbose::' Rakefile || die
+
+ epatch "${FILESDIR}/${P}+ruby-1.9.patch"
+}