summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/point2play/ChangeLog9
-rw-r--r--app-emulation/point2play/files/digest-point2play-2.0.11
-rw-r--r--app-emulation/point2play/point2play-2.0.1.ebuild42
3 files changed, 50 insertions, 2 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 38949fe38cc6..1dfcff37c16f 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/point2play
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.17 2005/03/08 23:20:29 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.18 2005/06/08 01:04:47 vapier Exp $
+
+*point2play-2.0.1 (08 Jun 2005)
+
+ 08 Jun 2005; Mike Frysinger <vapier@gentoo.org> +point2play-2.0.1.ebuild:
+ Version bump #95376 by Mike Hepple.
*point2play-1.3.3 (08 Mar 2005)
diff --git a/app-emulation/point2play/files/digest-point2play-2.0.1 b/app-emulation/point2play/files/digest-point2play-2.0.1
new file mode 100644
index 000000000000..1bfd98570f8c
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-2.0.1
@@ -0,0 +1 @@
+MD5 8c3a22d57b897ecc9c6ec82ec9df0c6b point2play-small-2.0.1.tgz 1270826
diff --git a/app-emulation/point2play/point2play-2.0.1.ebuild b/app-emulation/point2play/point2play-2.0.1.ebuild
new file mode 100644
index 000000000000..384fdc581e39
--- /dev/null
+++ b/app-emulation/point2play/point2play-2.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-2.0.1.ebuild,v 1.1 2005/06/08 01:04:47 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4"
+ #>=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.3.2-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr "${D}"/ || die "mv usr"
+ mv etc/X11/applnk "${D}"/usr/share
+ make_desktop_entry Point2Play Point2Play /usr/lib/transgaming_point2play/pixmaps/tg_logo.png
+}