summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/ant-testutil/ChangeLog8
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.8.2.ebuild31
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.8.4.ebuild31
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.9.1.ebuild36
4 files changed, 6 insertions, 100 deletions
diff --git a/dev-java/ant-testutil/ChangeLog b/dev-java/ant-testutil/ChangeLog
index 0feba0a3aeb8..09263302a4fd 100644
--- a/dev-java/ant-testutil/ChangeLog
+++ b/dev-java/ant-testutil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-testutil
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.25 2014/03/08 16:27:31 tomwij Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.26 2015/07/09 21:12:58 chewi Exp $
+
+ 09 Jul 2015; James Le Cuirot <chewi@gentoo.org> -ant-testutil-1.8.2.ebuild,
+ -ant-testutil-1.8.4.ebuild, -ant-testutil-1.9.1.ebuild:
+ Remove old versions.
08 Mar 2014; Tom Wijsman <TomWij@gentoo.org> -ant-testutil-1.8.0.ebuild,
-ant-testutil-1.8.1.ebuild:
diff --git a/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild b/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild
deleted file mode 100644
index 7ed200ba848b..000000000000
--- a/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild,v 1.3 2012/05/25 11:30:03 ago Exp $
-
-EAPI="4"
-
-inherit ant-tasks
-
-DESCRIPTION="Apache Ant's optional test utility classes"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-DEPEND="virtual/jdk:1.6
- dev-java/junit:4
- ~dev-java/ant-swing-${PV}
- ~dev-java/ant-junit4-${PV}"
-RDEPEND=""
-
-IUSE=""
-
-# the build system builds much more than it actually packages, so there are many
-# build-only deps, but since those are quite common, it wasn't worth to patch it
-
-src_unpack() {
- ant-tasks_src_unpack base
- java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
- java-pkg_jar-from --build-only ant-core ant-launcher.jar
-}
-
-src_compile() {
- eant test-jar
-}
diff --git a/dev-java/ant-testutil/ant-testutil-1.8.4.ebuild b/dev-java/ant-testutil/ant-testutil-1.8.4.ebuild
deleted file mode 100644
index a522c705867f..000000000000
--- a/dev-java/ant-testutil/ant-testutil-1.8.4.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.8.4.ebuild,v 1.5 2012/12/05 17:33:44 ago Exp $
-
-EAPI="4"
-
-inherit ant-tasks
-
-DESCRIPTION="Apache Ant's optional test utility classes"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-DEPEND="virtual/jdk:1.6
- dev-java/junit:4
- ~dev-java/ant-swing-${PV}
- ~dev-java/ant-junit4-${PV}"
-RDEPEND=""
-
-IUSE=""
-
-# the build system builds much more than it actually packages, so there are many
-# build-only deps, but since those are quite common, it wasn't worth to patch it
-
-src_unpack() {
- ant-tasks_src_unpack base
- java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
- java-pkg_jar-from --build-only ant-core ant-launcher.jar
-}
-
-src_compile() {
- eant test-jar
-}
diff --git a/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild b/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild
deleted file mode 100644
index 295106017867..000000000000
--- a/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild,v 1.1 2013/07/05 14:28:11 tomwij Exp $
-
-EAPI="5"
-
-inherit ant-tasks
-
-DESCRIPTION="Apache Ant's optional test utility classes"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux \
- ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris \
- ~x64-solaris ~x86-solaris"
-
-CDEPEND="dev-java/ant-core:0"
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.6
- >=dev-java/junit-4.11:4
- ~dev-java/ant-swing-${PV}
- ~dev-java/ant-junit4-${PV}"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-# The build system builds much more than it actually packages, so there are many
-# build-only deps, but since those are quite common, it wasn't worth to patch it.
-
-src_unpack() {
- ant-tasks_src_unpack base
- java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
- java-pkg_jar-from --build-only ant-core ant-launcher.jar
-}
-
-src_compile() {
- eant test-jar
-}