summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/shish/Manifest12
-rw-r--r--app-shells/shish/shish-0.7_pre3.ebuild15
2 files changed, 8 insertions, 19 deletions
diff --git a/app-shells/shish/Manifest b/app-shells/shish/Manifest
index f73354a1ff54..885ab39dcaff 100644
--- a/app-shells/shish/Manifest
+++ b/app-shells/shish/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 b55bfb88b955107a0f0e6c5aaef21723 metadata.xml 162
-MD5 a5d7e6c47b19aefc9966cd4c202a7508 shish-0.7_pre3.ebuild 994
+MD5 0e63c247d314422447a706d04e9925d4 shish-0.7_pre3.ebuild 1020
MD5 9fe91ed4c9f254b7c15bf03482b8faff ChangeLog 371
MD5 e757d2d1cac83cfb7cb0ffe0c49ef5f4 files/digest-shish-0.7_pre3 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDO4MWmPFBzbX68WERAhCdAKCK97BVJETyS7KnXVGKnEZj8pRFUgCffiHA
-EIAPOJZqErx1xIkPGjEcArk=
-=hmJ8
------END PGP SIGNATURE-----
diff --git a/app-shells/shish/shish-0.7_pre3.ebuild b/app-shells/shish/shish-0.7_pre3.ebuild
index 795d6490d6b2..fd83da7909af 100644
--- a/app-shells/shish/shish-0.7_pre3.ebuild
+++ b/app-shells/shish/shish-0.7_pre3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/shish/shish-0.7_pre3.ebuild,v 1.1 2005/09/29 05:58:55 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/shish/shish-0.7_pre3.ebuild,v 1.2 2005/10/01 13:44:42 hollow Exp $
inherit toolchain-funcs
@@ -20,11 +20,12 @@ DEPEND="diet? ( dev-libs/dietlibc )"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use diet && export CC="diet $(tc-getCC) -nostdinc"
+}
+
src_compile() {
- useq diet && export DIET="diet"
- econf \
- $(use_enable debug) \
- || die "econf failed"
+ econf $(use_enable debug) || die "econf failed"
# parallel make is b0rked
emake -j1 || die "emake failed"
@@ -38,8 +39,6 @@ src_install() {
pkg_postinst() {
einfo "Updating /etc/shells"
- { grep -v "^/bin/shish$" /etc/shells;
- echo "/bin/shish"
- } > ${T}/shells
+ ( grep -v "^/bin/shish$" /etc/shells; echo "/bin/shish" ) > ${T}/shells
mv -f ${T}/shells /etc/shells
}