summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/ccolamd/ChangeLog9
-rw-r--r--sci-libs/ccolamd/ccolamd-2.7.3.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/sci-libs/ccolamd/ChangeLog b/sci-libs/ccolamd/ChangeLog
index ac0ca125006b..c870f22573a3 100644
--- a/sci-libs/ccolamd/ChangeLog
+++ b/sci-libs/ccolamd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/ccolamd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ChangeLog,v 1.15 2010/12/25 18:49:18 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ChangeLog,v 1.16 2011/02/23 19:50:06 bicatali Exp $
+
+*ccolamd-2.7.3 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +ccolamd-2.7.3.ebuild:
+ Bump
25 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> ccolamd-2.7.1.ebuild:
Added static-libs flag
diff --git a/sci-libs/ccolamd/ccolamd-2.7.3.ebuild b/sci-libs/ccolamd/ccolamd-2.7.3.ebuild
new file mode 100644
index 000000000000..0856acfe7fed
--- /dev/null
+++ b/sci-libs/ccolamd/ccolamd-2.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ccolamd-2.7.3.ebuild,v 1.1 2011/02/23 19:50:06 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=CCOLAMD
+DESCRIPTION="Constrained column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ccolamd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.7.1-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}