summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/polkit/ChangeLog5
-rw-r--r--sys-auth/polkit/polkit-0.112-r1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 0f7bedbaa1ec..0e516192b111 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.160 2013/09/23 19:17:01 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.161 2013/12/24 13:58:53 blueness Exp $
+
+ 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
+ Fix dependence on spidermonkey for mips, bug #495168
23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
Stable for sparc, wrt bug #484486
diff --git a/sys-auth/polkit/polkit-0.112-r1.ebuild b/sys-auth/polkit/polkit-0.112-r1.ebuild
index a912a7b88502..9c38bdfbd9fe 100644
--- a/sys-auth/polkit/polkit-0.112-r1.ebuild
+++ b/sys-auth/polkit/polkit-0.112-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.112-r1.ebuild,v 1.1 2013/09/19 17:08:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.112-r1.ebuild,v 1.2 2013/12/24 13:58:53 blueness Exp $
EAPI=5
inherit eutils multilib pam pax-utils systemd user
@@ -15,6 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="examples gtk +introspection kde nls pam selinux systemd"
RDEPEND="ia64? ( =dev-lang/spidermonkey-1.8.5*[-debug] )
+ mips? ( =dev-lang/spidermonkey-1.8.5*[-debug] )
!ia64? ( dev-lang/spidermonkey:17[-debug] )
>=dev-libs/glib-2.32
>=dev-libs/expat-2:=
@@ -68,6 +69,7 @@ src_configure() {
--disable-examples \
$(use_enable nls) \
$(usex ia64 --with-mozjs=mozjs185 --with-mozjs=mozjs-17.0) \
+ $(usex mips --with-mozjs=mozjs185 --with-mozjs=mozjs-17.0) \
"$(systemd_with_unitdir)" \
--with-authfw=$(usex pam pam shadow) \
$(use pam && echo --with-pam-module-dir="$(getpam_mod_dir)") \
@@ -80,8 +82,9 @@ src_compile() {
# Required for polkitd on hardened/PaX due to spidermonkey's JIT
local f='src/polkitbackend/.libs/polkitd test/polkitbackend/.libs/polkitbackendjsauthoritytest'
local m='m'
- # ia64 uses spidermonkey-1.8.5 which requires different pax-mark flags
+ # ia64 and mips uses spidermonkey-1.8.5 which requires different pax-mark flags
use ia64 && m='mr'
+ use mips && m='mr'
pax-mark ${m} ${f}
}