summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/acpid/ChangeLog5
-rw-r--r--sys-power/acpid/acpid-2.0.16-r1.ebuild7
-rw-r--r--sys-power/acpid/acpid-2.0.17.ebuild7
3 files changed, 14 insertions, 5 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 683da3c5a661..f7c1be26302b 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.96 2012/11/19 09:31:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.97 2012/11/25 15:11:36 swift Exp $
+
+ 25 Nov 2012; <swift@gentoo.org> acpid-2.0.16-r1.ebuild, acpid-2.0.17.ebuild:
+ Adding optional SELinux apm module dependency
19 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> acpid-2.0.16-r1.ebuild,
acpid-2.0.17.ebuild:
diff --git a/sys-power/acpid/acpid-2.0.16-r1.ebuild b/sys-power/acpid/acpid-2.0.16-r1.ebuild
index 9a4fcd5c0e8a..8efa2c25f002 100644
--- a/sys-power/acpid/acpid-2.0.16-r1.ebuild
+++ b/sys-power/acpid/acpid-2.0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.16-r1.ebuild,v 1.5 2012/11/19 09:31:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.16-r1.ebuild,v 1.6 2012/11/25 15:11:36 swift Exp $
EAPI=4
inherit systemd
@@ -12,7 +12,10 @@ SRC_URI="http://tedfelix.com/linux/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ia64 -ppc x86"
-IUSE=""
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND="${RDEPEND}"
src_configure() {
econf --docdir=/usr/share/doc/${PF}
diff --git a/sys-power/acpid/acpid-2.0.17.ebuild b/sys-power/acpid/acpid-2.0.17.ebuild
index d1b0a76a93d7..005fbf1e2fef 100644
--- a/sys-power/acpid/acpid-2.0.17.ebuild
+++ b/sys-power/acpid/acpid-2.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.17.ebuild,v 1.4 2012/11/19 09:31:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.17.ebuild,v 1.5 2012/11/25 15:11:36 swift Exp $
EAPI=4
inherit systemd
@@ -12,7 +12,10 @@ SRC_URI="http://tedfelix.com/linux/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ia64 -ppc x86"
-IUSE=""
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND="${RDEPEND}"
src_configure() {
econf --docdir=/usr/share/doc/${PF}