summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/py/ChangeLog6
-rw-r--r--dev-python/py/py-1.3.1.ebuild25
-rw-r--r--dev-python/py/py-1.3.3.ebuild42
3 files changed, 5 insertions, 68 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index 5f6eae04f08a..f8303ae71f19 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/py
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.69 2010/12/27 20:58:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.70 2010/12/27 21:04:40 arfrever Exp $
+
+ 27 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -py-1.3.1.ebuild, -py-1.3.3.ebuild:
+ Delete.
27 Dec 2010; Brent Baude <ranger@gentoo.org> py-1.3.4.ebuild:
Marking py-1.3.4 ppc64 for bug 341335
diff --git a/dev-python/py/py-1.3.1.ebuild b/dev-python/py/py-1.3.1.ebuild
deleted file mode 100644
index 3792fbb787a2..000000000000
--- a/dev-python/py/py-1.3.1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.3.1.ebuild,v 1.12 2010/10/03 14:34:03 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="A library aiming to support agile and test-driven python development on various levels."
-HOMEPAGE="http://codespeak.net/py/ http://pypi.python.org/pypi/py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${D%/}${EPREFIX}/usr/bin/py.test"
-}
diff --git a/dev-python/py/py-1.3.3.ebuild b/dev-python/py/py-1.3.3.ebuild
deleted file mode 100644
index c6b2cea14888..000000000000
--- a/dev-python/py/py-1.3.3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.3.3.ebuild,v 1.7 2010/10/09 17:06:41 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="A library aiming to support agile and test-driven python development on various levels."
-HOMEPAGE="http://codespeak.net/py/ http://pypi.python.org/pypi/py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- rm -f testing/path/test_svnwc.py
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" bin/py.test
-
- # Ignore test failures.
- :
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-}