summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/automake/ChangeLog8
-rw-r--r--sys-devel/automake/automake-1.9.6-r2.ebuild56
-rw-r--r--sys-devel/automake/files/automake-1.9.6-ignore-comments.patch29
-rw-r--r--sys-devel/automake/files/digest-automake-1.9.6-r21
4 files changed, 93 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 8d9812ae6860..c9fe417c509b 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.78 2006/03/23 09:29:41 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.79 2006/03/24 00:09:37 vapier Exp $
+
+*automake-1.9.6-r2 (24 Mar 2006)
+
+ 24 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/automake-1.9.6-ignore-comments.patch, +automake-1.9.6-r2.ebuild:
+ Ignore m4 macros present in comments #126388 by Donnie Berkholz.
23 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>;
automake-1.9.6-r1.ebuild:
diff --git a/sys-devel/automake/automake-1.9.6-r2.ebuild b/sys-devel/automake/automake-1.9.6-r2.ebuild
new file mode 100644
index 000000000000..ae99b0c7da24
--- /dev/null
+++ b/sys-devel/automake/automake-1.9.6-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r2.ebuild,v 1.1 2006/03/24 00:09:39 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://sources.redhat.com/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV:0:3}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-devel/automake-wrapper
+ >=sys-devel/autoconf-2.59-r6
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^@setfilename/s|automake|automake${SLOT}|" \
+ -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
+ -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-1.9.6-infopage-namechange.patch
+ epatch "${FILESDIR}"/${P}-include-dir-prefix.patch #107435
+ epatch "${FILESDIR}"/${P}-ignore-comments.patch #126388
+ export WANT_AUTOCONF=2.5
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ local x
+ for x in aclocal automake ; do
+ help2man ${x} > ${x}.1
+ doman ${x}.1
+ rm -f "${D}"/usr/bin/${x}
+ done
+
+ dodoc NEWS README THANKS TODO AUTHORS ChangeLog
+ doinfo doc/*.info*
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}
diff --git a/sys-devel/automake/files/automake-1.9.6-ignore-comments.patch b/sys-devel/automake/files/automake-1.9.6-ignore-comments.patch
new file mode 100644
index 000000000000..f62987456cfe
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.9.6-ignore-comments.patch
@@ -0,0 +1,29 @@
+http://bugs.gentoo.org/126388
+
+2006-03-16 Mike Frysinger <vapier@gentoo.org>
+
+ * aclocal.in (scan_configure_dep): Ignore ## lines.
+ (scan_file): Remove dnl and # comments.
+
+--- aclocal.in
++++ aclocal.in
+@@ -227,6 +227,8 @@
+ foreach (split ("\n", $contents))
+ {
+ ++$line;
++ # Ignore `##' lines.
++ next if /^##/;
+ # Remove comments from current line.
+ s/\bdnl\b.*$//;
+ s/\#.*$//;
+@@ -311,6 +313,10 @@
+
+ $contents .= $_;
+
++ # Remove comments from current line.
++ s/\bdnl\b.*$//;
++ s/\#.*$//;
++
+ while (/$ac_defun_rx/go)
+ {
+ if (! defined $1)
diff --git a/sys-devel/automake/files/digest-automake-1.9.6-r2 b/sys-devel/automake/files/digest-automake-1.9.6-r2
new file mode 100644
index 000000000000..3fe57a5cad3e
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.9.6-r2
@@ -0,0 +1 @@
+MD5 c11b8100bb311492d8220378fd8bf9e0 automake-1.9.6.tar.bz2 765505