summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/hg-git/ChangeLog9
-rw-r--r--dev-vcs/hg-git/hg-git-0.5.0.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-vcs/hg-git/ChangeLog b/dev-vcs/hg-git/ChangeLog
index 92f37e6f1737..fb44c437dc87 100644
--- a/dev-vcs/hg-git/ChangeLog
+++ b/dev-vcs/hg-git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hg-git
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.49 2013/06/25 12:56:36 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.50 2014/01/06 09:54:27 grobian Exp $
+
+*hg-git-0.5.0 (06 Jan 2014)
+
+ 06 Jan 2014; Fabian Groffen <grobian@gentoo.org> +hg-git-0.5.0.ebuild:
+ Version bump, bug #496064
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> hg-git-0.4.0.ebuild:
Stable for amd64, wrt bug #472864
diff --git a/dev-vcs/hg-git/hg-git-0.5.0.ebuild b/dev-vcs/hg-git/hg-git-0.5.0.ebuild
new file mode 100644
index 000000000000..0511c93f1f4e
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.5.0.ebuild,v 1.1 2014/01/06 09:54:27 grobian Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit eutils distutils
+
+DESCRIPTION="push and pull from a Git server using Mercurial"
+HOMEPAGE="http://hg-git.github.com/ http://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-vcs/mercurial-1.9
+ >=dev-python/dulwich-0.9.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="hggit"