summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-sci/babel/babel-1.6.ebuild2
-rw-r--r--app-sci/euler/euler-1.59.1.ebuild7
-rw-r--r--app-sci/gperiodic/gperiodic-1.3.2.ebuild26
-rw-r--r--app-sci/gromacs/gromacs-3.1.3.ebuild2
-rw-r--r--app-sci/magic/magic-7.1-r1.ebuild4
-rw-r--r--app-sci/moldy/moldy-2.16e.ebuild41
-rw-r--r--app-sci/pymol/pymol-0.82.ebuild12
-rw-r--r--app-sci/qcad/qcad-1.4.7.ebuild6
-rw-r--r--app-sci/rasmol/rasmol-2.6_beta2.ebuild7
-rw-r--r--app-sci/scilab/scilab-2.6.ebuild25
-rw-r--r--app-sci/setiathome/setiathome-3.03-r1.ebuild4
-rw-r--r--app-sci/units/units-1.74.ebuild2
-rw-r--r--app-shells/bash-completion/bash-completion-20020624.ebuild10
-rw-r--r--app-shells/bash-completion/bash-completion-20020727.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20020812.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20020819.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021007.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021013.ebuild6
-rw-r--r--app-shells/bash-completion/bash-completion-20021017.ebuild6
-rw-r--r--app-shells/psh/psh-0.009-r1.ebuild10
-rw-r--r--app-shells/sash/sash-3.4-r3.ebuild4
-rw-r--r--app-shells/sash/sash-3.4-r4.ebuild12
-rw-r--r--app-shells/sash/sash-3.4-r5.ebuild11
-rw-r--r--app-shells/scsh/scsh-0.6.1-r1.ebuild4
-rw-r--r--app-shells/tcsh/tcsh-6.10-r3.ebuild23
25 files changed, 107 insertions, 141 deletions
diff --git a/app-sci/babel/babel-1.6.ebuild b/app-sci/babel/babel-1.6.ebuild
index 932647c81322..68d49a6b4093 100644
--- a/app-sci/babel/babel-1.6.ebuild
+++ b/app-sci/babel/babel-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $ Header: $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/babel/babel-1.6.ebuild,v 1.6 2002/10/17 14:26:47 vapier Exp $
S=${WORKDIR}/${P}
diff --git a/app-sci/euler/euler-1.59.1.ebuild b/app-sci/euler/euler-1.59.1.ebuild
index 80d27988d311..595f22bb4eca 100644
--- a/app-sci/euler/euler-1.59.1.ebuild
+++ b/app-sci/euler/euler-1.59.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/euler/euler-1.59.1.ebuild,v 1.8 2002/10/04 05:00:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/euler/euler-1.59.1.ebuild,v 1.9 2002/10/17 14:26:47 vapier Exp $
S=${WORKDIR}/${P}
@@ -15,8 +15,8 @@ SLOT="0"
KEYWORDS="x86"
DEPEND="virtual/glibc
- virtual/x11
- =x11-libs/gtk+-1.2*"
+ virtual/x11
+ =x11-libs/gtk+-1.2*"
PROVIDE="app-misc/euler"
@@ -49,4 +49,3 @@ src_install () {
rm -rf ${D}/usr/share/euler/docs
dodoc ChangeLog README TODO
}
-
diff --git a/app-sci/gperiodic/gperiodic-1.3.2.ebuild b/app-sci/gperiodic/gperiodic-1.3.2.ebuild
index 8255008328ce..0eecc1e68e20 100644
--- a/app-sci/gperiodic/gperiodic-1.3.2.ebuild
+++ b/app-sci/gperiodic/gperiodic-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/gperiodic/gperiodic-1.3.2.ebuild,v 1.8 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gperiodic/gperiodic-1.3.2.ebuild,v 1.9 2002/10/17 14:26:47 vapier Exp $
IUSE="nls"
@@ -19,7 +19,7 @@ DEPEND=">=sys-libs/ncurses-5.2
PROVIDE="app-misc/gperiodic"
src_unpack() {
- unpack ${P}.tar.gz
+ unpack ${A}
cd ${S}
#Fix version number,comment out non-working lex inquiry
@@ -36,23 +36,23 @@ src_compile() {
myconf="--disable-nls"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
${myconf} || die
emake || die
}
src_install () {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
install || die
doman man/gperiodic.1
diff --git a/app-sci/gromacs/gromacs-3.1.3.ebuild b/app-sci/gromacs/gromacs-3.1.3.ebuild
index 661c8977335d..a1cd13433e3e 100644
--- a/app-sci/gromacs/gromacs-3.1.3.ebuild
+++ b/app-sci/gromacs/gromacs-3.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.1.3.ebuild,v 1.6 2002/10/17 14:26:47 vapier Exp $
DESCRIPTION="The ultimate Molecular Dynamics simulation package"
diff --git a/app-sci/magic/magic-7.1-r1.ebuild b/app-sci/magic/magic-7.1-r1.ebuild
index 68fe73860b07..eeca70cb1585 100644
--- a/app-sci/magic/magic-7.1-r1.ebuild
+++ b/app-sci/magic/magic-7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/magic/magic-7.1-r1.ebuild,v 1.1 2002/10/14 17:58:53 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/magic/magic-7.1-r1.ebuild,v 1.2 2002/10/17 14:26:47 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The VLSI design CAD tool"
diff --git a/app-sci/moldy/moldy-2.16e.ebuild b/app-sci/moldy/moldy-2.16e.ebuild
index 42d0551b53f6..b25b9d20a8da 100644
--- a/app-sci/moldy/moldy-2.16e.ebuild
+++ b/app-sci/moldy/moldy-2.16e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+# $Header: /var/cvsroot/gentoo-x86/app-sci/moldy/moldy-2.16e.ebuild,v 1.7 2002/10/17 14:26:47 vapier Exp $
IUSE="X"
@@ -15,15 +15,12 @@ SLOT="0"
KEYWORDS="x86"
DEPEND="virtual/glibc
- X? ( x11-base/xfree )"
+ X? ( x11-base/xfree )"
src_compile() {
+ local myconf
- local myconf
- if [ -z "`use X`" ]
- then
- myconf="--without-x"
- fi
+ use X || myconf="--without-x"
#Individuals may want to edit the OPT* variables below.
#From the READ.ME:
@@ -35,27 +32,23 @@ src_compile() {
#function arguments as restricted pointers which are not aliased to
#any other object". OPT is used for less preformance-critical modules
#and may be set to a lower level of optimization than OPT2.
-
- OPT=${CFLAGS} OPT2=${CFLAGS} \
- ./configure --prefix=/usr \
- --host=${CHOST} \
- ${myconf} || die
-
- emake || die
+
+ OPT=${CFLAGS} OPT2=${CFLAGS} \
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
make moldy.pdf || die
}
-src_install () {
-
+src_install() {
dodir /usr/bin
- make prefix=${D}/usr install || die
- rm Makefile.in configure.in config.h.in
- insinto /usr/share/${PN}/examples/
- doins *.in *.out control.*
- dodoc BENCHMARK COPYING READ.ME RELNOTES
+ make prefix=${D}/usr install || die
+ rm Makefile.in configure.in config.h.in
+ insinto /usr/share/${PN}/examples/
+ doins *.in *.out control.*
+ dodoc BENCHMARK COPYING READ.ME RELNOTES
insinto /usr/share/doc/${P}/pdf
newins moldy.pdf moldy-manual.pdf
-
}
-
-
diff --git a/app-sci/pymol/pymol-0.82.ebuild b/app-sci/pymol/pymol-0.82.ebuild
index 4f6cd4128702..751540af8aed 100644
--- a/app-sci/pymol/pymol-0.82.ebuild
+++ b/app-sci/pymol/pymol-0.82.ebuild
@@ -1,11 +1,11 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.82.ebuild,v 1.2 2002/10/04 05:01:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.82.ebuild,v 1.3 2002/10/17 14:26:47 vapier Exp $
-A="pymol-0_82-src.tgz"
+MY_P="pymol-0_82-src.tgz"
S="$WORKDIR/${P}"
DESCRIPTION="A Python-extensible molecular graphics system."
-SRC_URI="http://download.sourceforge.net/pymol/${A}"
+SRC_URI="http://download.sourceforge.net/pymol/${MY_P}"
HOMEPAGE="http://pymol.sf.net"
LICENSE="PSF-2.2"
SLOT="0"
@@ -17,8 +17,7 @@ DEPEND="dev-lang/python
dev-lang/tk
media-libs/libpng
sys-libs/zlib
- media-libs/glut
- "
+ media-libs/glut"
RDEPEND="${DEPEND}"
src_unpack() {
@@ -34,8 +33,7 @@ src_compile() {
}
-src_install()
-{
+src_install() {
local PYMOL_PATH=/usr/lib/pymol/${PV}
mkdir -p ${D}/usr/lib/pymol/${PV}
cp -a modules ${D}/usr/lib/pymol/${PV}
diff --git a/app-sci/qcad/qcad-1.4.7.ebuild b/app-sci/qcad/qcad-1.4.7.ebuild
index 143031d2c90d..f3290b41c864 100644
--- a/app-sci/qcad/qcad-1.4.7.ebuild
+++ b/app-sci/qcad/qcad-1.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-1.4.7.ebuild,v 1.4 2002/10/04 05:01:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-1.4.7.ebuild,v 1.5 2002/10/17 14:26:47 vapier Exp $
MY_P=${P}-src
S=${WORKDIR}/${MY_P}
@@ -18,11 +18,11 @@ DEPEND=">=dev-util/tmake-1.8-r1
src_compile() {
export QTDIR=/usr/qt/2
cd ${S}
- tmake qcad.pro -o Makefile
+ tmake qcad.pro -o Makefile
emake CXXFLAGS="$CXXFLAGS" || die
}
-src_install () {
+src_install() {
dobin qcad
dohtml -r doc
diff --git a/app-sci/rasmol/rasmol-2.6_beta2.ebuild b/app-sci/rasmol/rasmol-2.6_beta2.ebuild
index 2e34e805ff08..2f98b58e0d63 100644
--- a/app-sci/rasmol/rasmol-2.6_beta2.ebuild
+++ b/app-sci/rasmol/rasmol-2.6_beta2.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.6_beta2.ebuild,v 1.2 2002/07/25 16:18:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.6_beta2.ebuild,v 1.3 2002/10/17 14:26:47 vapier Exp $
DESCRIPTION="Free program which displays molecular structure."
HOMEPAGE="http://www.umass.edu/microbio/rasmol/index2.htm"
KEYWORDS="x86"
SLOT="0"
-LICENSE="Public"
-LICENSE="Domain"
-
+LICENSE="public-domain"
DEPEND="virtual/x11"
-
RDEPEND="${DEPEND}"
P0=rasmol_2.6b2
diff --git a/app-sci/scilab/scilab-2.6.ebuild b/app-sci/scilab/scilab-2.6.ebuild
index 6a0e54255a79..cd55005eb78d 100644
--- a/app-sci/scilab/scilab-2.6.ebuild
+++ b/app-sci/scilab/scilab-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.6.ebuild,v 1.5 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.6.ebuild,v 1.6 2002/10/17 14:26:47 vapier Exp $
IUSE="tcltk"
@@ -20,22 +20,19 @@ DEPEND="virtual/x11
src_compile() {
local myopts
- if [ "`use tcltk`" ]
- then
- myopts="--with-tk"
- fi
+ use tcltk && myopts="--with-tk"
./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myopts} || die "./configure failed"
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ ${myopts} || die "./configure failed"
# HOME must be set to prevent writing to /root directory
- export HOME=/var/tmp/portage/${P}/work
- make all || die
+ export HOME=/var/tmp/portage/${P}/work
+ make all || die
}
src_install () {
diff --git a/app-sci/setiathome/setiathome-3.03-r1.ebuild b/app-sci/setiathome/setiathome-3.03-r1.ebuild
index 90dbc8952e78..adc3afab6d5f 100644
--- a/app-sci/setiathome/setiathome-3.03-r1.ebuild
+++ b/app-sci/setiathome/setiathome-3.03-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/setiathome/setiathome-3.03-r1.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/setiathome/setiathome-3.03-r1.ebuild,v 1.8 2002/10/17 14:26:47 vapier Exp $
IUSE="X"
@@ -16,7 +16,7 @@ DEPEND=">=sys-apps/baselayout-1.8.0"
RDEPEND="X? ( x11-base/xfree )"
SLOT="0"
-LICENSE="proprietary"
+LICENSE="as-is"
KEYWORDS="x86 ppc"
src_unpack () {
diff --git a/app-sci/units/units-1.74.ebuild b/app-sci/units/units-1.74.ebuild
index af91aa305341..5063fa0e89d0 100644
--- a/app-sci/units/units-1.74.ebuild
+++ b/app-sci/units/units-1.74.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $ Header: $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/units/units-1.74.ebuild,v 1.6 2002/10/17 14:26:47 vapier Exp $
S=${WORKDIR}/${P}
diff --git a/app-shells/bash-completion/bash-completion-20020624.ebuild b/app-shells/bash-completion/bash-completion-20020624.ebuild
index 86336b3ec076..f776006dceba 100644
--- a/app-shells/bash-completion/bash-completion-20020624.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020624.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020624.ebuild,v 1.10 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020624.ebuild,v 1.11 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,11 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
-
+src_install() {
insinto /etc
doins bash_completion
@@ -35,15 +34,12 @@ src_install () {
doins ${FILESDIR}/bash-completion
dodoc COPYING Changelog README
-
}
pkg_postinst() {
-
echo
einfo "Add the following line to your ~/.bashrc to"
einfo "activate completion support in your bash:"
einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
echo
-
}
diff --git a/app-shells/bash-completion/bash-completion-20020727.ebuild b/app-shells/bash-completion/bash-completion-20020727.ebuild
index 0eedd73cfd63..8b2d72a1a2e2 100644
--- a/app-shells/bash-completion/bash-completion-20020727.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020727.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020727.ebuild,v 1.4 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020727.ebuild,v 1.5 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20020812.ebuild b/app-shells/bash-completion/bash-completion-20020812.ebuild
index a24eec8aaab5..703e226026d8 100644
--- a/app-shells/bash-completion/bash-completion-20020812.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020812.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020812.ebuild,v 1.4 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020812.ebuild,v 1.5 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20020819.ebuild b/app-shells/bash-completion/bash-completion-20020819.ebuild
index 20c19c4a1c9e..c5ae6d605f89 100644
--- a/app-shells/bash-completion/bash-completion-20020819.ebuild
+++ b/app-shells/bash-completion/bash-completion-20020819.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020819.ebuild,v 1.2 2002/10/04 20:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020819.ebuild,v 1.3 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021007.ebuild b/app-shells/bash-completion/bash-completion-20021007.ebuild
index cf7a5e1cfe5e..b37be4a3de9d 100644
--- a/app-shells/bash-completion/bash-completion-20021007.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021007.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021007.ebuild,v 1.1 2002/10/12 10:02:18 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021007.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021013.ebuild b/app-shells/bash-completion/bash-completion-20021013.ebuild
index 126d4bfe6dc9..48bd815f3e95 100644
--- a/app-shells/bash-completion/bash-completion-20021013.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021013.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021013.ebuild,v 1.1 2002/10/14 21:12:47 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021013.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20021017.ebuild b/app-shells/bash-completion/bash-completion-20021017.ebuild
index 0f1bc2949b06..d4a608a57d42 100644
--- a/app-shells/bash-completion/bash-completion-20021017.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021017.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.1 2002/10/17 13:49:18 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.2 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${PN/-/_}
@@ -11,10 +11,10 @@ KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
SLOT="0"
-DEPEND=""
+DEPEND="sys-apps/tar sys-apps/bzip2"
RDEPEND=">=sys-apps/bash-2.05a"
-src_install () {
+src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/psh/psh-0.009-r1.ebuild b/app-shells/psh/psh-0.009-r1.ebuild
index c075ff4fffa4..8f979c15367e 100644
--- a/app-shells/psh/psh-0.009-r1.ebuild
+++ b/app-shells/psh/psh-0.009-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.7 2002/10/04 05:02:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
@@ -19,10 +19,10 @@ src_compile() {
}
src_install() {
- make PREFIX=${D}/usr \
- prefix=${D}/usr \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- install || die
+ make PREFIX=${D}/usr \
+ prefix=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
dodoc COPYRIGHT HACKING MANIFEST README* RELEASE TODO
dodoc examples/complete-examples
diff --git a/app-shells/sash/sash-3.4-r3.ebuild b/app-shells/sash/sash-3.4-r3.ebuild
index ebf29d8728cb..869f54fd3233 100644
--- a/app-shells/sash/sash-3.4-r3.ebuild
+++ b/app-shells/sash/sash-3.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.12 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.13 2002/10/17 14:31:29 vapier Exp $
IUSE="readline static"
@@ -18,7 +18,7 @@ fi
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
KEYWORDS="x86 ppc sparc sparc64"
diff --git a/app-shells/sash/sash-3.4-r4.ebuild b/app-shells/sash/sash-3.4-r4.ebuild
index 0ac6b1ee810b..f59f68cab335 100644
--- a/app-shells/sash/sash-3.4-r4.ebuild
+++ b/app-shells/sash/sash-3.4-r4.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r4.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r4.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
IUSE="readline"
S=${WORKDIR}/${P}
DESCRIPTION="A small static UNIX Shell with readline suppport"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
- http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
@@ -18,6 +18,7 @@ DEPEND="virtual/glibc
RDEPEND=""
KEYWORDS="x86 ppc sparc sparc64"
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -35,18 +36,13 @@ src_unpack() {
}
src_compile() {
-
make || die
-
}
src_install() {
-
into /
dobin sash
into /usr
doman sash.1
dodoc README
-
}
-
diff --git a/app-shells/sash/sash-3.4-r5.ebuild b/app-shells/sash/sash-3.4-r5.ebuild
index 145e80bd134a..910016088ca9 100644
--- a/app-shells/sash/sash-3.4-r5.ebuild
+++ b/app-shells/sash/sash-3.4-r5.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.9 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.10 2002/10/17 14:31:29 vapier Exp $
IUSE="readline"
S=${WORKDIR}/${P}
DESCRIPTION="A small static UNIX Shell with readline support"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
- http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SLOT="0"
-LICENSE="Freeware"
+LICENSE="freedist"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.4
@@ -36,18 +36,13 @@ src_unpack() {
}
src_compile() {
-
make || die
-
}
src_install() {
-
into /
dobin sash
into /usr
doman sash.1
dodoc README
-
}
-
diff --git a/app-shells/scsh/scsh-0.6.1-r1.ebuild b/app-shells/scsh/scsh-0.6.1-r1.ebuild
index c8779f7981d1..7a5fb299f6b3 100644
--- a/app-shells/scsh/scsh-0.6.1-r1.ebuild
+++ b/app-shells/scsh/scsh-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1-r1.ebuild,v 1.7 2002/10/04 05:02:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1-r1.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Scsh is a Unix shell embedded in Scheme"
@@ -8,7 +8,7 @@ SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/${P}.tar.gz"
HOMEPAGE="http://www.scsh.net/"
SLOT="0"
-LICENSE="as-is | BSD | GPL"
+LICENSE="as-is | BSD | GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
DEPEND="virtual/glibc"
diff --git a/app-shells/tcsh/tcsh-6.10-r3.ebuild b/app-shells/tcsh/tcsh-6.10-r3.ebuild
index bf168d71a823..1e6099aa79ab 100644
--- a/app-shells/tcsh/tcsh-6.10-r3.ebuild
+++ b/app-shells/tcsh/tcsh-6.10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
IUSE="perl"
@@ -12,20 +12,19 @@ SRC_URI="ftp://ftp.gw.com/pub/unix/tcsh/${P}.tar.gz
HOMEPAGE="http://www.tcsh.org/"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.1
- perl? ( sys-devel/perl )"
+ perl? ( sys-devel/perl )"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="BSD"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
}
src_compile() {
-
./configure \
--prefix=/ \
--mandir=/usr/share/man \
@@ -38,17 +37,13 @@ src_compile() {
src_install() {
make DESTDIR=${D} install install.man || die
- if [ "`use perl`" ]
- then
- perl tcsh.man2html || die
- dohtml tcsh.html/*.html
- fi
+ if [ "`use perl`" ]; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
dosym tcsh /bin/csh
dodoc FAQ Fixes NewThings Ported README WishList Y2K
insinto /etc
doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
}
-
-
-