summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/nspluginwrapper/ChangeLog19
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fix-npident-array-sending.patch178
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fortify.patch19
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-gdk-native-windows.patch13
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-inst-crash.patch12
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-ldflags.patch22
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-make.patch51
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-offsetof.patch11
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.0.0.ebuild81
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.2.2.ebuild84
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.3.0.ebuild (renamed from www-plugins/nspluginwrapper/nspluginwrapper-1.2.2-r1.ebuild)24
11 files changed, 340 insertions, 174 deletions
diff --git a/www-plugins/nspluginwrapper/ChangeLog b/www-plugins/nspluginwrapper/ChangeLog
index fcbfb0b9c1c6..a9bc623f8fed 100644
--- a/www-plugins/nspluginwrapper/ChangeLog
+++ b/www-plugins/nspluginwrapper/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for www-plugins/nspluginwrapper
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.4 2010/02/13 12:29:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.5 2010/06/20 10:07:01 pacho Exp $
+
+*nspluginwrapper-1.3.0 (20 Jun 2010)
+
+ 20 Jun 2010; Pacho Ramos <pacho@gentoo.org> -nspluginwrapper-1.0.0.ebuild,
+ -nspluginwrapper-1.2.2.ebuild, -nspluginwrapper-1.2.2-r1.ebuild,
+ +nspluginwrapper-1.3.0.ebuild,
+ +files/nspluginwrapper-1.3.0-fix-npident-array-sending.patch,
+ +files/nspluginwrapper-1.3.0-fortify.patch,
+ +files/nspluginwrapper-1.3.0-gdk-native-windows.patch,
+ +files/nspluginwrapper-1.3.0-inst-crash.patch,
+ +files/nspluginwrapper-1.3.0-ldflags.patch,
+ +files/nspluginwrapper-1.3.0-make.patch,
+ +files/nspluginwrapper-1.3.0-offsetof.patch:
+ Version bump to 1.3.0 (provided by most distributions) with bugfixes over
+ 1.2.2. Also including some patches from Mandriva, Fedora and OpenSUSE to
+ set GDK_NATIVE_WINDOWS=1 (bug #324773 by Alexander E. Patrakov), LDFLAGS
+ fixes, prevent some crashes and others. Removing old versions.
13 Feb 2010; Pacho Ramos <pacho@gentoo.org>
nspluginwrapper-1.2.2-r2.ebuild:
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fix-npident-array-sending.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fix-npident-array-sending.patch
new file mode 100644
index 000000000000..568a4ea1f79a
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fix-npident-array-sending.patch
@@ -0,0 +1,178 @@
+Index: src/npw-viewer.c
+===================================================================
+--- src/npw-viewer.c (revision 942)
++++ src/npw-viewer.c (working copy)
+@@ -2059,7 +2059,7 @@
+ RPC_METHOD_NPN_INVOKE,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, methodName,
++ RPC_TYPE_NP_IDENTIFIER, &methodName,
+ RPC_TYPE_ARRAY, RPC_TYPE_NP_VARIANT, argCount, args,
+ RPC_TYPE_INVALID);
+
+@@ -2249,7 +2249,7 @@
+ RPC_METHOD_NPN_GET_PROPERTY,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, propertyName,
++ RPC_TYPE_NP_IDENTIFIER, &propertyName,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2311,7 +2311,7 @@
+ RPC_METHOD_NPN_SET_PROPERTY,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, propertyName,
++ RPC_TYPE_NP_IDENTIFIER, &propertyName,
+ RPC_TYPE_NP_VARIANT, value,
+ RPC_TYPE_INVALID);
+
+@@ -2370,7 +2370,7 @@
+ RPC_METHOD_NPN_REMOVE_PROPERTY,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, propertyName,
++ RPC_TYPE_NP_IDENTIFIER, &propertyName,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2427,7 +2427,7 @@
+ RPC_METHOD_NPN_HAS_PROPERTY,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, propertyName,
++ RPC_TYPE_NP_IDENTIFIER, &propertyName,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2484,7 +2484,7 @@
+ RPC_METHOD_NPN_HAS_METHOD,
+ RPC_TYPE_NPW_PLUGIN_INSTANCE, plugin,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, methodName,
++ RPC_TYPE_NP_IDENTIFIER, &methodName,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2780,7 +2780,7 @@
+
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPN_IDENTIFIER_IS_STRING,
+- RPC_TYPE_NP_IDENTIFIER, identifier,
++ RPC_TYPE_NP_IDENTIFIER, &identifier,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2838,7 +2838,7 @@
+
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPN_UTF8_FROM_IDENTIFIER,
+- RPC_TYPE_NP_IDENTIFIER, identifier,
++ RPC_TYPE_NP_IDENTIFIER, &identifier,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -2902,7 +2902,7 @@
+
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPN_INT_FROM_IDENTIFIER,
+- RPC_TYPE_NP_IDENTIFIER, identifier,
++ RPC_TYPE_NP_IDENTIFIER, &identifier,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+Index: src/npw-wrapper.c
+===================================================================
+--- src/npw-wrapper.c (revision 942)
++++ src/npw-wrapper.c (working copy)
+@@ -1528,7 +1528,7 @@
+ free(name);
+
+ return rpc_method_send_reply(connection,
+- RPC_TYPE_NP_IDENTIFIER, ident,
++ RPC_TYPE_NP_IDENTIFIER, &ident,
+ RPC_TYPE_INVALID);
+ }
+
+@@ -1601,7 +1601,7 @@
+ NPIdentifier ident = g_NPN_GetIntIdentifier(intid);
+
+ return rpc_method_send_reply(connection,
+- RPC_TYPE_NP_IDENTIFIER, ident,
++ RPC_TYPE_NP_IDENTIFIER, &ident,
+ RPC_TYPE_INVALID);
+ }
+
+Index: src/npruntime.c
+===================================================================
+--- src/npruntime.c (revision 942)
++++ src/npruntime.c (working copy)
+@@ -221,7 +221,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_HAS_METHOD,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -327,7 +327,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_INVOKE,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_ARRAY, RPC_TYPE_NP_VARIANT, argCount, args,
+ RPC_TYPE_INVALID);
+
+@@ -509,7 +509,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_HAS_PROPERTY,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -599,7 +599,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_GET_PROPERTY,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+@@ -684,7 +684,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_SET_PROPERTY,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_NP_VARIANT, value,
+ RPC_TYPE_INVALID);
+
+@@ -763,7 +763,7 @@
+ int error = rpc_method_invoke(g_rpc_connection,
+ RPC_METHOD_NPCLASS_REMOVE_PROPERTY,
+ RPC_TYPE_NP_OBJECT, npobj,
+- RPC_TYPE_NP_IDENTIFIER, name,
++ RPC_TYPE_NP_IDENTIFIER, &name,
+ RPC_TYPE_INVALID);
+
+ if (error != RPC_ERROR_NO_ERROR) {
+Index: src/npw-rpc.c
+===================================================================
+--- src/npw-rpc.c (revision 942)
++++ src/npw-rpc.c (working copy)
+@@ -1252,7 +1252,7 @@
+ // the browser side
+ static int do_send_NPIdentifier(rpc_message_t *message, void *p_value)
+ {
+- NPIdentifier ident = (NPIdentifier)p_value;
++ NPIdentifier ident = *(NPIdentifier *)p_value;
+ int id = 0;
+ if (ident) {
+ #ifdef BUILD_WRAPPER
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fortify.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fortify.patch
new file mode 100644
index 000000000000..e0b077f67251
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-fortify.patch
@@ -0,0 +1,19 @@
+--- nspluginwrapper-1.3.0/lsb-build/stub_libs/libc_nonshared.c.fortify 2008-12-20 23:34:55.000000000 +0100
++++ nspluginwrapper-1.3.0/lsb-build/stub_libs/libc_nonshared.c 2010-03-30 16:03:51.000000000 +0200
+@@ -98,3 +98,16 @@
+
+ _fini ();
+ }
++
++int
++__sprintf_chk (char *str, int flags, size_t size, const char *format, ...)
++{
++ __builtin_va_list ap;
++ int result;
++ __builtin_va_start(ap, format);
++ result = __builtin_vsnprintf(str, size, format, ap);
++ __builtin_va_end(ap);
++ return result;
++}
++
++void __stack_chk_fail_local (void) {}
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-gdk-native-windows.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-gdk-native-windows.patch
new file mode 100644
index 000000000000..977af6c97e85
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-gdk-native-windows.patch
@@ -0,0 +1,13 @@
+diff -up nspluginwrapper-1.3.0/src/npw-viewer.sh.old nspluginwrapper-1.3.0/src/npw-viewer.sh
+--- nspluginwrapper-1.3.0/src/npw-viewer.sh.old 2009-11-16 12:57:53.000000000 +0100
++++ nspluginwrapper-1.3.0/src/npw-viewer.sh 2009-12-04 16:16:27.000000000 +0100
+@@ -77,6 +77,9 @@ NPW_USE_XSHM=${NPW_USE_XSHM:-yes}
+ NPW_USE_VALGRIND=${NPW_USE_VALGRIND:-no}
+ can_use_valgrind="no"
+
++# Compiz/Flash workaround (rhbz#542424)
++export GDK_NATIVE_WINDOWS=1
++
+ if test "$ARCH" != "$TARGET_ARCH"; then
+ case $TARGET_ARCH in
+ i386)
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-inst-crash.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-inst-crash.patch
new file mode 100644
index 000000000000..60f6b1e0f5e5
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-inst-crash.patch
@@ -0,0 +1,12 @@
+diff -up nspluginwrapper-1.3.0/src/npw-common.h.old nspluginwrapper-1.3.0/src/npw-common.h
+--- nspluginwrapper-1.3.0/src/npw-common.h.old 2009-01-02 15:22:29.000000000 +0100
++++ nspluginwrapper-1.3.0/src/npw-common.h 2009-11-10 09:58:34.000000000 +0100
+@@ -115,7 +115,7 @@ npw_plugin_instance_is_valid(void *ptr)
+ static inline NPW_PluginInstance *
+ _npw_get_plugin_instance (NPP instance)
+ {
+- return (NPW_PluginInstance *)instance->_NPW_INSTANCE_PRIVATE_DATA;
++ return instance ? (NPW_PluginInstance *)instance->_NPW_INSTANCE_PRIVATE_DATA : NULL;
+ }
+
+ static inline NPW_PluginInstance *
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-ldflags.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-ldflags.patch
new file mode 100644
index 000000000000..e8922e651179
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-ldflags.patch
@@ -0,0 +1,22 @@
+diff -up nspluginwrapper-1.3.0/configure.conf nspluginwrapper-1.3.0/configure
+--- nspluginwrapper-1.3.0/configure.conf 2009-01-02 15:22:29.000000000 +0100
++++ nspluginwrapper-1.3.0/configure 2009-01-07 12:06:21.000000000 +0100
+@@ -559,10 +559,6 @@ for dir in $x_base_dirs; do
+ fi
+ fi
+ done
+-if test -z "$x_base_dir"; then
+- echo "X11/Xt environment not found"
+- exit 1
+-fi
+
+ # big/little endian test
+ cat > $TMPC << EOF
+@@ -763,6 +759,7 @@ echo "COMPILER=$compiler" >> $config_mak
+ echo "CC=$cc" >> $config_mak
+ echo "CXX=$cxx" >> $config_mak
+ echo "CFLAGS=$CFLAGS" >> $config_mak
++echo "LDFLAGS=$LDFLAGS" >> $config_mak
+ echo "GLIB_CFLAGS=$GLIB_CFLAGS" >> $config_mak
+ echo "GLIB_LDFLAGS=$GLIB_LDFLAGS" >> $config_mak
+ echo "GTK_CFLAGS=$GTK_CFLAGS" >> $config_mak
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-make.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-make.patch
new file mode 100644
index 000000000000..13587225b484
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-make.patch
@@ -0,0 +1,51 @@
+diff -up nspluginwrapper-1.3.0/Makefile.make nspluginwrapper-1.3.0/Makefile
+--- nspluginwrapper-1.3.0/Makefile.make 2009-01-02 15:22:29.000000000 +0100
++++ nspluginwrapper-1.3.0/Makefile 2009-01-07 13:00:40.000000000 +0100
+@@ -364,13 +364,13 @@ changelog.commit: changelog
+ svn commit -m "Generated by svn2cl." ChangeLog
+
+ $(npwrapper_LIBRARY): $(npwrapper_OBJECTS)
+- $(CC) -o $@ $(DSO_LDFLAGS) $(npwrapper_OBJECTS) $(npwrapper_LDFLAGS)
++ $(CC) -o $@ $(DSO_LDFLAGS) $(npwrapper_OBJECTS) $(npwrapper_LDFLAGS) $(LDFLAGS)
+
+ npwrapper-%.os: $(SRC_PATH)/src/%.c
+ $(CC) -o $@ -c $< $(PIC_CFLAGS) $(CPPFLAGS) $(npwrapper_CFLAGS) -DBUILD_WRAPPER
+
+ $(npviewer_PROGRAM): $(npviewer_OBJECTS) $(npviewer_MAPFILE) $(LSB_OBJ_DIR) $(LSB_LIBS)
+- $(CC) $(LDFLAGS_32) -o $@ $(npviewer_OBJECTS) $(npviewer_LDFLAGS)
++ $(CC) $(LDFLAGS_32) -o $@ $(npviewer_OBJECTS) $(npviewer_LDFLAGS) $(LDFLAGS)
+
+ npviewer-%.o: $(SRC_PATH)/src/%.c
+ $(CC) $(CFLAGS_32) -o $@ -c $< $(CPPFLAGS) $(npviewer_CFLAGS) -DBUILD_VIEWER
+@@ -387,19 +387,19 @@ npplayer-%.o: $(SRC_PATH)/src/tidy/%.c
+ $(CC) $(CFLAGS) -o $@ -c $< $(CPPFLAGS) $(npplayer_CFLAGS) -DBUILD_PLAYER
+
+ $(libxpcom_LIBRARY): $(libxpcom_OBJECTS) $(LSB_OBJ_DIR) $(LSB_LIBS)
+- $(CC) $(LDFLAGS_32) $(DSO_LDFLAGS) -o $@ $(libxpcom_OBJECTS) $(libxpcom_LDFLAGS) -Wl,$(LD_soname),libxpcom.so
++ $(CC) $(LDFLAGS) $(LDFLAGS_32) $(DSO_LDFLAGS) -o $@ $(libxpcom_OBJECTS) $(libxpcom_LDFLAGS) -Wl,$(LD_soname),libxpcom.so
+
+ libxpcom-%.o: $(SRC_PATH)/src/%.c
+ $(CC) $(CFLAGS_32) -o $@ -c $< $(CPPFLAGS) $(libxpcom_CFLAGS) -DBUILD_XPCOM
+
+ $(libnoxshm_LIBRARY): $(libnoxshm_OBJECTS) $(LSB_OBJ_DIR) $(LSB_LIBS)
+- $(CC) $(LDFLAGS_32) $(DSO_LDFLAGS) -o $@ $(libnoxshm_OBJECTS) $(libnoxshm_LDFLAGS) -Wl,$(LD_soname),libnoxshm.so
++ $(CC) $(LDFLAGS) $(LDFLAGS_32) $(DSO_LDFLAGS) -o $@ $(libnoxshm_OBJECTS) $(libnoxshm_LDFLAGS) -Wl,$(LD_soname),libnoxshm.so
+
+ libnoxshm-%.o: $(SRC_PATH)/src/%.c
+ $(CC) $(CFLAGS_32) -o $@ -c $< $(CPPFLAGS) $(libnoxshm_CFLAGS)
+
+ $(npconfig_PROGRAM): $(npconfig_OBJECTS)
+- $(CC) -o $@ $(npconfig_OBJECTS) $(npconfig_LDFLAGS)
++ $(CC) -o $@ $(npconfig_OBJECTS) $(npconfig_LDFLAGS) $(LDFLAGS)
+
+ npconfig-%.o: $(SRC_PATH)/src/%.c
+ $(CC) -o $@ -c $< $(CPPFLAGS) $(CFLAGS)
+@@ -425,7 +425,7 @@ $(LSB_OBJ_DIR)/libgcc_s_32.so: $(LSB_OBJ
+ $(LN_S) libgcc_s.so $@
+
+ $(LSB_OBJ_DIR)/%.so: $(LSB_OBJ_DIR)/%.o
+- $(CC) $(LDFLAGS_32) -nostdlib $(DSO_LDFLAGS) $< -o $@ \
++ $(CC) $(LDFLAGS) $(LDFLAGS_32) -nostdlib $(DSO_LDFLAGS) $< -o $@ \
+ -Wl,--version-script,$(patsubst $(LSB_OBJ_DIR)/%.o,$(LSB_SRC_DIR)/%.Version,$<) \
+ -Wl,-soname,`grep "$(patsubst $(LSB_OBJ_DIR)/%.o,%,$<) " $(LSB_SRC_DIR)/LibNameMap.txt | cut -f2 -d' '`
+
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-offsetof.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-offsetof.patch
new file mode 100644
index 000000000000..93e3e174adac
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.3.0-offsetof.patch
@@ -0,0 +1,11 @@
+--- lsb-build/headers/stddef.h
++++ lsb-build/headers/stddef.h
+@@ -7,7 +7,7 @@
+ #endif
+
+
+-#define offsetof(TYPE,MEMBER) ((size_t)&((TYPE*)0)->MEMBER)
++#define offsetof(TYPE,MEMBER) __builtin_offsetof(TYPE,MEMBER)
+
+ #if !defined(__cplusplus)
+
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.0.0.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.0.0.ebuild
deleted file mode 100644
index 2639ec263b75..000000000000
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.0.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.0.0.ebuild,v 1.1 2009/04/09 21:06:33 ulm Exp $
-
-inherit eutils nsplugins flag-o-matic multilib
-
-DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
-HOMEPAGE="http://www.gibix.net/projects/nspluginwrapper/"
-SRC_URI="http://www.gibix.net/projects/nspluginwrapper/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-gtklibs
- || ( >=sys-apps/util-linux-2.13 sys-apps/setarch )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-autoinstall() {
- if [[ -x /usr/bin/${PN} ]]; then
- einfo "Auto installing 32bit plugins..."
- ${PN} -a -i
- ls /usr/lib64/nsbrowser/plugins
-
- # Remove wrappers if equivalent 64-bit plugins exist
- # TODO: May be better to patch nspluginwrapper so it doesn't create
- # duplicate wrappers in the first place...
- local DIR64="${ROOT}/usr/lib64/nsbrowser/plugins/"
- for f in "${DIR64}"/npwrapper.*.so; do
- local PLUGIN=${f##*/npwrapper.}
- if [[ -f ${DIR64}/${PLUGIN} ]]; then
- einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
- ${PN} -r "${f}"
- fi
- done
- fi
-}
-
-src_compile() {
- econf --with-biarch \
- --with-lib32=$(ABI=x86 get_libdir) \
- --with-lib64=$(get_libdir) \
- --pkglibdir=/usr/$(get_libdir)/${PN} || die
- emake || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" DONT_STRIP=yes install || die
-
- inst_plugin /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npwrapper.so
- dosym /usr/$(get_libdir)/nspluginwrapper/x86_64/linux/npconfig /usr/bin/nspluginwrapper
-
- dodoc NEWS README TODO ChangeLog
-}
-
-pkg_postinst() {
- autoinstall
- elog "Any 32bit plugins you currently have installed have now been"
- elog "configured to work in a 64bit browser. Any plugins you install in"
- elog "the future will first need to be setup with:"
- elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
- elog "before they will function in a 64bit browser"
- elog
-}
-
-# this is terribly ugly, but without a way to query portage as to whether
-# we are upgrading/reinstalling a package versus unmerging, I can't think of
-# a better way
-
-pkg_prerm() {
- einfo "Removing wrapper plugins..."
- nspluginwrapper -a -r
-}
-
-pkg_postrm() {
- autoinstall
-}
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2.ebuild
deleted file mode 100644
index e0e6639d4b38..000000000000
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2.ebuild,v 1.2 2009/07/20 20:26:05 chutzpah Exp $
-
-inherit eutils nsplugins multilib
-
-DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
-HOMEPAGE="http://www.gibix.net/projects/nspluginwrapper/"
-SRC_URI="http://www.gibix.net/projects/${PN}/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2
- net-misc/curl
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-gtklibs
- || ( >=sys-apps/util-linux-2.13 sys-apps/setarch )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-autoinstall() {
- if [[ -x /usr/bin/${PN} ]]; then
- einfo "Auto installing 32bit plugins..."
- ${PN} -a -i
- ls /usr/lib64/nsbrowser/plugins
-
- # Remove wrappers if equivalent 64-bit plugins exist
- # TODO: May be better to patch nspluginwrapper so it doesn't create
- # duplicate wrappers in the first place...
- local DIR64="${ROOT}/usr/lib64/nsbrowser/plugins/"
- for f in "${DIR64}"/npwrapper.*.so; do
- local PLUGIN=${f##*/npwrapper.}
- if [[ -f ${DIR64}/${PLUGIN} ]]; then
- einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
- ${PN} -r "${f}"
- fi
- done
- fi
-}
-
-src_compile() {
- econf --with-biarch \
- --with-lib32=$(ABI=x86 get_libdir) \
- --with-lib64=$(get_libdir) \
- --pkglibdir=/usr/$(get_libdir)/${PN}
-
- emake || die "emake failed"
-
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- inst_plugin "/usr/$(get_libdir)/${PN}/x86_64/linux/npwrapper.so"
- dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}"
-
- dodoc NEWS README TODO ChangeLog
-}
-
-pkg_postinst() {
- autoinstall
- elog "Any 32bit plugins you currently have installed have now been"
- elog "configured to work in a 64bit browser. Any plugins you install in"
- elog "the future will first need to be setup with:"
- elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
- elog "before they will function in a 64bit browser"
- elog
-}
-
-# this is terribly ugly, but without a way to query portage as to whether
-# we are upgrading/reinstalling a package versus unmerging, I can't think of
-# a better way
-
-pkg_prerm() {
- einfo "Removing wrapper plugins..."
- ${PN} --auto --remove
-}
-
-pkg_postrm() {
- autoinstall
-}
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2-r1.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.3.0.ebuild
index 20a82be30913..fca9fcb4f2c3 100644
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2-r1.ebuild
+++ b/www-plugins/nspluginwrapper/nspluginwrapper-1.3.0.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.2.2-r1.ebuild,v 1.1 2009/07/20 20:26:05 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.3.0.ebuild,v 1.1 2010/06/20 10:07:01 pacho Exp $
EAPI=2
-inherit eutils nsplugins multilib
+inherit eutils nsplugins multilib flag-o-matic
DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
HOMEPAGE="http://www.gibix.net/projects/nspluginwrapper/"
-SRC_URI="http://www.gibix.net/projects/${PN}/files/${P}.tar.bz2"
+#SRC_URI="http://www.gibix.net/projects/${PN}/files/${P}.tar.bz2"
+SRC_URI="mirror://debian/pool/contrib/n/${PN}/${P/-/_}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -44,12 +45,19 @@ autoinstall() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}-gcc44.patch"
- epatch "${FILESDIR}/${P}-npidentifiers.patch"
+ epatch "${FILESDIR}/${P}-gdk-native-windows.patch"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-inst-crash.patch"
+ epatch "${FILESDIR}/${P}-make.patch"
+ epatch "${FILESDIR}/${P}-fix-npident-array-sending.patch"
+ epatch "${FILESDIR}/${P}-fortify.patch"
+ epatch "${FILESDIR}/${P}-offsetof.patch"
}
src_configure() {
- econf --enable-biarch \
+ replace-flags -O3 -O2
+
+ ./configure --enable-biarch \
--target-cpu=i386 \
--with-lib32=$(ABI=x86 get_libdir) \
--with-lib64=$(get_libdir) \
@@ -57,7 +65,7 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
}
src_install() {