summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/quota/ChangeLog9
-rw-r--r--sys-fs/quota/quota-3.17.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index 6655a87018f4..92fac6177740 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/quota
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.38 2008/11/25 11:57:53 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.39 2009/01/05 23:09:49 vapier Exp $
+
+*quota-3.17 (05 Jan 2009)
+
+ 05 Jan 2009; Mike Frysinger <vapier@gentoo.org> +quota-3.17.ebuild:
+ Version bump.
25 Nov 2008; Raúl Porcel <armin76@gentoo.org> quota-3.15.ebuild:
alpha/ia64/sparc stable wrt #247651
diff --git a/sys-fs/quota/quota-3.17.ebuild b/sys-fs/quota/quota-3.17.ebuild
new file mode 100644
index 000000000000..86b0aea510b5
--- /dev/null
+++ b/sys-fs/quota/quota-3.17.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.17.ebuild,v 1.1 2009/01/05 23:09:49 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls tcpd ldap rpc"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ rpc? ( net-nds/portmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # This was for openldap-2.2 support before,
+ # Now we only support >=2.3
+ append-cppflags -DLDAP_DEPRECATED=0
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ dodoc doc/*
+ dodoc README.*
+ dodoc Changelog
+
+ newinitd "${FILESDIR}"/quota.rc6 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}