summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-5.07.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 5e9cad1ec31e..fbd291bcfdd1 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.196 2011/04/15 08:04:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.197 2011/05/11 03:43:09 vapier Exp $
+
+*file-5.07 (11 May 2011)
+
+ 11 May 2011; Mike Frysinger <vapier@gentoo.org> +file-5.07.ebuild:
+ Version bump.
*file-5.06 (15 Apr 2011)
diff --git a/sys-apps/file/file-5.07.ebuild b/sys-apps/file/file-5.07.ebuild
new file mode 100644
index 000000000000..1b59f39efb1c
--- /dev/null
+++ b/sys-apps/file/file-5.07.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.07.ebuild,v 1.1 2011/05/11 03:43:09 vapier Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="python static-libs"
+
+PYTHON_MODNAME="magic.py"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_configure() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+ use static-libs || rm -f "${D}"/usr/lib*/libmagic.la
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}