summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/corkscrew/ChangeLog6
-rw-r--r--net-misc/corkscrew/corkscrew-2.0.ebuild29
2 files changed, 23 insertions, 12 deletions
diff --git a/net-misc/corkscrew/ChangeLog b/net-misc/corkscrew/ChangeLog
index 2f8625a16627..938e7b1589ca 100644
--- a/net-misc/corkscrew/ChangeLog
+++ b/net-misc/corkscrew/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/corkscrew
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/ChangeLog,v 1.8 2010/06/22 17:41:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/ChangeLog,v 1.9 2010/06/23 09:53:44 angelos Exp $
+
+ 23 Jun 2010; Christoph Mende <angelos@gentoo.org> corkscrew-2.0.ebuild:
+ Regenerate autotools to fix bug #305771, also stable on amd64 wrt bug
+ #284604
22 Jun 2010; Christoph Mende <angelos@gentoo.org> corkscrew-2.0.ebuild:
QA: Respect CC and use emake
diff --git a/net-misc/corkscrew/corkscrew-2.0.ebuild b/net-misc/corkscrew/corkscrew-2.0.ebuild
index 24f2654ab58e..e17f5dcaffb7 100644
--- a/net-misc/corkscrew/corkscrew-2.0.ebuild
+++ b/net-misc/corkscrew/corkscrew-2.0.ebuild
@@ -1,24 +1,31 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/corkscrew-2.0.ebuild,v 1.9 2010/06/22 17:41:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/corkscrew-2.0.ebuild,v 1.10 2010/06/23 09:53:44 angelos Exp $
-EAPI=2
-inherit toolchain-funcs
+EAPI=3
+inherit autotools
-DESCRIPTION="Corkscrew is a tool for tunneling SSH through HTTP proxies."
+DESCRIPTION="a tool for tunneling SSH through HTTP proxies."
HOMEPAGE="http://www.agroman.net/corkscrew/"
+SRC_URI="http://www.agroman.net/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
-DEPEND=""
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
SLOT="0"
-SRC_URI="http://www.agroman.net/corkscrew/${P}.tar.gz"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
-src_compile() {
- emake CC=$(tc-getCC) || die "emake failed"
+src_prepare() {
+ # Christoph Mende <angelos@gentoo.org (23 Jun 2010)
+ # Shipped configure doesn't work with some locales (bug #305771)
+ # Shipped missing doesn't work with new configure, so we'll force
+ # regeneration
+ rm -f install-sh missing mkinstalldirs || die
+ eautoreconf
}
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
}