summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/dsniff/ChangeLog10
-rw-r--r--net-analyzer/dsniff/dsniff-2.4_beta1-r4.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index b99fa2ce8195..b65f01255376 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/dsniff
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.47 2008/11/25 10:05:47 hanno Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.48 2009/03/23 19:39:39 rbu Exp $
+
+*dsniff-2.4_beta1-r4 (23 Mar 2009)
+
+ 23 Mar 2009; Robert Buchholz <rbu@gentoo.org> +dsniff-2.4_beta1-r4.ebuild:
+ Bump to newer debian patchset that actually works. This needs a more recent
+ libnids, bug #253533.
25 Nov 2008; Hanno Boeck <hanno@gentoo.org> +files/dsniff-lresolv.patch,
dsniff-2.4_beta1-r3.ebuild:
diff --git a/net-analyzer/dsniff/dsniff-2.4_beta1-r4.ebuild b/net-analyzer/dsniff/dsniff-2.4_beta1-r4.ebuild
new file mode 100644
index 000000000000..fc50df8ba14b
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.4_beta1-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.4_beta1-r4.ebuild,v 1.1 2009/03/23 19:39:39 rbu Exp $
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
+SRC_URI="http://monkey.org/~dugsong/${PN}/beta/${P/_beta/b}.tar.gz
+ mirror://debian/pool/main/d/${PN}/${PN}_2.4b1+debian-18.diff.gz"
+
+LICENSE="DSNIFF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.2.1-r1
+ >=net-libs/libnids-1.21
+ >=dev-libs/openssl-0.9.6e
+ >=sys-libs/db-4.2.52_p4
+ sys-apps/sed
+ X? ( x11-libs/libXmu )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/_beta1/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Debian's patchset
+ epatch "${DISTDIR}"/${PN}_2.4b1+debian-18.diff.gz
+ epatch "${S}"/dsniff-2.4b1+debian/debian/patches/*.dpatch
+
+ sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
+ epatch "${FILESDIR}"/2.3-makefile.patch
+
+ # Bug 125084
+ epatch "${FILESDIR}"/${PN}-httppostfix.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with X x) \
+ || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake install install_prefix="${D}" || die "emake install failed"
+ dodir /etc/dsniff
+ cp "${D}"/usr/share/dsniff/{dnsspoof.hosts,dsniff.{magic,services}} \
+ "${D}"/etc/dsniff/
+ dodoc CHANGES README TODO
+}