summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/sqlguipart/sqlguipart-0.4.ebuild35
-rw-r--r--dev-java/fop-bin/fop-bin-0.20.4.ebuild6
-rw-r--r--dev-java/junit/junit-3.7-r1.ebuild18
-rw-r--r--dev-java/junit/junit-3.8.1.ebuild16
-rw-r--r--dev-java/regexp/regexp-1.2.ebuild12
5 files changed, 44 insertions, 43 deletions
diff --git a/dev-db/sqlguipart/sqlguipart-0.4.ebuild b/dev-db/sqlguipart/sqlguipart-0.4.ebuild
index a9f2ba6b2f3a..adefc6123583 100644
--- a/dev-db/sqlguipart/sqlguipart-0.4.ebuild
+++ b/dev-db/sqlguipart/sqlguipart-0.4.ebuild
@@ -1,33 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlguipart/sqlguipart-0.4.ebuild,v 1.3 2003/02/13 10:05:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlguipart/sqlguipart-0.4.ebuild,v 1.4 2003/03/01 04:50:37 vapier Exp $
+
inherit kde-base
need-kde 3
-newdepend ">=dev-db/mysql-3.23.38 >=kde-base/kdebase-3"
+newdepend ">=dev-db/mysql-3.23.38
+ >=kde-base/kdebase-3"
DESCRIPTION="kpart for administering a mysql db. dev-db/sqlgui is a gui for it."
SRC_URI="http://www.sqlgui.de/download/sqlgui-0.4.0.tar.gz"
HOMEPAGE="http://www.sqlgui.de/"
+
LICENSE="GPL-2"
KEYWORDS="x86"
-S=$WORKDIR/sqlgui-0.4.0/$P
-
-myconf="$myconf --with-extra-includes=/usr/include/mysql"
-src_unpack() {
+myconf="${myconf} --with-extra-includes=/usr/include/mysql"
- cd $WORKDIR
- unpack sqlgui-0.4.0.tar.gz
- cd sqlgui-0.4.0
- tar -xvzpf $P.tar.gz
- cd $S
- patch -p0 < $FILESDIR/$P-gcc3.diff
- patch -p0 < $FILESDIR/$P-gentoo.diff
- need-autoconf 2.1
- make -f Makefile.dist
- need-autoconf 2.5
+S=${WORKDIR}/sqlgui-0.4.0/${P}
+src_unpack() {
+ cd $WORKDIR
+ unpack sqlgui-0.4.0.tar.gz
+ cd sqlgui-0.4.0
+ tar -xvzpf $P.tar.gz
+ cd $S
+ patch -p0 < $FILESDIR/$P-gcc3.diff
+ patch -p0 < $FILESDIR/$P-gentoo.diff
+ need-autoconf 2.1
+ make -f Makefile.dist
+ need-autoconf 2.5
}
-
diff --git a/dev-java/fop-bin/fop-bin-0.20.4.ebuild b/dev-java/fop-bin/fop-bin-0.20.4.ebuild
index 8fda42b1dc4f..d44377896b80 100644
--- a/dev-java/fop-bin/fop-bin-0.20.4.ebuild
+++ b/dev-java/fop-bin/fop-bin-0.20.4.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fop-bin/fop-bin-0.20.4.ebuild,v 1.2 2003/02/13 10:09:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop-bin/fop-bin-0.20.4.ebuild,v 1.3 2003/03/01 04:51:11 vapier Exp $
P=${P/-bin/}
PN=${PN/-bin/}
DESCRIPTION="Formatting Objects Processor is a print formatter driven by XSL"
SRC_URI="http://xml.apache.org/dist/fop/${P}-bin.tar.gz"
HOMEPAGE="http://xml.apache.org/fop/"
-LICENSE="Apache-1.1"
+LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86"
+
DEPEND=">=virtual/jdk-1.4"
-IUSE=""
src_install() {
sed '2itest "$FOP_HOME" || FOP_HOME=/usr/share/fop/' fop.sh > fop
diff --git a/dev-java/junit/junit-3.7-r1.ebuild b/dev-java/junit/junit-3.7-r1.ebuild
index 481304be28f0..f924ed205d48 100644
--- a/dev-java/junit/junit-3.7-r1.ebuild
+++ b/dev-java/junit/junit-3.7-r1.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.7-r1.ebuild,v 1.6 2003/02/13 10:12:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.7-r1.ebuild,v 1.7 2003/03/01 04:52:11 vapier Exp $
NP="junit3.7"
S=${WORKDIR}/${NP}
-DESCRIPTION="JUnit is a simple framework to write repeatable tests."
+DESCRIPTION="simple framework to write repeatable tests"
SRC_URI="http://download.sourceforge.net/junit/${NP}.zip"
HOMEPAGE="http://www.junit.org/"
+
+LICENSE="CPL-0.5"
+SLOT="0"
+KEYWORDS="x86"
+
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
>=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jdk-1.3"
-LICENSE="CPL-0.5"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
src_unpack() {
unpack ${NP}.zip
@@ -23,13 +24,12 @@ src_unpack() {
}
src_compile() {
- ant
+ ant || die
}
-src_install () {
+src_install() {
dojar junit.jar src.jar
dodir /usr/share/ant/lib
dosym /usr/share/junit/lib/junit.jar /usr/share/ant/lib/
dohtml -r README.html doc javadoc
}
-
diff --git a/dev-java/junit/junit-3.8.1.ebuild b/dev-java/junit/junit-3.8.1.ebuild
index 3d5921a204e3..f1d6db36bbfc 100644
--- a/dev-java/junit/junit-3.8.1.ebuild
+++ b/dev-java/junit/junit-3.8.1.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.1.ebuild,v 1.4 2003/02/13 10:12:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.1.ebuild,v 1.5 2003/03/01 04:52:11 vapier Exp $
NP=${P/-/}
S=${WORKDIR}/${NP}
DESCRIPTION="JUnit is a simple framework to write repeatable tests."
SRC_URI="http://download.sourceforge.net/junit/${NP}.zip"
HOMEPAGE="http://www.junit.org/"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
>=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jdk-1.3"
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
src_unpack() {
unpack ${A}
@@ -24,14 +25,13 @@ src_unpack() {
src_compile() {
rm junit.jar
- ant
+ ant || die
}
-src_install () {
+src_install() {
cd ${NP}
dojar junit.jar
dodir /usr/share/ant/lib
dosym /usr/share/junit/lib/junit.jar /usr/share/ant/lib/
dohtml -r README.html cpl-v10.html doc javadoc
}
-
diff --git a/dev-java/regexp/regexp-1.2.ebuild b/dev-java/regexp/regexp-1.2.ebuild
index 14ad2568f964..60c2ba3680f4 100644
--- a/dev-java/regexp/regexp-1.2.ebuild
+++ b/dev-java/regexp/regexp-1.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Copyright 2002 Jordan Armstrong <jordan@papercrane.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/regexp/regexp-1.2.ebuild,v 1.2 2003/02/13 10:22:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/regexp/regexp-1.2.ebuild,v 1.3 2003/03/01 04:52:55 vapier Exp $
S=${WORKDIR}/jakarta-regexp-${PV}
-DESCRIPTION="Regexp is a 100% Pure Java Regular Expression package"
+DESCRIPTION="100% Pure Java Regular Expression package"
SRC_URI="http://jakarta.apache.org/builds/jakarta-regexp/release/v${PV}/jakarta-regexp-${PV}.tar.gz"
-HOMEPAGE="http://jakarta.apache.org"
+HOMEPAGE="http://jakarta.apache.org/"
+
SLOT="1"
LICENSE="Apache-1.1"
-DEPEND=">=virtual/jdk-1.3"
-RDEPEND="$DEPEND"
KEYWORDS="x86"
+DEPEND=">=virtual/jdk-1.3"
+
src_compile() {
cd build
sh build-regexp.sh || die