summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/digest-xdm-0.99.41
-rw-r--r--x11-apps/xdm/xdm-0.99.4.ebuild38
-rw-r--r--x11-apps/xdpyinfo/ChangeLog8
-rw-r--r--x11-apps/xdpyinfo/files/digest-xdpyinfo-0.99.21
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-0.99.2.ebuild33
-rw-r--r--x11-apps/xdriinfo/ChangeLog8
-rw-r--r--x11-apps/xdriinfo/files/digest-xdriinfo-0.99.21
-rw-r--r--x11-apps/xdriinfo/xdriinfo-0.99.2.ebuild14
-rw-r--r--x11-apps/xedit/ChangeLog8
-rw-r--r--x11-apps/xedit/files/digest-xedit-0.99.31
-rw-r--r--x11-apps/xedit/xedit-0.99.3.ebuild29
-rw-r--r--x11-apps/xev/ChangeLog7
-rw-r--r--x11-apps/xev/files/digest-xev-0.99.21
-rw-r--r--x11-apps/xev/xev-0.99.2.ebuild13
-rw-r--r--x11-apps/xeyes/ChangeLog8
-rw-r--r--x11-apps/xeyes/files/digest-xeyes-0.99.21
-rw-r--r--x11-apps/xeyes/xeyes-0.99.2.ebuild16
-rw-r--r--x11-apps/xf86dga/ChangeLog8
-rw-r--r--x11-apps/xf86dga/files/digest-xf86dga-0.99.31
-rw-r--r--x11-apps/xf86dga/xf86dga-0.99.3.ebuild14
-rw-r--r--x11-apps/xfd/ChangeLog7
-rw-r--r--x11-apps/xfd/files/digest-xfd-0.99.21
-rw-r--r--x11-apps/xfd/xfd-0.99.2.ebuild23
-rw-r--r--x11-apps/xfindproxy/ChangeLog8
-rw-r--r--x11-apps/xfindproxy/files/digest-xfindproxy-0.99.31
-rw-r--r--x11-apps/xfindproxy/xfindproxy-0.99.3.ebuild15
-rw-r--r--x11-apps/xfontsel/ChangeLog8
-rw-r--r--x11-apps/xfontsel/files/digest-xfontsel-0.99.21
-rw-r--r--x11-apps/xfontsel/xfontsel-0.99.2.ebuild22
-rw-r--r--x11-apps/xfsinfo/ChangeLog8
-rw-r--r--x11-apps/xfsinfo/files/digest-xfsinfo-0.99.21
-rw-r--r--x11-apps/xfsinfo/xfsinfo-0.99.2.ebuild14
33 files changed, 316 insertions, 11 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index e8b258912f7b..27364ae92918 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.27 2005/11/17 04:12:58 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.28 2005/12/04 21:59:03 joshuabaergen Exp $
+
+*xdm-0.99.4 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-0.99.4.ebuild:
+ Bump for 7.0RC3.
*xdm-0.99.3_p20051113-r1 (17 Nov 2005)
diff --git a/x11-apps/xdm/files/digest-xdm-0.99.4 b/x11-apps/xdm/files/digest-xdm-0.99.4
new file mode 100644
index 000000000000..b1d6016918f3
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-0.99.4
@@ -0,0 +1 @@
+MD5 8ea0b887baf9d702c883f8e85fb100b8 xdm-0.99.4.tar.bz2 291986
diff --git a/x11-apps/xdm/xdm-0.99.4.ebuild b/x11-apps/xdm/xdm-0.99.4.ebuild
new file mode 100644
index 000000000000..aff29a951c62
--- /dev/null
+++ b/x11-apps/xdm/xdm-0.99.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-0.99.4.ebuild,v 1.1 2005/12/04 21:59:03 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-0.99.1_pre20050905-r1
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}
diff --git a/x11-apps/xdpyinfo/ChangeLog b/x11-apps/xdpyinfo/ChangeLog
index a7b798776d4e..6047bda3bc14 100644
--- a/x11-apps/xdpyinfo/ChangeLog
+++ b/x11-apps/xdpyinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdpyinfo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.7 2005/10/20 00:45:22 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.8 2005/12/04 21:59:31 joshuabaergen Exp $
+
+*xdpyinfo-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xdpyinfo-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xdpyinfo-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xdpyinfo/files/digest-xdpyinfo-0.99.2 b/x11-apps/xdpyinfo/files/digest-xdpyinfo-0.99.2
new file mode 100644
index 000000000000..6797f3a16b1b
--- /dev/null
+++ b/x11-apps/xdpyinfo/files/digest-xdpyinfo-0.99.2
@@ -0,0 +1 @@
+MD5 3bb5b7d3650fce39ab1911813cb0f012 xdpyinfo-0.99.2.tar.bz2 86141
diff --git a/x11-apps/xdpyinfo/xdpyinfo-0.99.2.ebuild b/x11-apps/xdpyinfo/xdpyinfo-0.99.2.ebuild
new file mode 100644
index 000000000000..c9c5c5398df9
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-0.99.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-0.99.2.ebuild,v 1.1 2005/12/04 21:59:31 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xdpyinfo application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86misc
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXinerama
+ x11-libs/libdmx
+ x11-libs/libXp"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/kbproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86miscproto
+ x11-proto/inputproto
+ x11-proto/renderproto
+ x11-proto/xineramaproto
+ x11-proto/dmxproto
+ x11-proto/printproto"
diff --git a/x11-apps/xdriinfo/ChangeLog b/x11-apps/xdriinfo/ChangeLog
index 69e907dac73d..9b7e0e7c27dc 100644
--- a/x11-apps/xdriinfo/ChangeLog
+++ b/x11-apps/xdriinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdriinfo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.4 2005/10/31 17:42:41 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.5 2005/12/04 21:59:59 joshuabaergen Exp $
+
+*xdriinfo-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xdriinfo-0.99.2.ebuild:
+ Bump for 7.0RC3.
31 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xdriinfo-0.99.0_pre20050908.ebuild:
diff --git a/x11-apps/xdriinfo/files/digest-xdriinfo-0.99.2 b/x11-apps/xdriinfo/files/digest-xdriinfo-0.99.2
new file mode 100644
index 000000000000..cb0d0310a409
--- /dev/null
+++ b/x11-apps/xdriinfo/files/digest-xdriinfo-0.99.2
@@ -0,0 +1 @@
+MD5 76ffe35f42e4f51d73349f8c3b1812cc xdriinfo-0.99.2.tar.bz2 76346
diff --git a/x11-apps/xdriinfo/xdriinfo-0.99.2.ebuild b/x11-apps/xdriinfo/xdriinfo-0.99.2.ebuild
new file mode 100644
index 000000000000..3e7c6b5708d0
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-0.99.2.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-0.99.2.ebuild,v 1.1 2005/12/04 21:59:59 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xdriinfo application"
+KEYWORDS="~x86"
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/glproto"
diff --git a/x11-apps/xedit/ChangeLog b/x11-apps/xedit/ChangeLog
index f77a4899c3d3..71ea26c53151 100644
--- a/x11-apps/xedit/ChangeLog
+++ b/x11-apps/xedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xedit
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.8 2005/11/17 13:27:00 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.9 2005/12/04 22:00:28 joshuabaergen Exp $
+
+*xedit-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xedit-0.99.3.ebuild:
+ Bump for 7.0RC3.
17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> xedit-0.99.2.ebuild:
Marked ~amd64.
diff --git a/x11-apps/xedit/files/digest-xedit-0.99.3 b/x11-apps/xedit/files/digest-xedit-0.99.3
new file mode 100644
index 000000000000..ffd21d6110cf
--- /dev/null
+++ b/x11-apps/xedit/files/digest-xedit-0.99.3
@@ -0,0 +1 @@
+MD5 ec0c82ba9b80186ce6792f3fa9eff19d xedit-0.99.3.tar.bz2 439712
diff --git a/x11-apps/xedit/xedit-0.99.3.ebuild b/x11-apps/xedit/xedit-0.99.3.ebuild
new file mode 100644
index 000000000000..c423245f98dd
--- /dev/null
+++ b/x11-apps/xedit/xedit-0.99.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-0.99.3.ebuild,v 1.1 2005/12/04 22:00:28 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xedit application"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
+ x11-libs/libXaw
+ xprint? ( x11-libs/libXprintUtil )"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+#src_compile() {
+# x-modular_src_configure
+# emake -j1 || die "emake failed"
+#}
diff --git a/x11-apps/xev/ChangeLog b/x11-apps/xev/ChangeLog
index 5362e5b7af23..dd3c5cd0a7ee 100644
--- a/x11-apps/xev/ChangeLog
+++ b/x11-apps/xev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xev/ChangeLog,v 1.5 2005/10/20 00:45:22 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xev/ChangeLog,v 1.6 2005/12/04 22:00:55 joshuabaergen Exp $
+
+*xev-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xev-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xev-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xev/files/digest-xev-0.99.2 b/x11-apps/xev/files/digest-xev-0.99.2
new file mode 100644
index 000000000000..a51ad8b4b969
--- /dev/null
+++ b/x11-apps/xev/files/digest-xev-0.99.2
@@ -0,0 +1 @@
+MD5 a264918cd4f90db7c87afe68f98d3582 xev-0.99.2.tar.bz2 78673
diff --git a/x11-apps/xev/xev-0.99.2.ebuild b/x11-apps/xev/xev-0.99.2.ebuild
new file mode 100644
index 000000000000..7a2fa50c923e
--- /dev/null
+++ b/x11-apps/xev/xev-0.99.2.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xev/xev-0.99.2.ebuild,v 1.1 2005/12/04 22:00:55 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xev application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xeyes/ChangeLog b/x11-apps/xeyes/ChangeLog
index 20e8e834b415..554f7f13b730 100644
--- a/x11-apps/xeyes/ChangeLog
+++ b/x11-apps/xeyes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xeyes
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xeyes/ChangeLog,v 1.5 2005/11/17 13:28:59 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xeyes/ChangeLog,v 1.6 2005/12/04 22:01:23 joshuabaergen Exp $
+
+*xeyes-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xeyes-0.99.2.ebuild:
+ Bump for 7.0RC3.
17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> xeyes-0.99.1.ebuild:
Marked ~amd64.
diff --git a/x11-apps/xeyes/files/digest-xeyes-0.99.2 b/x11-apps/xeyes/files/digest-xeyes-0.99.2
new file mode 100644
index 000000000000..5e805c65b5d6
--- /dev/null
+++ b/x11-apps/xeyes/files/digest-xeyes-0.99.2
@@ -0,0 +1 @@
+MD5 a8e1485e466607f6d3c2af75192a0af3 xeyes-0.99.2.tar.bz2 79831
diff --git a/x11-apps/xeyes/xeyes-0.99.2.ebuild b/x11-apps/xeyes/xeyes-0.99.2.ebuild
new file mode 100644
index 000000000000..c8a7f67a3233
--- /dev/null
+++ b/x11-apps/xeyes/xeyes-0.99.2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xeyes/xeyes-0.99.2.ebuild,v 1.1 2005/12/04 22:01:23 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xeyes application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xf86dga/ChangeLog b/x11-apps/xf86dga/ChangeLog
index c1fbc445090c..27985f5fe6a5 100644
--- a/x11-apps/xf86dga/ChangeLog
+++ b/x11-apps/xf86dga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xf86dga
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xf86dga/ChangeLog,v 1.5 2005/11/11 19:54:15 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xf86dga/ChangeLog,v 1.6 2005/12/04 22:01:55 joshuabaergen Exp $
+
+*xf86dga-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86dga-0.99.3.ebuild:
+ Bump for 7.0RC3.
*xf86dga-0.99.2 (11 Nov 2005)
diff --git a/x11-apps/xf86dga/files/digest-xf86dga-0.99.3 b/x11-apps/xf86dga/files/digest-xf86dga-0.99.3
new file mode 100644
index 000000000000..a51c9610ee45
--- /dev/null
+++ b/x11-apps/xf86dga/files/digest-xf86dga-0.99.3
@@ -0,0 +1 @@
+MD5 233d5c219723dcda459290d4ac638347 xf86dga-0.99.3.tar.bz2 73971
diff --git a/x11-apps/xf86dga/xf86dga-0.99.3.ebuild b/x11-apps/xf86dga/xf86dga-0.99.3.ebuild
new file mode 100644
index 000000000000..e12224eb9da8
--- /dev/null
+++ b/x11-apps/xf86dga/xf86dga-0.99.3.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xf86dga/xf86dga-0.99.3.ebuild,v 1.1 2005/12/04 22:01:55 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xf86dga application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXxf86dga"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xfd/ChangeLog b/x11-apps/xfd/ChangeLog
index 57dd975012f9..abf0ae000b93 100644
--- a/x11-apps/xfd/ChangeLog
+++ b/x11-apps/xfd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/ChangeLog,v 1.5 2005/10/20 00:45:22 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/ChangeLog,v 1.6 2005/12/04 22:02:22 joshuabaergen Exp $
+
+*xfd-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xfd-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xfd-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xfd/files/digest-xfd-0.99.2 b/x11-apps/xfd/files/digest-xfd-0.99.2
new file mode 100644
index 000000000000..0dafe52b704a
--- /dev/null
+++ b/x11-apps/xfd/files/digest-xfd-0.99.2
@@ -0,0 +1 @@
+MD5 0b44706f52656d1762a00fcf4a522f33 xfd-0.99.2.tar.bz2 87311
diff --git a/x11-apps/xfd/xfd-0.99.2.ebuild b/x11-apps/xfd/xfd-0.99.2.ebuild
new file mode 100644
index 000000000000..3a36f4d522e9
--- /dev/null
+++ b/x11-apps/xfd/xfd-0.99.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/xfd-0.99.2.ebuild,v 1.1 2005/12/04 22:02:22 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfd application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="=media-libs/freetype-2*
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xfindproxy/ChangeLog b/x11-apps/xfindproxy/ChangeLog
index 1e575f5ea7fc..ab2e3fc1e5ba 100644
--- a/x11-apps/xfindproxy/ChangeLog
+++ b/x11-apps/xfindproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xfindproxy
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfindproxy/ChangeLog,v 1.2 2005/11/11 19:54:43 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfindproxy/ChangeLog,v 1.3 2005/12/04 22:02:59 joshuabaergen Exp $
+
+*xfindproxy-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xfindproxy-0.99.3.ebuild:
+ Bump for 7.0RC3.
*xfindproxy-0.99.2 (11 Nov 2005)
diff --git a/x11-apps/xfindproxy/files/digest-xfindproxy-0.99.3 b/x11-apps/xfindproxy/files/digest-xfindproxy-0.99.3
new file mode 100644
index 000000000000..dc98307765d6
--- /dev/null
+++ b/x11-apps/xfindproxy/files/digest-xfindproxy-0.99.3
@@ -0,0 +1 @@
+MD5 b4d27764923c88211abbfaa9f8cf767a xfindproxy-0.99.3.tar.bz2 76470
diff --git a/x11-apps/xfindproxy/xfindproxy-0.99.3.ebuild b/x11-apps/xfindproxy/xfindproxy-0.99.3.ebuild
new file mode 100644
index 000000000000..0aced2e54d4d
--- /dev/null
+++ b/x11-apps/xfindproxy/xfindproxy-0.99.3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfindproxy/xfindproxy-0.99.3.ebuild,v 1.1 2005/12/04 22:02:59 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfindproxy application"
+KEYWORDS="~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xfontsel/ChangeLog b/x11-apps/xfontsel/ChangeLog
index 61ee23fe87a6..7859434c4c19 100644
--- a/x11-apps/xfontsel/ChangeLog
+++ b/x11-apps/xfontsel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xfontsel
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfontsel/ChangeLog,v 1.5 2005/11/06 18:29:05 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfontsel/ChangeLog,v 1.6 2005/12/04 22:03:30 joshuabaergen Exp $
+
+*xfontsel-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xfontsel-0.99.2.ebuild:
+ Bump for 7.0RC3.
06 Nov 2005; <dang@gentoo.org> xfontsel-0.99.1.ebuild:
Marked ~amd64
diff --git a/x11-apps/xfontsel/files/digest-xfontsel-0.99.2 b/x11-apps/xfontsel/files/digest-xfontsel-0.99.2
new file mode 100644
index 000000000000..fe8085da1e9d
--- /dev/null
+++ b/x11-apps/xfontsel/files/digest-xfontsel-0.99.2
@@ -0,0 +1 @@
+MD5 2ba71df364afe06ee9c48a4ecce13e34 xfontsel-0.99.2.tar.bz2 94219
diff --git a/x11-apps/xfontsel/xfontsel-0.99.2.ebuild b/x11-apps/xfontsel/xfontsel-0.99.2.ebuild
new file mode 100644
index 000000000000..478d6ee55c74
--- /dev/null
+++ b/x11-apps/xfontsel/xfontsel-0.99.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfontsel/xfontsel-0.99.2.ebuild,v 1.1 2005/12/04 22:03:30 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfontsel application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xfsinfo/ChangeLog b/x11-apps/xfsinfo/ChangeLog
index 68152a93037a..6b2de8d1f4db 100644
--- a/x11-apps/xfsinfo/ChangeLog
+++ b/x11-apps/xfsinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xfsinfo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfsinfo/ChangeLog,v 1.4 2005/10/20 00:45:23 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfsinfo/ChangeLog,v 1.5 2005/12/04 22:03:54 joshuabaergen Exp $
+
+*xfsinfo-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xfsinfo-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xfsinfo-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xfsinfo/files/digest-xfsinfo-0.99.2 b/x11-apps/xfsinfo/files/digest-xfsinfo-0.99.2
new file mode 100644
index 000000000000..a5833be4ad83
--- /dev/null
+++ b/x11-apps/xfsinfo/files/digest-xfsinfo-0.99.2
@@ -0,0 +1 @@
+MD5 5c801a0ab3c98d990cd819f186e527be xfsinfo-0.99.2.tar.bz2 73162
diff --git a/x11-apps/xfsinfo/xfsinfo-0.99.2.ebuild b/x11-apps/xfsinfo/xfsinfo-0.99.2.ebuild
new file mode 100644
index 000000000000..eeb82dd460c4
--- /dev/null
+++ b/x11-apps/xfsinfo/xfsinfo-0.99.2.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfsinfo/xfsinfo-0.99.2.ebuild,v 1.1 2005/12/04 22:03:54 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfsinfo application"
+KEYWORDS="~mips ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libFS"
+DEPEND="${RDEPEND}"