summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/numactl/ChangeLog8
-rw-r--r--sys-process/numactl/files/numactl-2.0.2-build.patch13
-rw-r--r--sys-process/numactl/numactl-2.0.2.ebuild28
3 files changed, 36 insertions, 13 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index a360e6cb640f..c751791c5614 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/numactl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.8 2008/09/29 23:40:12 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.9 2009/02/08 19:54:31 vapier Exp $
+
+ 08 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/numactl-2.0.2-build.patch, numactl-2.0.2.ebuild:
+ Fix linking order #248444 by Diego E. Pettenò.
*numactl-2.0.2 (29 Sep 2008)
diff --git a/sys-process/numactl/files/numactl-2.0.2-build.patch b/sys-process/numactl/files/numactl-2.0.2-build.patch
new file mode 100644
index 000000000000..acb04b8ab81b
--- /dev/null
+++ b/sys-process/numactl/files/numactl-2.0.2-build.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 3795115..28a9418 100755
+--- a/Makefile
++++ b/Makefile
+@@ -57,7 +57,7 @@ memhog: util.o memhog.o libnuma.so
+
+ numactl.o: numactl.c
+
+-numademo: override LDFLAGS += -lm
++numademo: LDLIBS += -lm
+ # GNU make 3.80 appends BENCH_CFLAGS twice. Bug? It's harmless though.
+ numademo: CFLAGS += -DHAVE_STREAM_LIB -DHAVE_MT -DHAVE_CLEAR_CACHE ${BENCH_CFLAGS}
+ stream_lib.o: CFLAGS += ${BENCH_CFLAGS}
diff --git a/sys-process/numactl/numactl-2.0.2.ebuild b/sys-process/numactl/numactl-2.0.2.ebuild
index 7bc480a04847..e8b5d26c6b44 100644
--- a/sys-process/numactl/numactl-2.0.2.ebuild
+++ b/sys-process/numactl/numactl-2.0.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.1 2008/09/29 23:40:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.2 2009/02/08 19:54:31 vapier Exp $
-inherit base eutils toolchain-funcs
+inherit eutils toolchain-funcs
-DESCRIPTION="Utilities and libraries for NUMA systems."
+DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
@@ -15,10 +15,23 @@ IUSE="perl"
RDEPEND="perl? ( dev-lang/perl )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
}
+src_test() {
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+}
+
src_install() {
emake install prefix="${D}/usr" || die
# delete man pages provided by the man-pages package #238805
@@ -29,10 +42,3 @@ src_install() {
rm "${D}"/usr/bin/numastat "${D}"/usr/share/man/man8/numastat.8 || die
fi
}
-
-src_test() {
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- cd test
- ./regress2 || die "regress2 failed!"
-}