summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/lua/ChangeLog7
-rw-r--r--dev-lang/lua/files/digest-lua-5.1.2-r23
-rw-r--r--dev-lang/lua/lua-5.1.2-r2.ebuild105
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index d10d6bf94fbb..e55dc3a8f41f 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.84 2007/04/24 11:20:19 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.85 2007/09/18 08:14:28 mabi Exp $
+
+*lua-5.1.2-r2 (18 Sep 2007)
+
+ 18 Sep 2007; Matti Bickel <mabi@gentoo.org> +lua-5.1.2-r2.ebuild:
+ new revision fixing bug #191333
24 Apr 2007; Alexander Færøy <eroyf@gentoo.org> lua-5.1.1-r2.ebuild:
Marked ~mips.
diff --git a/dev-lang/lua/files/digest-lua-5.1.2-r2 b/dev-lang/lua/files/digest-lua-5.1.2-r2
new file mode 100644
index 000000000000..0847c24c6a15
--- /dev/null
+++ b/dev-lang/lua/files/digest-lua-5.1.2-r2
@@ -0,0 +1,3 @@
+MD5 687ce4c2a1ddff18f1008490fdc4e5e0 lua-5.1.2.tar.gz 214134
+RMD160 01350549b3a05838925dae1a666700bb9f1bc01a lua-5.1.2.tar.gz 214134
+SHA256 5cf098c6fe68d3d2d9221904f1017ff0286e4a9cc166a1452a456df9b88b3d9e lua-5.1.2.tar.gz 214134
diff --git a/dev-lang/lua/lua-5.1.2-r2.ebuild b/dev-lang/lua/lua-5.1.2-r2.ebuild
new file mode 100644
index 000000000000..95d7bccfab7e
--- /dev/null
+++ b/dev-lang/lua/lua-5.1.2-r2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2-r2.ebuild,v 1.1 2007/09/18 08:14:28 mabi Exp $
+
+inherit eutils portability versionator
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="http://www.lua.org/"
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="readline static"
+
+DEPEND="readline? ( sys-libs/readline )"
+
+src_unpack() {
+ local PATCH_PV=$(get_version_component_range 1-2)
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
+
+ # correct lua versioning (bug #173611)
+ sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:2:1/' src/Makefile
+
+ sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
+
+ if ! use readline ; then
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
+ fi
+
+ # Using dynamic linked lua is not recommended upstream for performance
+ # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
+ # Mainly, this is of concern if your arch is poor with GPRs, like x86
+ # Note that the lua compiler is build statically anyway
+ if use static ; then
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
+ fi
+
+ # We want packages to find our things...
+ sed -i -e 's:/usr/local:/usr:' etc/lua.pc
+}
+
+src_compile() {
+ myflags=
+ # what to link to liblua
+ liblibs="-lm"
+ if use ppc-macos; then
+ mycflags="${mycflags} -DLUA_USE_MACOSX"
+ else # building for standard linux (and bsd too)
+ mycflags="${mycflags} -DLUA_USE_LINUX"
+ liblibs="${liblibs} $(dlopen_lib)"
+ fi
+
+ # what to link to the executables
+ mylibs=
+ if use readline; then
+ mylibs="-lreadline"
+ fi
+
+ cd src
+ emake CFLAGS="${mycflags} ${CFLAGS}" \
+ RPATH="/usr/$(get_libdir)/" \
+ LUA_LIBS="${mylibs}" \
+ LIB_LIBS="${liblibs}" \
+ V=${PV} \
+ gentoo_all || die "emake failed"
+
+ mv lua_test ../test/lua.static
+}
+
+src_install() {
+ emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
+ V=${PV} gentoo_install \
+ || die "emake install gentoo_install failed"
+
+ dodoc HISTORY README
+ dohtml doc/*.html doc/*.gif
+
+ insinto /usr/share/pixmaps
+ doins etc/lua.ico
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins etc/lua.pc
+
+ doman doc/lua.1 doc/luac.1
+}
+
+src_test() {
+ local positive="bisect cf echo env factorial fib fibfor hello printf sieve
+ sort trace-calls trace-globals"
+ local negative="readonly"
+ local test
+
+ cd "${S}"
+ for test in ${positive}; do
+ test/lua.static test/${test}.lua &> /dev/null || die "test $test failed"
+ done
+
+ for test in ${negative}; do
+ test/lua.static test/${test}.lua &> /dev/null && die "test $test failed"
+ done
+}