summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/vcsh/ChangeLog8
-rw-r--r--dev-vcs/vcsh/vcsh-1.20140508-r1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-vcs/vcsh/ChangeLog b/dev-vcs/vcsh/ChangeLog
index b2b2cd7b070e..b8e01163b2cd 100644
--- a/dev-vcs/vcsh/ChangeLog
+++ b/dev-vcs/vcsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/vcsh
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/ChangeLog,v 1.8 2014/05/25 21:37:47 dastergon Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/ChangeLog,v 1.9 2014/09/09 15:10:40 dev-zero Exp $
+
+*vcsh-1.20140508-r1 (09 Sep 2014)
+
+ 09 Sep 2014; Tiziano Müller <dev-zero@gentoo.org> +vcsh-1.20140508-r1.ebuild:
+ Make installation of manpage optional via USE=doc due to ruby dep for building
+ it. Install sample hooks as docs.
*vcsh-1.20140508 (25 May 2014)
diff --git a/dev-vcs/vcsh/vcsh-1.20140508-r1.ebuild b/dev-vcs/vcsh/vcsh-1.20140508-r1.ebuild
new file mode 100644
index 000000000000..3c630d003980
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20140508-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/vcsh-1.20140508-r1.ebuild,v 1.1 2014/09/09 15:10:40 dev-zero Exp $
+
+EAPI=5
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+SRC_URI="http://github.com/RichiH/vcsh/archive/v${PV}-1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-vcs/git"
+DEPEND="doc? ( app-text/ronn )"
+
+S=${S}-1
+
+src_compile() {
+ use doc && emake manpages
+}
+
+src_install() {
+ dobin vcsh
+
+ dodoc -r changelog CONTRIBUTORS README.md doc/{hooks,sample_hooks}
+ insinto /usr/share/zsh/site-functions
+ doins _vcsh
+
+ use doc && doman vcsh.1
+}