summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/henplus/ChangeLog10
-rw-r--r--dev-db/henplus/files/0.9.8-build.xml.patch23
-rw-r--r--dev-db/henplus/henplus-0.9.8.ebuild44
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-db/henplus/ChangeLog b/dev-db/henplus/ChangeLog
index f4951587476f..71b96cb38207 100644
--- a/dev-db/henplus/ChangeLog
+++ b/dev-db/henplus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/henplus
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.21 2008/11/17 20:54:11 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.22 2009/05/01 20:51:17 betelgeuse Exp $
+
+*henplus-0.9.8 (01 May 2009)
+
+ 01 May 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +files/0.9.8-build.xml.patch, +henplus-0.9.8.ebuild:
+ Version bump. Fixes bug #268125.
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org> files/henplus.patch:
Fix patch with absolute paths.
diff --git a/dev-db/henplus/files/0.9.8-build.xml.patch b/dev-db/henplus/files/0.9.8-build.xml.patch
new file mode 100644
index 000000000000..e2763978080e
--- /dev/null
+++ b/dev-db/henplus/files/0.9.8-build.xml.patch
@@ -0,0 +1,23 @@
+diff -ur henplus-0.9.8.old/build.xml henplus-0.9.8/build.xml
+--- henplus-0.9.8.old/build.xml 2009-05-01 23:51:41.000000000 +0300
++++ henplus-0.9.8/build.xml 2009-05-01 23:52:31.000000000 +0300
+@@ -33,13 +33,13 @@
+ <pathelement path="${classes}" />
+ </path>
+
+- <taskdef name="ant-server" classname="net.sweetohm.ant.server.ServerTask">
+- <classpath>
+- <pathelement location="${lib}/build/sat-0.7.jar" />
+- </classpath>
+- </taskdef>
+-
+ <target name="server">
++ <taskdef name="ant-server" classname="net.sweetohm.ant.server.ServerTask">
++ <classpath>
++ <pathelement location="${lib}/build/sat-0.7.jar" />
++ </classpath>
++ </taskdef>
++
+ <ant-server/>
+ </target>
+
diff --git a/dev-db/henplus/henplus-0.9.8.ebuild b/dev-db/henplus/henplus-0.9.8.ebuild
new file mode 100644
index 000000000000..cbfa00519276
--- /dev/null
+++ b/dev-db/henplus/henplus-0.9.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/henplus-0.9.8.ebuild,v 1.1 2009/05/01 20:51:17 betelgeuse Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="Java-based multisession SQL shell for databases with JDBC support."
+HOMEPAGE="http://henplus.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/commons-cli:1
+ dev-java/libreadline-java:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}"
+
+java_prepare() {
+ epatch "${FILESDIR}/0.9.8-build.xml.patch"
+ rm -v lib/*.jar lib/*/*.jar || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-cli-1,libreadline-java"
+
+src_install () {
+ java-pkg_dojar "build/${PN}.jar"
+
+ java-pkg_dolauncher ${PN} -pre "${FILESDIR}/${PN}.pre" \
+ --main henplus.HenPlus
+
+ dodoc README || die
+ dohtml doc/HenPlus.html || die
+ use doc && java-pkg_dojavadoc javadoc/api
+
+ use source && java-pkg_dosrc "src/${PN}"
+}