summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gksu/ChangeLog9
-rw-r--r--x11-libs/gksu/files/digest-gksu-2.0.03
-rw-r--r--x11-libs/gksu/gksu-1.9.1.ebuild4
-rw-r--r--x11-libs/gksu/gksu-2.0.0.ebuild42
4 files changed, 55 insertions, 3 deletions
diff --git a/x11-libs/gksu/ChangeLog b/x11-libs/gksu/ChangeLog
index 4c78eac8015b..d867d39046b5 100644
--- a/x11-libs/gksu/ChangeLog
+++ b/x11-libs/gksu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gksu
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gksu/ChangeLog,v 1.22 2006/09/28 19:54:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gksu/ChangeLog,v 1.23 2006/09/29 14:45:54 dang Exp $
+
+*gksu-2.0.0 (29 Sep 2006)
+
+ 29 Sep 2006; Daniel Gryniewicz <dang@gentoo.org> gksu-1.9.1.ebuild,
+ +gksu-2.0.0.ebuild:
+ 2.0.0 is out. New feature is the nautilus extension (Open as administrator).
+ Also, upstream moved the download location for 1.9.1, fix that
28 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> gksu-1.9.1.ebuild:
Stable on sparc wrt #149444
diff --git a/x11-libs/gksu/files/digest-gksu-2.0.0 b/x11-libs/gksu/files/digest-gksu-2.0.0
new file mode 100644
index 000000000000..94f165691baf
--- /dev/null
+++ b/x11-libs/gksu/files/digest-gksu-2.0.0
@@ -0,0 +1,3 @@
+MD5 f517302cff6f09e4f2f312c4b618bd40 gksu-2.0.0.tar.gz 440748
+RMD160 5045d7c4ca56e8ca2fb7049c7e86c382cda67df2 gksu-2.0.0.tar.gz 440748
+SHA256 8148faf12bb2bbd321b08c1207e7aa5ae93d5cc8b8809e2de6ce5af1e1c5b85b gksu-2.0.0.tar.gz 440748
diff --git a/x11-libs/gksu/gksu-1.9.1.ebuild b/x11-libs/gksu/gksu-1.9.1.ebuild
index 8114656ea896..a44d8acf5b5a 100644
--- a/x11-libs/gksu/gksu-1.9.1.ebuild
+++ b/x11-libs/gksu/gksu-1.9.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gksu/gksu-1.9.1.ebuild,v 1.4 2006/09/28 19:54:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gksu/gksu-1.9.1.ebuild,v 1.5 2006/09/29 14:45:54 dang Exp $
inherit gnome2 fixheadtails
DESCRIPTION="A gtk+ frontend for libgksu"
HOMEPAGE="http://www.nongnu.org/gksu/"
-SRC_URI="http://people.debian.org/~kov/gksu/gksu/${P}.tar.gz"
+SRC_URI="http://people.debian.org/~kov/gksu/old_stuff/gksu/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc ~x86"
diff --git a/x11-libs/gksu/gksu-2.0.0.ebuild b/x11-libs/gksu/gksu-2.0.0.ebuild
new file mode 100644
index 000000000000..684cb443c1f4
--- /dev/null
+++ b/x11-libs/gksu/gksu-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gksu/gksu-2.0.0.ebuild,v 1.1 2006/09/29 14:45:54 dang Exp $
+
+inherit gnome2 fixheadtails
+
+DESCRIPTION="A gtk+ frontend for libgksu"
+HOMEPAGE="http://www.nongnu.org/gksu/"
+SRC_URI="http://people.debian.org/~kov/gksu/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc gnome"
+
+RDEPEND=">=x11-libs/libgksu-2
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/gconf-2.0
+ gnome? ( >=gnome-base/nautilus-2 )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+
+G2CONF="$(use_enable doc gtk-doc) $(use_enable gnome nautilus-extension)"
+USE_DESTDIR="1"
+
+src_unpack() {
+ gnome2_src_unpack
+ ht_fix_file "${S}/gksu-migrate-conf.sh"
+}
+
+src_install() {
+ gnome2_src_install
+ chmod +x "${D}/usr/share/gksu/gksu-migrate-conf.sh"
+}
+
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ einfo 'updating configuration'
+ "${ROOT}"/usr/share/gksu/gksu-migrate-conf.sh
+}