summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-0.6.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 62821f4761e5..27d7e6a6ddc4 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.14 2011/03/22 10:36:48 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.15 2011/09/09 09:01:38 djc Exp $
+
+*wtforms-0.6.3 (09 Sep 2011)
+
+ 09 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +wtforms-0.6.3.ebuild:
+ Version bump to 0.6.3.
22 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-wtforms-0.6.1.ebuild:
diff --git a/dev-python/wtforms/wtforms-0.6.3.ebuild b/dev-python/wtforms/wtforms-0.6.3.ebuild
new file mode 100644
index 000000000000..65fa46193b04
--- /dev/null
+++ b/dev-python/wtforms/wtforms-0.6.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.6.3.ebuild,v 1.1 2011/09/09 09:01:38 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test() {
+ cd tests
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}