summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php4/pecl-memcache/ChangeLog6
-rw-r--r--dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild9
-rw-r--r--dev-php5/pecl-memcache/ChangeLog6
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild9
4 files changed, 20 insertions, 10 deletions
diff --git a/dev-php4/pecl-memcache/ChangeLog b/dev-php4/pecl-memcache/ChangeLog
index bc528501a0c7..4d82091eecc4 100644
--- a/dev-php4/pecl-memcache/ChangeLog
+++ b/dev-php4/pecl-memcache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php4/pecl-memcache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/ChangeLog,v 1.6 2006/01/06 17:39:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/ChangeLog,v 1.7 2006/01/11 03:59:44 robbat2 Exp $
+
+ 11 Jan 2006; Robin H. Johnson <robbat2@gentoo.org>
+ pecl-memcache-2.0.0.ebuild:
+ Better fix for bug #117990.
06 Jan 2006; Luca Longinotti <chtekk@gentoo.org>
+files/config-zlib-det-fix.patch, pecl-memcache-2.0.0.ebuild:
diff --git a/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild b/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild
index e817189377c5..23ee2139c6a8 100644
--- a/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild
+++ b/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.2 2006/01/06 17:39:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.3 2006/01/11 03:59:44 robbat2 Exp $
PHP_EXT_NAME="memcache"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-inherit php-ext-pecl-r1
+inherit php-ext-pecl-r1 eutils
KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="PHP extension for using memcached."
@@ -24,8 +24,9 @@ src_unpack() {
cd "${S}"
- # change configure to fix bug #117990
- epatch "${FILESDIR}/config-zlib-det-fix.patch"
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
}
src_compile() {
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index 6042eecfe126..bdcad166e716 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.6 2006/01/06 17:43:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.7 2006/01/11 04:00:53 robbat2 Exp $
+
+ 11 Jan 2006; Robin H. Johnson <robbat2@gentoo.org>
+ pecl-memcache-2.0.0.ebuild:
+ Better fix for bug #117990.
06 Jan 2006; Luca Longinotti <chtekk@gentoo.org>
+files/config-zlib-det-fix.patch, pecl-memcache-2.0.0.ebuild:
diff --git a/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild b/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
index bf578bbc8856..6ecdcd108c90 100644
--- a/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
+++ b/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.2 2006/01/06 17:43:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.3 2006/01/11 04:00:53 robbat2 Exp $
PHP_EXT_NAME="memcache"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-inherit php-ext-pecl-r1
+inherit php-ext-pecl-r1 eutils
KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="PHP extension for using memcached."
@@ -24,8 +24,9 @@ src_unpack() {
cd "${S}"
- # change configure to fix bug #117990
- epatch "${FILESDIR}/config-zlib-det-fix.patch"
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
}
src_compile() {