summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/uim/ChangeLog6
-rw-r--r--app-i18n/uim/files/uim-1.6.1-libnotify-0.7.patch25
-rw-r--r--app-i18n/uim/uim-1.6.1.ebuild9
3 files changed, 35 insertions, 5 deletions
diff --git a/app-i18n/uim/ChangeLog b/app-i18n/uim/ChangeLog
index 3294f58d6d6b..007187fffa2b 100644
--- a/app-i18n/uim/ChangeLog
+++ b/app-i18n/uim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/uim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.227 2011/01/08 06:21:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.228 2011/02/05 07:37:11 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> uim-1.6.1.ebuild,
+ +files/uim-1.6.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*uim-1.6.1 (08 Jan 2011)
diff --git a/app-i18n/uim/files/uim-1.6.1-libnotify-0.7.patch b/app-i18n/uim/files/uim-1.6.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..4899794c52da
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.6.1-libnotify-0.7.patch
@@ -0,0 +1,25 @@
+--- notify/uim-libnotify.c
++++ notify/uim-libnotify.c
+@@ -44,6 +44,10 @@
+ #include "uim-notify.h"
+ #include "gettext.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define UIM_ICON UIM_PIXMAPSDIR "/uim-icon.png"
+ #define UGETTEXT(str) (dgettext(GETTEXT_PACKAGE, (str)))
+
+@@ -73,7 +77,11 @@
+ return UIM_FALSE;
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification = notify_notification_new("uim", gmsg, UIM_ICON);
++#else
+ notification = notify_notification_new("uim", gmsg, UIM_ICON, NULL);
++#endif
+
+ if (!notification) {
+ fprintf(stderr, "notify_notification_new: can not create notification object\n");
diff --git a/app-i18n/uim/uim-1.6.1.ebuild b/app-i18n/uim/uim-1.6.1.ebuild
index ab57bfbc0a36..f4254c81ffef 100644
--- a/app-i18n/uim/uim-1.6.1.ebuild
+++ b/app-i18n/uim/uim-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.6.1.ebuild,v 1.1 2011/01/08 06:21:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.6.1.ebuild,v 1.2 2011/02/05 07:37:11 ssuominen Exp $
EAPI="3"
inherit autotools eutils multilib elisp-common flag-o-matic
@@ -93,9 +93,10 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}/${PN}-1.6.0-gentoo.patch" \
- "${FILESDIR}/${PN}-1.5.4-zhTW.patch" \
- "${FILESDIR}/${PN}-1.6.0-linker.patch"
+ "${FILESDIR}"/${PN}-1.6.0-gentoo.patch \
+ "${FILESDIR}"/${PN}-1.5.4-zhTW.patch \
+ "${FILESDIR}"/${PN}-1.6.0-linker.patch \
+ "${FILESDIR}"/${PN}-1.6.1-libnotify-0.7.patch
# bug 275420
sed -i -e "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac || die