summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/g15daemon/ChangeLog9
-rw-r--r--app-misc/g15daemon/files/digest-g15daemon-1.9.13
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.2.7-r2.initd41
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.1.ebuild132
-rw-r--r--app-misc/g15daemon/metadata.xml4
5 files changed, 186 insertions, 3 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index 7a06ae398663..9c89462e7506 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.16 2007/10/04 08:43:58 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.17 2007/12/19 17:38:29 chainsaw Exp $
+
+*g15daemon-1.9.1 (19 Dec 2007)
+
+ 19 Dec 2007; Tony Vroon <chainsaw@gentoo.org>
+ +files/g15daemon-1.2.7-r2.initd, metadata.xml, +g15daemon-1.9.1.ebuild:
+ Version bump. Prevent "pid X is not a child of this shell" message by
+ shutting down the daemon differently. Took maintainership.
*g15daemon-1.9.0-r1 (04 Oct 2007)
*g15daemon-1.2.7-r1 (04 Oct 2007)
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.9.1 b/app-misc/g15daemon/files/digest-g15daemon-1.9.1
new file mode 100644
index 000000000000..89a7be3af481
--- /dev/null
+++ b/app-misc/g15daemon/files/digest-g15daemon-1.9.1
@@ -0,0 +1,3 @@
+MD5 e1f86ed0ebcaba3584187f33a36a634f g15daemon-1.9.1.tar.bz2 301481
+RMD160 2dab5ced813edb598b5b680f1fceee57164d7967 g15daemon-1.9.1.tar.bz2 301481
+SHA256 a0928871e4f597278397e7f9a90247d4e4586870b58932b213fb1d1a30e0e7d3 g15daemon-1.9.1.tar.bz2 301481
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.7-r2.initd b/app-misc/g15daemon/files/g15daemon-1.2.7-r2.initd
new file mode 100644
index 000000000000..b8e8cd6a5714
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.2.7-r2.initd
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.2.7-r2.initd,v 1.1 2007/12/19 17:38:30 chainsaw Exp $
+
+# Init script for g15daemon
+
+depend() {
+ after hotplug
+ after usb
+ after modules
+}
+
+start() {
+ ebegin "Starting g15daemon"
+
+ # Does the input device already exist?
+ if [ -e /proc/modules -a ! -e /dev/input/uinput ]; then
+ # We can load modules, but uinput device does not exist
+ einfo "Loading uinput module"
+ /sbin/modprobe uinput > /dev/null 2> /dev/null
+ fi
+
+ local SWITCHKEY=""
+ [ "${CLIENT_SWITCH_L1}" = "yes" ] && SWITCHKEY="--switch"
+ start-stop-daemon --start --background --pidfile /var/run/g15daemon.pid \
+ --exec /usr/sbin/g15daemon -- ${SWITCHKEY}
+ eend $? "Failed to start g15daemon."
+}
+
+stop() {
+ ebegin "Stopping g15daemon"
+ local KILLOPT="-k"
+ if [ $BACKLIGHT_OFF = "yes" ]; then
+ KILLOPT="-K"
+ fi
+ /usr/sbin/g15daemon ${KILLOPT} &>/dev/null
+ sleep 1
+ start-stop-daemon -R 5 --stop --quiet --pidfile /var/run/g15daemon.pid
+ eend $?
+}
diff --git a/app-misc/g15daemon/g15daemon-1.9.1.ebuild b/app-misc/g15daemon/g15daemon-1.9.1.ebuild
new file mode 100644
index 000000000000..267d2de0ca05
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-1.9.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.1.ebuild,v 1.1 2007/12/19 17:38:29 chainsaw Exp $
+
+inherit eutils linux-info perl-module python multilib
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="perl python"
+
+DEPEND="dev-libs/libusb
+ >=dev-libs/libg15-1.2.4
+ >=dev-libs/libg15render-1.2
+ perl? ( >=dev-perl/Inline-0.4 )
+ python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ linux_chkconfig_present INPUT_UINPUT
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ die "INPUT_UINPUT support not detected!"
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+}
+
+src_unpack() {
+ unpack ${A}
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_compile() {
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} install || die "make install failed"
+
+ # remove odd docs installed my make
+ rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+ python_version
+
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
+ doins g15daemon.py
+
+ docinto python
+ dodoc AUTHORS
+ fi
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize "${ROOT}/usr/$(get_libdir)/python*/site-packages/g15daemon"
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
+ fi
+}
diff --git a/app-misc/g15daemon/metadata.xml b/app-misc/g15daemon/metadata.xml
index dce4644a99be..3ae74f316232 100644
--- a/app-misc/g15daemon/metadata.xml
+++ b/app-misc/g15daemon/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>lcd</herd>
<maintainer>
- <email>rob@thetruth.de</email>
- <name>Robert Buchholz</name>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
</maintainer>
</pkgmetadata>