summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/cuyo/ChangeLog10
-rw-r--r--games-puzzle/cuyo/cuyo-1.8.6.ebuild42
-rw-r--r--games-puzzle/cuyo/files/cuyo-1.8.6-gcc4.patch11
-rw-r--r--games-puzzle/cuyo/files/digest-cuyo-1.8.63
4 files changed, 64 insertions, 2 deletions
diff --git a/games-puzzle/cuyo/ChangeLog b/games-puzzle/cuyo/ChangeLog
index 308ca3898deb..08dd1e63c37e 100644
--- a/games-puzzle/cuyo/ChangeLog
+++ b/games-puzzle/cuyo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/cuyo
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.13 2006/10/08 22:22:59 nyhm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/ChangeLog,v 1.14 2007/05/27 08:36:20 tupone Exp $
+
+*cuyo-1.8.6 (27 May 2007)
+
+ 27 May 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/cuyo-1.8.6-gcc4.patch, +cuyo-1.8.6.ebuild:
+ Version bump. Bug #160072 by Pacho Ramos
08 Oct 2006; Tristan Heaven <nyhm@gentoo.org> cuyo-1.8.5.ebuild:
Use qt3 eclass
diff --git a/games-puzzle/cuyo/cuyo-1.8.6.ebuild b/games-puzzle/cuyo/cuyo-1.8.6.ebuild
new file mode 100644
index 000000000000..861f61057fbd
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-1.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.6.ebuild,v 1.1 2007/05/27 08:36:20 tupone Exp $
+
+inherit toolchain-funcs eutils qt3 games
+
+DESCRIPTION="highly addictive and remotely related to tetris"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+SRC_URI="http://savannah.nongnu.org/download/cuyo/${P//_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3)"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^gamesdir.*=/ s:\$(prefix)/games:$(bindir):' \
+ -e 's:-O2:@CXXFLAGS@ -Wno-long-long:' src/Makefile.in \
+ || die "sed src/Makefile.in failed"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
+src_compile() {
+ egamesconf \
+ --with-qtdir="${QTDIR}" \
+ --with-x \
+ || die
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO ChangeLog
+ prepgamesdirs
+}
diff --git a/games-puzzle/cuyo/files/cuyo-1.8.6-gcc4.patch b/games-puzzle/cuyo/files/cuyo-1.8.6-gcc4.patch
new file mode 100644
index 000000000000..a2fd81202f1f
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-1.8.6-gcc4.patch
@@ -0,0 +1,11 @@
+--- src/fall.cpp.old 2007-05-27 10:14:08.000000000 +0200
++++ src/fall.cpp 2007-05-27 10:14:42.000000000 +0200
+@@ -381,7 +381,7 @@
+ }
+ /** Liefert true, wenn das Fall existiert.
+ Mit Argument: Wenn diese Hälfte existiert. */
+-bool Fall::existiert(int a=0) const {
++bool Fall::existiert(int a) const {
+ return mPos.r != richtung_keins && !(mPos.r == richtung_einzel && a == 1);
+ }
+
diff --git a/games-puzzle/cuyo/files/digest-cuyo-1.8.6 b/games-puzzle/cuyo/files/digest-cuyo-1.8.6
new file mode 100644
index 000000000000..bfef7ac7f73e
--- /dev/null
+++ b/games-puzzle/cuyo/files/digest-cuyo-1.8.6
@@ -0,0 +1,3 @@
+MD5 c0c1e5d435109e3a8e48b7a18594e30f cuyo-1.8.6.tar.gz 1444617
+RMD160 6b39aa146dbcfb4c51b511fce495bec7876a53a6 cuyo-1.8.6.tar.gz 1444617
+SHA256 4b8ed5fa01ec922f19d52a7da9538a55a6bbe4c728c904a49ffeb7e3174d1f6d cuyo-1.8.6.tar.gz 1444617