summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/truevision/ChangeLog6
-rw-r--r--media-gfx/truevision/files/truevision-0.5.5.2-gcc43.patch12
-rw-r--r--media-gfx/truevision/truevision-0.5.5.2.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/media-gfx/truevision/ChangeLog b/media-gfx/truevision/ChangeLog
index 53ad9a776fc6..ece0d3ebbb0e 100644
--- a/media-gfx/truevision/ChangeLog
+++ b/media-gfx/truevision/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/truevision
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/ChangeLog,v 1.17 2008/01/21 04:36:31 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/ChangeLog,v 1.18 2008/12/21 16:04:47 maekke Exp $
+
+ 21 Dec 2008; Markus Meier <maekke@gentoo.org>
+ +files/truevision-0.5.5.2-gcc43.patch, truevision-0.5.5.2.ebuild:
+ fix building with gcc-4.3, bug #251152
21 Jan 2008; Richard Freeman <rich0@gentoo.org> truevision-0.5.5.2.ebuild:
amd64 marked for testing - bug 205477
diff --git a/media-gfx/truevision/files/truevision-0.5.5.2-gcc43.patch b/media-gfx/truevision/files/truevision-0.5.5.2-gcc43.patch
new file mode 100644
index 000000000000..85c671d75a8b
--- /dev/null
+++ b/media-gfx/truevision/files/truevision-0.5.5.2-gcc43.patch
@@ -0,0 +1,12 @@
+diff -ur truevision-0.5.5.orig/include/objparam.h truevision-0.5.5/include/objparam.h
+--- truevision-0.5.5.orig/include/objparam.h 2008-12-21 16:57:25.000000000 +0100
++++ truevision-0.5.5/include/objparam.h 2008-12-21 16:58:49.000000000 +0100
+@@ -465,7 +465,7 @@
+ TvWidget_entry( name, sname, tooltip, appref, val) {}
+ ObjParam_entry( ObjParam_entry & ref ) : ObjParam( ref ), TvWidget_entry( ref ) {}
+ void get_widget( GtkWidget *box, bool tt );
+- void get_widget( GtkWidget *row, bool tt, int row );
++ void get_widget( GtkWidget *tab, bool tt, int row );
+ void flush();
+ void swap_data( ObjParam *param );
+ };
diff --git a/media-gfx/truevision/truevision-0.5.5.2.ebuild b/media-gfx/truevision/truevision-0.5.5.2.ebuild
index 35bd92bdc567..9b90f3c1eafa 100644
--- a/media-gfx/truevision/truevision-0.5.5.2.ebuild
+++ b/media-gfx/truevision/truevision-0.5.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/truevision-0.5.5.2.ebuild,v 1.9 2008/01/21 04:36:31 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/truevision-0.5.5.2.ebuild,v 1.10 2008/12/21 16:04:47 maekke Exp $
inherit eutils gnome2 versionator
@@ -39,6 +39,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-makefile-mime-magic.patch
# bug 148763 - won't compile with gcc4
epatch "${DISTDIR}"/${P}-gcc4.diff.bz2
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {