summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.6-gcc44.patch14
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.6.ebuild40
3 files changed, 61 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index a4da85124d6a..a7a35c73723c 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.146 2009/12/09 19:27:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.147 2009/12/22 20:07:40 ssuominen Exp $
+
+*libtorrent-0.12.6 (22 Dec 2009)
+
+ 22 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +libtorrent-0.12.6.ebuild, +files/libtorrent-0.12.6-gcc44.patch:
+ Version bump.
09 Dec 2009; nixnut <nixnut@gentoo.org> libtorrent-0.12.5.ebuild:
ppc stable #291036
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.6-gcc44.patch b/net-libs/libtorrent/files/libtorrent-0.12.6-gcc44.patch
new file mode 100644
index 000000000000..ca1f2ba8f8a6
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.6-gcc44.patch
@@ -0,0 +1,14 @@
+Missing include required by snprintf and --disable-openssl ./configure switch.
+
+diff -ur libtorrent-0.12.6.orig/src/protocol/handshake.cc libtorrent-0.12.6/src/protocol/handshake.cc
+--- libtorrent-0.12.6.orig/src/protocol/handshake.cc 2009-11-12 10:03:51.000000000 +0200
++++ libtorrent-0.12.6/src/protocol/handshake.cc 2009-12-22 22:05:27.000000000 +0200
+@@ -53,6 +53,8 @@
+ #include "handshake.h"
+ #include "handshake_manager.h"
+
++#include <stdio.h>
++
+ namespace torrent {
+
+ const char* Handshake::m_protocol = "BitTorrent protocol";
diff --git a/net-libs/libtorrent/libtorrent-0.12.6.ebuild b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
new file mode 100644
index 000000000000..484fe9fb27e5
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.6.ebuild,v 1.1 2009/12/22 20:07:40 ssuominen Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ --with-posix-fallocate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}