summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/junit/ChangeLog6
-rw-r--r--dev-java/junit/junit-3.8.2-r1.ebuild6
-rw-r--r--dev-java/junit/junit-4.6.ebuild74
-rw-r--r--dev-java/junit/junit-4.8.2-r1.ebuild87
4 files changed, 8 insertions, 165 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index f394b699b5e0..456a9cb51795 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.85 2015/07/10 12:48:21 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.86 2015/07/11 09:20:21 chewi Exp $
+
+ 11 Jul 2015; James Le Cuirot <chewi@gentoo.org> junit-3.8.2-r1.ebuild,
+ -junit-4.6.ebuild, -junit-4.8.2-r1.ebuild:
+ Drop java on ia64 and also drop old versions.
*junit-4.12 (10 Jul 2015)
diff --git a/dev-java/junit/junit-3.8.2-r1.ebuild b/dev-java/junit/junit-3.8.2-r1.ebuild
index 1a05f25f8317..581e0310879f 100644
--- a/dev-java/junit/junit-3.8.2-r1.ebuild
+++ b/dev-java/junit/junit-3.8.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.2-r1.ebuild,v 1.12 2013/02/05 05:50:17 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.2-r1.ebuild,v 1.13 2015/07/11 09:20:21 chewi Exp $
JAVA_PKG_IUSE="doc source"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
HOMEPAGE="http://www.junit.org/"
LICENSE="CPL-1.0"
SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND=">=virtual/jdk-1.4
app-arch/unzip"
diff --git a/dev-java/junit/junit-4.6.ebuild b/dev-java/junit/junit-4.6.ebuild
deleted file mode 100644
index 6e1662d14953..000000000000
--- a/dev-java/junit/junit-4.6.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.6.ebuild,v 1.9 2012/01/01 22:39:29 sera Exp $
-
-# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
-
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P=${P/-/}
-DESCRIPTION="Simple framework to write repeatable tests"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-HOMEPAGE="http://www.junit.org/"
-LICENSE="CPL-1.0"
-SLOT="4"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-CDEPEND="=dev-java/hamcrest-core-1.1*"
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.5
- userland_GNU? ( >=sys-apps/findutils-4.3 )
- app-arch/unzip
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mkdir -p src/main/java src/test/java || die
- unzip -qq -d src/main/java ${P}-src.jar || die "unzip failed"
-
- # fix javadoc compilation
- if use doc ; then
- cp "${S}"/javadoc/stylesheet.css "${S}" || die
- fi
-
- rm -rf javadoc temp.hamcrest.source *.jar || die
- find . -name "*.class" -delete || die
-}
-
-src_compile() {
- eant build jars -Dhamcrestlib=$(java-pkg_getjars hamcrest-core) $(use_doc javadoc)
-}
-
-src_test() {
- mkdir classes || die
- cd junit/tests || die
- local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
- ejavac -sourcepath java -classpath ${cp} -d "${S}"/classes $(find . -name "*.java")
-
- cd "${S}"/classes || die
- for FILE in $(find . -name "AllTests\.class"); do
- local CLASS=$(echo ${FILE} | sed -e "s/\.class//" | sed -e "s%/%.%g" | sed -e "s/\.\.//")
- java -classpath .:${cp} org.junit.runner.JUnitCore ${CLASS} || die "Test ${CLASS} failed"
- done
-}
-
-src_install() {
- java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
- dodoc README.html doc/ReleaseNotes${PV}.txt || die
-
- use examples && java-pkg_doexamples org/junit/samples
- use source && java-pkg_dosrc src/main/java/org src/main/java/junit
-
- if use doc; then
- dohtml -r doc/*
- java-pkg_dojavadoc ${PN}${PV}/javadoc
- fi
-}
diff --git a/dev-java/junit/junit-4.8.2-r1.ebuild b/dev-java/junit/junit-4.8.2-r1.ebuild
deleted file mode 100644
index 4b6c76b91104..000000000000
--- a/dev-java/junit/junit-4.8.2-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.8.2-r1.ebuild,v 1.12 2013/02/05 06:48:08 zerochaos Exp $
-
-# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
-
-EAPI="3"
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple framework to write repeatable tests"
-SRC_URI="mirror://github/KentBeck/${PN}/${PN}${PV}.zip"
-HOMEPAGE="http://www.junit.org/"
-LICENSE="CPL-1.0"
-SLOT="4"
-KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-CDEPEND="dev-java/hamcrest-core:0"
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.5
- userland_GNU? ( >=sys-apps/findutils-4.3 )
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}${PV}"
-
-EANT_BUILD_TARGET="jars"
-
-src_unpack() {
- default
-
- # Unpack source JAR
- mkdir -p "${S}/src/main/java" "${S}/src/test/java" \
- || die "Unable to create source directories"
- pushd "${S}/src/main/java" >/dev/null
- jar xf "${S}/${P}-src.jar" || die "Unable to unpack sources."
- popd >/dev/null
-
- # copy Gentoo manifest to working directory
- cp "${FILESDIR}/gentoo-manifest.mf" "${S}" || die
-}
-
-java_prepare() {
- # fix javadoc compilation
- if use doc ; then
- cp "${S}"/javadoc/stylesheet.css "${S}" \
- || die "Unable to copy Javdoc stylesheet"
- fi
-
- # remove binary and other generated files
- rm -rf javadoc temp.hamcrest.source *.jar \
- || die "Unable to clean generated files."
- find . -name "*.class" -delete \
- || die "Unable to remove distributed class files"
-
- # Let Ant know where its hamcrest went
- EANT_EXTRA_ARGS="-Dhamcrestlib=$(java-pkg_getjars hamcrest-core)"
-
- # Add Gentoo manifest information to generated JAR files
- java-ant_xml-rewrite -f build.xml -c \
- -e jar -a manifest -v "gentoo-manifest.mf"
-}
-
-src_test() {
- mkdir classes || die "Unable to create build directory for tests"
-
- local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
- ejavac -classpath ${cp} -d classes $(find junit/tests -name "*.java")
-
- java -classpath ${cp}:classes org.junit.runner.JUnitCore junit.tests.AllTests \
- || die "Tests failed."
-}
-
-src_install() {
- java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
- dodoc README.html doc/ReleaseNotes${PV}.txt || die
-
- use examples && java-pkg_doexamples org/junit/samples
- use source && java-pkg_dosrc src/main/java/org src/main/java/junit
-
- if use doc; then
- dohtml -r doc/*
- java-pkg_dojavadoc ${PN}${PV}/javadoc
- fi
-}