summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-dotnet/ml-pnet/ChangeLog7
-rw-r--r--dev-dotnet/ml-pnet/files/digest-ml-pnet-0.7.43
-rw-r--r--dev-dotnet/ml-pnet/ml-pnet-0.7.4.ebuild27
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-dotnet/ml-pnet/ChangeLog b/dev-dotnet/ml-pnet/ChangeLog
index 16ba9edc646e..482876b8a918 100644
--- a/dev-dotnet/ml-pnet/ChangeLog
+++ b/dev-dotnet/ml-pnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/ml-pnet
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ChangeLog,v 1.25 2006/04/02 07:47:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ChangeLog,v 1.26 2006/08/06 02:10:23 tcort Exp $
+
+*ml-pnet-0.7.4 (06 Aug 2006)
+
+ 06 Aug 2006; Thomas Cort <tcort@gentoo.org> +ml-pnet-0.7.4.ebuild:
+ Version bump to 0.7.4 ; Bug #121110, Bug #118780.
02 Apr 2006; Bryan Østergaard <kloeri@gentoo.org metadata.xml:
Remove retired developer urilith from metadata.
diff --git a/dev-dotnet/ml-pnet/files/digest-ml-pnet-0.7.4 b/dev-dotnet/ml-pnet/files/digest-ml-pnet-0.7.4
new file mode 100644
index 000000000000..b397a08e73b5
--- /dev/null
+++ b/dev-dotnet/ml-pnet/files/digest-ml-pnet-0.7.4
@@ -0,0 +1,3 @@
+MD5 7ea52692236da9d3d48bafa6e7819b53 ml-pnet-0.7.4.tar.gz 4126354
+RMD160 246cc3dec6119d763173aec2b4fa55d2d35bb4f1 ml-pnet-0.7.4.tar.gz 4126354
+SHA256 3aa1ee861fc6f818749d96a3f5ec79a40841cc7cbb51b8265765f468c4a0ab98 ml-pnet-0.7.4.tar.gz 4126354
diff --git a/dev-dotnet/ml-pnet/ml-pnet-0.7.4.ebuild b/dev-dotnet/ml-pnet/ml-pnet-0.7.4.ebuild
new file mode 100644
index 000000000000..e98d94579ebb
--- /dev/null
+++ b/dev-dotnet/ml-pnet/ml-pnet-0.7.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ml-pnet-0.7.4.ebuild,v 1.1 2006/08/06 02:10:23 tcort Exp $
+
+DESCRIPTION="Mono C# libraries for Portable.NET"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="=dev-dotnet/pnetlib-${PV}*"
+
+src_compile() {
+ local lib_profile="framework1.1"
+ elog "Using profile: ${lib_profile}"
+
+ econf --with-profile=${lib_profile} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}