summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/enigma/ChangeLog6
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild5
-rw-r--r--games-puzzle/enigma/files/enigma-1.01-libpng15.patch11
3 files changed, 19 insertions, 3 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index a309059159d6..d0e63ea38eb2 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/enigma
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.50 2011/04/29 06:55:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.51 2011/09/15 02:16:23 ssuominen Exp $
+
+ 15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> enigma-1.01.ebuild,
+ +files/enigma-1.01-libpng15.patch:
+ Fix building with libpng15 wrt #378391 by Diego Elio Pettenò
29 Apr 2011; Tupone Alfredo <tupone@gentoo.org> enigma-1.01.ebuild,
+files/enigma-1.01-gcc46.patch:
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
index 9faa90292ca9..44ccada8a3ec 100644
--- a/games-puzzle/enigma/enigma-1.01.ebuild
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.15 2011/04/29 06:55:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.16 2011/09/15 02:16:23 ssuominen Exp $
EAPI=2
inherit autotools eutils games
@@ -32,7 +32,8 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-gcc46.patch \
- "${FILESDIR}"/${P}-xerces-c.patch
+ "${FILESDIR}"/${P}-xerces-c.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
eautoreconf
}
diff --git a/games-puzzle/enigma/files/enigma-1.01-libpng15.patch b/games-puzzle/enigma/files/enigma-1.01-libpng15.patch
new file mode 100644
index 000000000000..a6ce342bd168
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.01-libpng15.patch
@@ -0,0 +1,11 @@
+--- lib-src/enigma-core/IMG_SavePNG.c
++++ lib-src/enigma-core/IMG_SavePNG.c
+@@ -84,7 +84,7 @@
+ png_bytep *row_pointers = 0;
+
+ /* Set error handling. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ IMG_SetError("Error writing the PNG file");
+ }
+ else {