summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/bnc/ChangeLog8
-rw-r--r--net-irc/bnc/bnc-2.8.6.ebuild6
-rw-r--r--net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch26
3 files changed, 37 insertions, 3 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index acc564dbe701..e08bd19b9917 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bnc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.6 2004/01/06 02:04:37 weeve Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.7 2004/06/21 21:56:34 kloeri Exp $
+
+ 21 Jun 2004; Bryan Østergaard <kloeri@gentoo.org>
+ +files/bnc-2.8.6-gotofail-labelfix.patch, bnc-2.8.6.ebuild:
+ Add patch by redeeman <redeeman@metanurb.dk>, close bug #54689.
05 Jan 2004; Jason Wever <weeve@gentoo.org> bnc-2.8.6.ebuild:
Marked stable on sparc.
diff --git a/net-irc/bnc/bnc-2.8.6.ebuild b/net-irc/bnc/bnc-2.8.6.ebuild
index 46df777f93b7..3f4e8a51b528 100644
--- a/net-irc/bnc/bnc-2.8.6.ebuild
+++ b/net-irc/bnc/bnc-2.8.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6.ebuild,v 1.13 2004/05/28 02:57:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6.ebuild,v 1.14 2004/06/21 21:56:34 kloeri Exp $
+
+inherit eutils
MY_P=${P/-/}
DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
@@ -19,6 +21,8 @@ DEPEND="virtual/glibc"
S=${WORKDIR}/${MY_P}
src_compile() {
+ # fix gcc-3.4 compilation, bug #54689.
+ epatch ${FILESDIR}/bnc-2.8.6-gotofail-labelfix.patch
econf || die
emake || die
mv mkpasswd bncmkpasswd
diff --git a/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
new file mode 100644
index 000000000000..a4ced2e47223
--- /dev/null
+++ b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
@@ -0,0 +1,26 @@
+diff -Naur bnc2.8.6.orig/cmds.c bnc2.8.6/cmds.c
+--- bnc2.8.6.orig/cmds.c 2002-07-13 04:48:13.000000000 +0200
++++ bnc2.8.6/cmds.c 2004-06-21 23:32:49.057908144 +0200
+@@ -503,8 +503,8 @@
+ tprintf(&cptr->loc, "NOTICE AUTH :Docked session %i\n", dptr->srv.fd);
+ }
+ }
+- tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+ nodock:
++ tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+ }
+ tprintf(&cptr->loc, "NOTICE AUTH :type /quote help for basic list of commands and usage\n");
+ }
+@@ -1066,10 +1066,9 @@
+ vhost = vhost_ptr->vhost;
+ break;
+ }
+- }
+-vfast_fail:
++ }
+ }
+-
++vfast_fail:
+ res = inet_aton(vhost, &addr);
+ if(res == 1)
+ {