summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libcaca/ChangeLog7
-rw-r--r--media-libs/libcaca/libcaca-0.99_beta18.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/media-libs/libcaca/ChangeLog b/media-libs/libcaca/ChangeLog
index 31ea5e192aab..4e13bb555811 100644
--- a/media-libs/libcaca/ChangeLog
+++ b/media-libs/libcaca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libcaca
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaca/ChangeLog,v 1.103 2012/05/09 16:25:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaca/ChangeLog,v 1.104 2012/06/01 22:52:24 ssuominen Exp $
+
+ 01 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ libcaca-0.99_beta18.ebuild:
+ Use $(type -P gmcs) for exporting the CSC variable wrt #329651, Comment #8 by
+ Conway S. Smith
09 May 2012; Alexis Ballier <aballier@gentoo.org> libcaca-0.99_beta18.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/libcaca/libcaca-0.99_beta18.ebuild b/media-libs/libcaca/libcaca-0.99_beta18.ebuild
index 503e574b64ec..dae1b62a4d76 100644
--- a/media-libs/libcaca/libcaca-0.99_beta18.ebuild
+++ b/media-libs/libcaca/libcaca-0.99_beta18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaca/libcaca-0.99_beta18.ebuild,v 1.6 2012/05/09 16:25:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaca/libcaca-0.99_beta18.ebuild,v 1.7 2012/06/01 22:52:24 ssuominen Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -87,7 +87,7 @@ src_configure() {
append-cflags "$(java-pkg_get-jni-cflags)"
fi
- use mono && export CSC=gmcs #329651
+ use mono && export CSC="$(type -P gmcs)" #329651
export VARTEXFONTS="${T}/fonts" #44128
# python bindings are built via distutils
@@ -109,7 +109,7 @@ src_configure() {
src_compile() {
default
- if use python ; then
+ if use python; then
distutils_src_compile
fi
}
@@ -117,7 +117,7 @@ src_compile() {
src_install() {
default
- if use python ; then
+ if use python; then
distutils_src_install
fi
@@ -126,7 +126,7 @@ src_install() {
fi
rm -rf "${D}"/usr/share/java
- find "${D}" -name '*.la' -delete
+ find "${D}" -name '*.la' -exec rm -f {} +
}
pkg_postinst() {