summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/hardlink++/ChangeLog9
-rw-r--r--app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch13
-rw-r--r--app-arch/hardlink++/hardlink++-0.02.ebuild32
3 files changed, 23 insertions, 31 deletions
diff --git a/app-arch/hardlink++/ChangeLog b/app-arch/hardlink++/ChangeLog
index 4b7eef40e585..ec16a047805d 100644
--- a/app-arch/hardlink++/ChangeLog
+++ b/app-arch/hardlink++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/hardlink++
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/ChangeLog,v 1.5 2008/12/11 21:05:44 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/ChangeLog,v 1.6 2012/05/19 10:42:23 ssuominen Exp $
+
+ 19 May 2012; Samuli Suominen <ssuominen@gentoo.org> hardlink++-0.02.ebuild,
+ -files/hardlink++-0.02-sane-makefile.patch:
+ Punt useless Makefile and rewrite src_compile() wrt #337250 by Diego Elio
+ Pettenò
11 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+files/hardlink++-0.02-gcc-43-compile-fix.patch, hardlink++-0.02.ebuild:
diff --git a/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch b/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch
deleted file mode 100644
index b81ac3375b07..000000000000
--- a/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Nuar hardlink++-0.02.orig/Makefile hardlink++-0.02/Makefile
---- hardlink++-0.02.orig/Makefile 2003-08-14 12:59:21.000000000 -0700
-+++ hardlink++-0.02/Makefile 2005-01-29 20:00:47.618746992 -0800
-@@ -1,2 +1,7 @@
--hardlink++: hardlink.cpp hardlink.h
-- g++ -Wall -o hardlink++ hardlink.cpp
-+CXX := g++
-+CXXFLAGS :=
-+BIN := hardlink++
-+SRC := hardlink.cpp
-+
-+$(BIN): $(SRC)
-+ $(CXX) -Wall $(CXXFLAGS) -o $@ $^
diff --git a/app-arch/hardlink++/hardlink++-0.02.ebuild b/app-arch/hardlink++/hardlink++-0.02.ebuild
index 68cd3a73ac9e..58923780fad0 100644
--- a/app-arch/hardlink++/hardlink++-0.02.ebuild
+++ b/app-arch/hardlink++/hardlink++-0.02.ebuild
@@ -1,32 +1,32 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/hardlink++-0.02.ebuild,v 1.4 2008/12/11 21:05:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/hardlink++-0.02.ebuild,v 1.5 2012/05/19 10:42:23 ssuominen Exp $
-inherit eutils
-DESCRIPTION="Save disk space by hardlinking identical files."
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Save disk space by hardlinking identical files"
HOMEPAGE="http://www.sodarock.com/hardlink/"
-SRC_URI="${HOMEPAGE}/${P}.tgz"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="sys-devel/gcc"
-RDEPEND=""
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc34-optimize-help.patch || die
- epatch "${FILESDIR}"/${P}-sane-makefile.patch || die
- epatch "${FILESDIR}"/${P}-gcc-43-compile-fix.patch || die
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc34-optimize-help.patch \
+ "${FILESDIR}"/${P}-gcc-43-compile-fix.patch
+
+ rm -f Makefile
}
src_compile() {
- # no configure
- emake CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+ $(tc-getCXX) ${LDFLAGS} ${CXXFLAGS} hardlink.cpp -o ${PN}
}
src_install() {
- into /usr
- dobin hardlink++
+ dobin ${PN}
dodoc README
}