summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/smartmontools/ChangeLog6
-rw-r--r--sys-apps/smartmontools/files/smartd.rc7
-rw-r--r--sys-apps/smartmontools/smartmontools-5.33.ebuild11
3 files changed, 16 insertions, 8 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 83dbb000d80c..df73863cd55f 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.36 2005/01/02 23:52:22 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.37 2005/01/03 14:18:58 vapier Exp $
+
+ 03 Jan 2005; Mike Frysinger <vapier@gentoo.org> files/smartd.rc,
+ smartmontools-5.33.ebuild:
+ Update docs #76337 by Daniel Holth.
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/sys-apps/smartmontools/files/smartd.rc b/sys-apps/smartmontools/files/smartd.rc
index c4a5c3c79381..a0cfa4a404f2 100644
--- a/sys-apps/smartmontools/files/smartd.rc
+++ b/sys-apps/smartmontools/files/smartd.rc
@@ -1,14 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.4 2004/10/10 01:19:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.5 2005/01/03 14:18:58 vapier Exp $
opts="${opts} reload"
checkconfig() {
if [ ! -f "/etc/smartd.conf" ] ; then
eerror "You should setup your /etc/smartd.conf file!"
- eerror "See sample conf: /etc/smartd.conf.example"
+ eerror "See the smartd.conf(5) manpage."
return 1
fi
return 0
@@ -18,8 +18,7 @@ start() {
checkconfig || return 1
ebegin "Starting S.M.A.R.T. monitoring daemon"
- start-stop-daemon --start --exec /usr/sbin/smartd \
- -- -p /var/run/smartd.pid ${SMARTD_OPTS}
+ /usr/sbin/smartd -p /var/run/smartd.pid ${SMARTD_OPTS}
eend $?
}
diff --git a/sys-apps/smartmontools/smartmontools-5.33.ebuild b/sys-apps/smartmontools/smartmontools-5.33.ebuild
index 18b9d8e13451..4e097fa6d443 100644
--- a/sys-apps/smartmontools/smartmontools-5.33.ebuild
+++ b/sys-apps/smartmontools/smartmontools-5.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.33.ebuild,v 1.2 2005/01/02 23:52:22 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.33.ebuild,v 1.3 2005/01/03 14:18:58 vapier Exp $
DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
HOMEPAGE="http://smartmontools.sourceforge.net/"
@@ -11,14 +11,19 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE=""
+RDEPEND=""
+DEPEND=">=sys-apps/portage-2.0.51"
+
src_install() {
dosbin smart{ctl,d} || die "dosbin"
doman *.[58]
dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
+ newdoc smartd.conf smartd.conf.example
insinto /etc
doins smartd.conf
- exeinto /etc/init.d; newexe ${FILESDIR}/smartd.rc smartd
- insinto /etc/conf.d; newins ${FILESDIR}/smartd.confd smartd
+ dodir /etc/init.d /etc/conf.d
+ newinitd ${FILESDIR}/smartd.rc smartd
+ newconfd ${FILESDIR}/smartd.confd smartd
}