summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/alexandria/ChangeLog8
-rw-r--r--app-misc/alexandria/alexandria-0.6.5.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index c66cf1740cc7..249757e2816b 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.31 2009/08/24 18:44:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.32 2009/08/24 18:55:17 fauli Exp $
+
+*alexandria-0.6.5 (24 Aug 2009)
+
+ 24 Aug 2009; Christian Faulhammer <fauli@gentoo.org>
+ +alexandria-0.6.5.ebuild:
+ version bump
24 Aug 2009; Hans de Graaff <graaff@gentoo.org> -alexandria-0.5.1.ebuild:
Remove old version that still depended on the now gone
diff --git a/app-misc/alexandria/alexandria-0.6.5.ebuild b/app-misc/alexandria/alexandria-0.6.5.ebuild
new file mode 100644
index 000000000000..9d8daa7b253a
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.5.ebuild,v 1.1 2009/08/24 18:55:17 fauli Exp $
+
+inherit gnome2 ruby
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="evo"
+
+DOCS="ChangeLog README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.16.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/imagesize-0.1.1
+ dev-ruby/hpricot
+ evo? ( >=dev-ruby/revolution-0.5 )"
+
+DEPEND=">=dev-lang/ruby-1.8.0
+ app-text/scrollkeeper
+ dev-ruby/rake"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-rakefile.patch"
+)
+
+src_compile() {
+ rake || die
+}
+
+src_install() {
+ export PREFIX="${D}/usr"
+ rake install || die
+
+ [ -n "${DOCS}" ] && dodoc ${DOCS}
+
+ # Move the installed docs to the gentoo standard directory
+ for doc in "${D}/usr/share/doc/alexandria/*"
+ do
+ dodoc $doc
+ done
+ rm -rf "${D}/usr/share/doc/alexandria"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+
+ echo
+ elog "To enable some book providers you will need to emerge"
+ elog "additional packages:"
+ echo
+ elog " For the Deastore book provider:"
+ elog " dev-ruby/htmlentities"
+ echo
+ elog " For Z39.50 support and the Library of Congress and"
+ elog " British Library book proviers:"
+ elog " dev-ruby/ruby-zoom"
+}