summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/octave-2.1.57-r1.ebuild6
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 365aac511cf9..29a195a83859 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.45 2007/02/22 01:31:22 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.46 2007/03/16 22:38:28 kugelfang Exp $
+
+ 16 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57-r1.ebuild,
+ octave-2.1.69.ebuild:
+ QA: which -> type -P
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-mathematics/octave/octave-2.1.57-r1.ebuild b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
index 1c15c23d286a..8f00ed1b7c89 100644
--- a/sci-mathematics/octave/octave-2.1.57-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.8 2006/01/29 19:40:31 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.9 2007/03/16 22:38:28 kugelfang Exp $
inherit flag-o-matic
@@ -31,7 +31,7 @@ DEPEND="virtual/libc
# more information
pkg_setup() {
- use ifc || if [ -z `which g77` ]; then
+ use ifc || if [[ -z $(type -P g77) ]]; then
#if ifc is defined then the dep was already checked
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index 7bf3e63c0858..cfabbd998e18 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.9 2006/01/29 19:39:33 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.10 2007/03/16 22:38:28 kugelfang Exp $
inherit flag-o-matic
@@ -33,7 +33,7 @@ DEPEND="virtual/libc
# more information
pkg_setup() {
- use ifc || if [ -z `which g77` ]; then
+ use ifc || if [[ -z $(type -P g77) ]]; then
#if ifc is defined then the dep was already checked
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"