summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/traceproto/ChangeLog11
-rw-r--r--net-analyzer/traceproto/files/traceproto-1.1.1-fix-warnings.diff59
-rw-r--r--net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch17
-rw-r--r--net-analyzer/traceproto/files/traceproto-1.1.2_beta1.patch112
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.1.ebuild37
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild41
6 files changed, 45 insertions, 232 deletions
diff --git a/net-analyzer/traceproto/ChangeLog b/net-analyzer/traceproto/ChangeLog
index 3eba23f9b40f..ba28e607d6c5 100644
--- a/net-analyzer/traceproto/ChangeLog
+++ b/net-analyzer/traceproto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/traceproto
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/ChangeLog,v 1.7 2008/10/09 20:40:58 flameeyes Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/ChangeLog,v 1.8 2014/07/17 22:05:37 jer Exp $
+
+ 17 Jul 2014; Jeroen Roovers <jer@gentoo.org> -traceproto-1.1.1.ebuild,
+ traceproto-1.1.2_beta1.ebuild, -files/traceproto-1.1.1-fix-warnings.diff,
+ +files/traceproto-1.1.2_beta1-tinfo.patch,
+ -files/traceproto-1.1.2_beta1.patch:
+ EAPI bump. Undo patch that makes sys-libs/ncurses optional. Fix building
+ against sys-libs/ncurses[tinfo].
09 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
traceproto-1.1.2_beta1.ebuild:
diff --git a/net-analyzer/traceproto/files/traceproto-1.1.1-fix-warnings.diff b/net-analyzer/traceproto/files/traceproto-1.1.1-fix-warnings.diff
deleted file mode 100644
index 1882436fd3bf..000000000000
--- a/net-analyzer/traceproto/files/traceproto-1.1.1-fix-warnings.diff
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -urN traceproto-1.1.1.orig/tp_packet.c traceproto-1.1.1/tp_packet.c
---- traceproto-1.1.1.orig/tp_packet.c 2005-01-31 01:03:57.248742848 -0500
-+++ traceproto-1.1.1/tp_packet.c 2005-01-31 01:06:39.184124928 -0500
-@@ -103,7 +103,7 @@
- state.low_ttl = YES;
-
- // tcp_hdr = ( struct libnet_tcp_hdr * ) & raw_packet[ 0 ];
-- tcp_hdr = ( struct libnet_tcp_hdr * ) tp_align ( raw_packet,
-+ tcp_hdr = ( struct libnet_tcp_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_tcp_hdr ) );
-
-@@ -165,7 +165,7 @@
- state.low_ttl = YES;
-
- // udp_hdr = ( struct libnet_udp_hdr * ) & raw_packet[ 0 ];
-- udp_hdr = ( struct libnet_udp_hdr * ) tp_align ( raw_packet,
-+ udp_hdr = ( struct libnet_udp_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_udp_hdr ) );
-
-@@ -268,12 +268,12 @@
- * off of the packet
- */
- // eth_hdr = ( struct libnet_802_3_hdr * ) raw_packet;
-- eth_hdr = ( struct libnet_802_3_hdr * ) tp_align ( raw_packet,
-+ eth_hdr = ( struct libnet_802_3_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_802_3_hdr ) );
-
- // state.ip_hdr = ( struct libnet_ipv4_hdr * ) & raw_packet[ eth_offset ];
-- state.ip_hdr = ( struct libnet_ipv4_hdr * ) tp_align ( raw_packet,
-+ state.ip_hdr = ( struct libnet_ipv4_hdr * ) tp_align ( (char *)raw_packet,
- eth_offset,
- sizeof ( struct libnet_ipv4_hdr ) );
-
-@@ -294,19 +294,19 @@
- {
- case IPPROTO_ICMP:
- // return parse_icmp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] );
-- return parse_icmp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_icmp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_icmpv4_hdr ) ) );
- break;
- case IPPROTO_TCP:
- // return parse_tcp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] );
-- return parse_tcp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_tcp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_tcp_hdr ) ) );
- break;
- case IPPROTO_UDP:
- // return parse_udp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] );
-- return parse_udp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_udp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_udp_hdr ) ) );
- break;
diff --git a/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch
new file mode 100644
index 000000000000..383daaefd78b
--- /dev/null
+++ b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,9 +182,11 @@
+ AC_CHECK_LIB(pcap, pcap_open_live, , AC_MSG_ERROR([ERROR - pcap check failed]))
+ AC_CHECK_LIB(net, libnet_init, , AC_MSG_ERROR([ERROR - libnet check failed]))
+ AC_CHECK_LIB(cap, cap_init, , AC_MSG_WARN([libcap check failed]))
+-AC_CHECK_LIB(ncurses, initscr, , AC_MSG_WARN([ncurses check failed]))
+-AC_CHECK_LIB(curses, initscr, , AC_MSG_WARN([curses check failed]))
+-AC_CHECK_LIB(termcap, tgetent)
++PKG_CHECK_MODULES(ncurses,ncurses,
++ LIBS="$LIBS $ncurses_LIBS"
++ AC_DEFINE([HAVE_NCURSES_H], 1, [We have ncurses headers])
++ AC_DEFINE([HAVE_LIBNCURSES], 1, [We have ncurses libraries]),
++ AC_MSG_ERROR([ncurses check failed]))
+ if test "x$dmalloc_test" = "xyes"; then
+ AC_CHECK_LIB(dmalloc, malloc, ,AC_MSG_RESULT([dmalloc unavailable]))
+ fi
diff --git a/net-analyzer/traceproto/files/traceproto-1.1.2_beta1.patch b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1.patch
deleted file mode 100644
index ba111e6391b3..000000000000
--- a/net-analyzer/traceproto/files/traceproto-1.1.2_beta1.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-diff -ru traceproto-1.1.2beta1~/configure.ac traceproto-1.1.2beta1/configure.ac
---- traceproto-1.1.2beta1~/configure.ac 2006-12-17 16:36:48.000000000 +0100
-+++ traceproto-1.1.2beta1/configure.ac 2006-12-17 17:08:01.000000000 +0100
-@@ -167,11 +167,20 @@
- AC_ARG_ENABLE([dmalloc],
- [[ --enable-dmalloc Use the dmalloc library for debugging]],
- [
-- dmalloc_test=yes
-- AC_MSG_RESULT([requested])
-+ dmalloc_test=$enableval
- ],
- [
-- AC_MSG_RESULT([not requested])
-+ dmalloc_test=no
-+ ]
-+)
-+AC_MSG_CHECKING(for ncurses)
-+AC_ARG_ENABLE([ncurses],
-+ [[ --enable-ncurses Use the ncurses library]],
-+ [
-+ ncurses_test=$enableval
-+ ],
-+ [
-+ ncurses_test=no
- ]
- )
-
-@@ -182,8 +191,10 @@
- AC_CHECK_LIB(pcap, pcap_open_live, , AC_MSG_ERROR([ERROR - pcap check failed]))
- AC_CHECK_LIB(net, libnet_init, , AC_MSG_ERROR([ERROR - libnet check failed]))
- AC_CHECK_LIB(cap, cap_init, , AC_MSG_WARN([libcap check failed]))
--AC_CHECK_LIB(ncurses, initscr, , AC_MSG_WARN([ncurses check failed]))
--AC_CHECK_LIB(curses, initscr, , AC_MSG_WARN([curses check failed]))
-+if test "x$ncurses_test" = "xyes"; then
-+ AC_CHECK_LIB(ncurses, initscr, , AC_MSG_WARN([ncurses check failed]))
-+ AC_CHECK_LIB(curses, initscr, , AC_MSG_WARN([curses check failed]))
-+fi
- AC_CHECK_LIB(termcap, tgetent)
- if test "x$dmalloc_test" = "xyes"; then
- AC_CHECK_LIB(dmalloc, malloc, ,AC_MSG_RESULT([dmalloc unavailable]))
-@@ -191,8 +202,10 @@
-
- # Checks for header files.
- AC_HEADER_STDC
--AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h stdlib.h string.h sys/time.h unistd.h ncurses.h])
--AC_CHECK_HEADERS([ncurses.h ncurses/ncurses.h curses.h])
-+AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h stdlib.h string.h sys/time.h unistd.h])
-+if test "x$ncurses_test" = "xyes"; then
-+ AC_CHECK_HEADERS([ncurses.h ncurses/ncurses.h curses.h])
-+fi
- if test "x$dmalloc_test" = "xyes"; then
- AC_CHECK_HEADERS([dmalloc.h])
- fi
-diff -ru traceproto-1.1.2beta1~/tp_packet.c traceproto-1.1.2beta1/tp_packet.c
---- traceproto-1.1.2beta1~/tp_packet.c 2006-12-17 16:36:48.000000000 +0100
-+++ traceproto-1.1.2beta1/tp_packet.c 2006-12-17 16:39:50.000000000 +0100
-@@ -104,7 +104,7 @@
- state.low_ttl = YES;
-
- /* tcp_hdr = ( struct libnet_tcp_hdr * ) & raw_packet[ 0 ]; */
-- tcp_hdr = ( struct libnet_tcp_hdr * ) tp_align ( raw_packet,
-+ tcp_hdr = ( struct libnet_tcp_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_tcp_hdr ) );
-
-@@ -171,7 +171,7 @@
- state.low_ttl = YES;
-
- /* udp_hdr = ( struct libnet_udp_hdr * ) & raw_packet[ 0 ]; */
-- udp_hdr = ( struct libnet_udp_hdr * ) tp_align ( raw_packet,
-+ udp_hdr = ( struct libnet_udp_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_udp_hdr ) );
-
-@@ -289,12 +289,12 @@
- * off of the packet
- */
- /* eth_hdr = ( struct libnet_802_3_hdr * ) raw_packet; */
-- eth_hdr = ( struct libnet_802_3_hdr * ) tp_align ( raw_packet,
-+ eth_hdr = ( struct libnet_802_3_hdr * ) tp_align ( (char *)raw_packet,
- 0,
- sizeof ( struct libnet_802_3_hdr ) );
-
- /* state.ip_hdr = ( struct libnet_ipv4_hdr * ) & raw_packet[ eth_offset ]; */
-- state.ip_hdr = ( struct libnet_ipv4_hdr * ) tp_align ( raw_packet,
-+ state.ip_hdr = ( struct libnet_ipv4_hdr * ) tp_align ( (char *)raw_packet,
- eth_offset,
- sizeof ( struct libnet_ipv4_hdr ) );
-
-@@ -315,19 +315,19 @@
- {
- case IPPROTO_ICMP:
- /* return parse_icmp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] ); */
-- return parse_icmp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_icmp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_icmpv4_hdr ) ) );
- break;
- case IPPROTO_TCP:
- /* return parse_tcp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] ); */
-- return parse_tcp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_tcp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_tcp_hdr ) ) );
- break;
- case IPPROTO_UDP:
- /* return parse_udp_packet ( ( const u_char * ) & raw_packet [ ipv4_offset ] ); */
-- return parse_udp_packet ( ( const u_char * ) tp_align ( raw_packet,
-+ return parse_udp_packet ( ( const u_char * ) tp_align ( (char *)raw_packet,
- ipv4_offset,
- sizeof ( struct libnet_udp_hdr ) ) );
- break;
diff --git a/net-analyzer/traceproto/traceproto-1.1.1.ebuild b/net-analyzer/traceproto/traceproto-1.1.1.ebuild
deleted file mode 100644
index 2715fc5f84c0..000000000000
--- a/net-analyzer/traceproto/traceproto-1.1.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/traceproto-1.1.1.ebuild,v 1.5 2007/03/22 14:43:13 vanquirius Exp $
-
-inherit eutils
-
-DESCRIPTION="A traceroute-like utility that sends packets based on protocol"
-HOMEPAGE="http://traceproto.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE="debug ncurses"
-
-RDEPEND=">=net-libs/libnet-1.1.0
- net-libs/libpcap
- ncurses? ( sys-libs/ncurses )
- debug? ( dev-libs/dmalloc )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-fix-warnings.diff
-}
-
-src_compile() {
- local myconf
- use debug && myconf="--enable-dmalloc"
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO INSTALL
-}
diff --git a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
index 1196a1691052..dbeac84e7d3b 100644
--- a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
+++ b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild,v 1.3 2008/10/09 20:40:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild,v 1.4 2014/07/17 22:05:37 jer Exp $
+EAPI=5
inherit eutils autotools
MY_PV=${PV/_/}
@@ -13,32 +14,28 @@ SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE="debug ncurses"
+IUSE="debug"
-RDEPEND=">=net-libs/libnet-1.1.0
+RDEPEND="
+ net-libs/libnet:1.1
net-libs/libpcap
- ncurses? ( sys-libs/ncurses )
- debug? ( dev-libs/dmalloc )"
-DEPEND="${RDEPEND}"
+ sys-libs/ncurses
+ debug? ( dev-libs/dmalloc )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen[dot]
+"
S=${WORKDIR}/${PN}-${MY_PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}.patch
- eautoreconf
-}
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
-src_compile() {
- econf \
- $(use_enable debug dmalloc) \
- $(use_enable ncurses) \
- || die "econf failed"
- emake || die "emake failed"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+src_configure() {
+ econf $(use_enable debug dmalloc)
}