summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/jpeg/ChangeLog7
-rw-r--r--media-libs/jpeg/jpeg-8d-r2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index d6b939a0d6a7..a8c9deee1b65 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/jpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.166 2014/06/09 23:22:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.167 2014/08/21 11:56:52 ssuominen Exp $
+
+*jpeg-8d-r2 (21 Aug 2014)
+
+ 21 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> +jpeg-8d-r2.ebuild:
+ Special SLOT="8" to install only libjpeg.so.8 SONAME
09 Jun 2014; Mike Frysinger <vapier@gentoo.org> jpeg-6b-r12.ebuild,
jpeg-8d-r1.ebuild:
diff --git a/media-libs/jpeg/jpeg-8d-r2.ebuild b/media-libs/jpeg/jpeg-8d-r2.ebuild
new file mode 100644
index 000000000000..82f9b84a413e
--- /dev/null
+++ b/media-libs/jpeg/jpeg-8d-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-8d-r2.ebuild,v 1.1 2014/08/21 11:56:52 ssuominen Exp $
+
+EAPI=5
+
+# this ebuild is only for the libjpeg.so.8 SONAME for ABI compat
+
+inherit eutils libtool toolchain-funcs multilib-minimal
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz"
+
+LICENSE="IJG"
+SLOT="8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!=media-libs/jpeg-8*:0
+ !<media-libs/libjpeg-turbo-1.3.0-r2
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+DOCS=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch \
+ "${FILESDIR}"/${P}-CVE-2013-6629.patch
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Fix building against this library on eg. Solaris and DragonFly BSD, see:
+ # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
+ local ldverscript=
+ [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --enable-maxmem=64 \
+ ${ldverscript}
+}
+
+multilib_src_compile() {
+ emake libjpeg.la
+}
+
+multilib_src_install() {
+ newlib.so .libs/libjpeg.so.8.4.0 libjpeg.so.8
+}