summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/kgcc64/ChangeLog7
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.6.ebuild20
2 files changed, 15 insertions, 12 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index 1275dee11a1d..e950f9a15980 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.2 2006/07/17 06:03:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.3 2006/08/01 05:44:10 kumba Exp $
+
+ 02 Aug 2006; Joshua Kinard <kumba@gentoo.org> kgcc64-3.4.6.ebuild:
+ The beginning of the end for sys-devel/mips64 draws near. Mark kgcc64 stable
+ on mips, and update it to use v4 of the r10k cache barriers patchset. It'll
+ replace sys-devel/gcc-mips64 soon.
*kgcc64-4.1.1 (17 Jul 2006)
*kgcc64-3.4.6 (17 Jul 2006)
diff --git a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
index 56fab43c9cea..e6b773f16875 100644
--- a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.1 2006/07/17 06:03:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.2 2006/08/01 05:44:10 kumba Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -22,7 +22,7 @@ inherit toolchain eutils
DESCRIPTION="64bit kernel compiler"
-KEYWORDS="-* ~hppa ~mips ~ppc ~s390 ~sparc ~x86"
+KEYWORDS="-* ~hppa mips ~ppc ~s390 ~sparc ~x86"
# unlike every other target, hppa has not unified the 32/64 bit
# ports in binutils yet
@@ -39,21 +39,19 @@ src_unpack() {
# Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
# -mtune=r10000 support to gcc (Allows the compiler to generate code to
# take advantage of R10k's second ALU, perform shifts, etc..
- #
- # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
- # This is a very special patch -- it allows us to build semi-usable kernels
- # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
- # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
- # but for our purposes of building a kernel, it works.
+ # This is a very special patch -- it allows us to build kernels on SGI IP28
+ # (Indigo2 Impact R10000) systems.
# Unless you're building an IP28 kernel, you really don't need care about what
# this patch does, because if you are, you are probably already aware of what
# it does.
# All that said, the abilities of this patch are disabled by default and need
- # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
- # There is the possibility it may be used for very specific userland apps too.
- epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
+ # to be enabled by passing -mr10k-cache-barrier.
+ # The option also accepts a flag, which are highlighted below:
+ # -mr10k-cache-barrier=1 - Protect stores only (IP28)
+ # -mr10k-cache-barrier=2 - Protect stores and loads (IP32 R10K)
+ epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
;;
esac
}